1. Are you ready for the Galaxy S20? Here is everything we know so far!

WORKING soft brick fix for ZTE Force!

Discussion in 'Android Devices' started by bumtnate, Aug 3, 2013.

  1. bumtnate

    bumtnate Newbie
    Thread Starter

    holy HELL!! i figured out WORKING soft brick fix for the zte force!! it requires the avid root 4g made by osiris. thank u osiris! This is for those that still have stock recovery and are stuck in a bootloop or at the android screen and wont boot. heres the steps 1. first make sure no drivers at all are installed. 2. plug in phone to computer and boot it up. even though its not gonna fully boot, its going to give you the option to install usb handset drivers. do the automated install and let them install. 3. open up zte avid4g root folder made by osiris. you need to locate or download fastboot.exe and place it in the folder. also you will need to download the cwm recovery img which is located in the forums unzip it and place it in the zte avid root folder as well. ill try and post the link. 4. hold power button and volume up key at same time and boot into FTM mode 5. cd over to the directory of your avid root folder in ADB 6. type adb devices and you should see a question mark , its because it doesnt recognize it. now we need to get into the zte force bootloader (which is black screen) so type adb reboot bootloader. FROM HERE ON ITS VERY IMPORTANT U FOLLOW THE DIRECTIONS EXACTLY AS I WRITE THEM OR THIS WONT WORK. 7. type fastboot flash recovery recovery.img 8. its going to say waiting for device. now go to device manager and you should see an unknown android device with and exclamation mark on it right click on it and browse for drivers . you want to pick the one that sais zte adb composite device. now install the drivers. bypass the warning and all that 9. it should now recognize the zte force long enough to push the recovery image over to the phone. ALL DONE 10. the screen will still be black because zte force bootloader is a mystery in and of itself. but just pull battery and reboot into recovery and you should now see cwm recovery. ..11. pick your rom which only one is available right now and flash away. :) any questions or additional help. post them in the thread.


    Kraze lewis, ZTE Force and bcrichster like this.
  2. Best Answer:
    Post #45 by knoober, Dec 17, 2015 (1 points)
  3. sonicbluemustang

    sonicbluemustang Android Enthusiast

    Very interesting, Glad you got your phone working again. :)
  4. thescaryboy

    thescaryboy Lurker

    How can I get those files?, can you attch?
  5. thescaryboy

    thescaryboy Lurker

    Help..... I did pasy by past but...
    When the phone get bootloader mode, Pc doesnt reconize
  6. junkie2100

    junkie2100 Android Expert

    you have to manually force the lernel debug drivers for a fastboot connection. ive written a pretty good tutorial on.the subject in the warp sequent section

    also fastboot has compications with some usb standards, 2.0 seems to be the most reliable, 1.x and 3.0 are flaky at best
    ZTE Force likes this.
  7. htcphan

    htcphan Newbie

    How can we complete step #4 if we are stuck on android logo. It will not go to ftm
  8. junkie2100

    junkie2100 Android Expert

    if it cant go to ftm then you did serious damage to the bootloader or recovery partition. you screwed yourself basically. but most can get to ftm by pulling the battery, then holding up volume and power to turn it on, the same basic procedure for getting into recovery just a different vol direction. if you just turn the phone on then yea itll get stuck... its trying to boot android normally and cant kuz android is broken
  9. junkie2100

    junkie2100 Android Expert

    ftm gets erased with cwm installation mind you but if you have cwm thats even better and easier
  10. MidshipAc

    MidshipAc Well-Known Member

    so if we cant get step 4 its bricked right?
    Theres no more hope?
  11. junkie2100

    junkie2100 Android Expert

    pretty much. if you break both recovery and rom/boot at the same time, paperweight, if you break the bootloader partitions, paperweight. no coming back on the force. we attempted a fix but it only works on newer models sadly
  12. ZTE Force

    ZTE Force Newbie

    I was flashing JB on this Boost ICS phone from the stock sprint post. Anyway I rooted the touch CWM backed up ok but when I used recovery and flashed JB I got stuck in a bootloop!

    So I need to
    1.find flashboot.exe somewhere + a guide?
    2.get rid of the drivers which keep reinstalling on their own
    3.get windows to stabilize so I can ADB or something to boot the brick

    Any suggestions would be greatly appreciated... your thanks in advance
  13. ZTE Force

    ZTE Force Newbie

    ok the device manager no longer recognizes >android phone>ZTE Handset
    it now shows >android phone>Handset ADB Interface
    That's good right? N9100 is no longer showing up in Explorer

    but in CMD mode "adb reboot-bootloader" gets a error:device not found
    so I need to force the drivers per Junkie2100 http://androidforums.com/warp-seque...ide-checking-your-drivers-adb-connection.html ---> right now the driver its using is WinUSB.sys + 2 dll's

    That's incorrect cuz connectionchecker.bat wont list a S/N and a device name

    Any tips ??
  14. ZTE Force

    ZTE Force Newbie

    from the terminal prompt in windows type
    adb usb
    adb shell
    reboot recovery

    and voila CWM now appears on phone.... Things are looking much better
    But I cant get it to mount USB storage to upload my backup off the PC
    any clues?
  15. ZTE Force

    ZTE Force Newbie

    I loaded the driver ---> ZTE kernal debug interface (Yellow !) in DM
    the Handset adb Interface now has a ZTE in front of it (OK)
    BUT NOW i've gone full circle and CWM wont run from ADB shell anymore ....grrrr!
  16. ZTE Force

    ZTE Force Newbie

    Hello ... is there anybody out there...
    Here's what's happening out there folks...
    got fastboot running in CMD teminal (since ADB won't recognize device anymore)

    fastboot reboot-bootloader
    fastboot erase boot
    fastboot flash boot boot.img

    sending 'boot' (16384kb)
    ok writing 'boot'
    FAILED (remote: size too large)

    Now What's up with that?
  17. ZTE Force

    ZTE Force Newbie

    NO don't pull the battery WRONG !! Simply type flashboot reboot recovery
    thats a good way to screw yourself

    Flashboot no longer recognizes the device
    Anybody know how to get a boot.img flashed from here
  18. cdonkey

    cdonkey Lurker

    if you can get to cwm and you are able to use adb on your computer then you should be able to use sideload to reinstall a stock rom from there that would include a boot.img file. i was having the same issue with trying to flash a new boot.img not sure how to fix that though http://androidforums.com/force-4g-lte-all-things-root/871825-help-possibly-bricked.html you could try looking here these guys helped me figure out how to fix mine the other day
  19. ZTE Force

    ZTE Force Newbie

    Anyway still can get ADB to work on the PC and CWM recovery on the phone
    I need to push my backup over from the PC to the phone and adb push doesn't have the write permissions to do it ie. my SD card only has room for 1 ROM at a time and windows explorer doesn't have the correct drivers anymore.

    I have in device mgr: Handset ADB interface -- working
    ZTE Composite interface -- yellow!
    ZTE Kernal Debug interface -- yellow!

    If I fart around some more I could get fastboot instead of ADB but why?
    This has got to be easier than it's been going

    CDonkey explain sideload or ODIN more pls
    I was in sideload once tonight from CWM but chickened out
  20. knoober

    knoober Android Enthusiast

    Sideload worked pretty well for me. Have cmd prompt open, then navigate to Sideload in cwm, and follow the prompt. It gives the correct syntax in cwm ( I believe adb Sideload <filename. Zip>) there is an option I cwm to toggle signature verification if you need. Otherwise (and for the thousandth time in these forums there are smarter folks who could give better advice) i wonder if manually loading a backup from your pc to sd card wouldn't be the way to go. Hope this helps
    ZTE Force likes this.
  21. ZTE Force

    ZTE Force Newbie

    Yes thats all I need to do however
    I have a CWM 1970.1.2.3.etc folder of my backup right, but on the PC
    Can i just make a zip in windows of that to terminal over from the PC
    c:\ adb sideload 1970.1.2.etc.ZIP
    the phone boots into CWM fine... but it bootloops my 4.1.2 stock ROM from shinru2004
    which i flashed as a backup right out of CWM ... guess i got a dirty flash or something but would like to do it again the right way ... with a little help from my friends

    I used to just use explorer to manually move around backups from phone to PC
  22. knoober

    knoober Android Enthusiast

    I don't think you can just zip a backup and flash it. And I'm not sure you can Sideload a backup, I think it must be a flashable zip. There's more to it than that. I've seen tutorials but they're a bit over my head. SuperR has a deodexed debloayed rom in this forum that worked great for me. So for clarification are you boot looping (where it gets stuck in the boot process and tries to continuously reboot) or is it continuously booting to recovery? I think each may signify a different approach to fixing. But I'm afraid to say that if flashing back to stock doesn't work then you will have to wait for someone with better knowledge. The fact that recovery is working is to your advantage though. Good luck.

    EDIT: hold on a sec, you're using the 4.1.2 stock from shinru? Try the one from SuperR. Force runs 4.0.4 natively ( I guess it depends on your carrier Sprint did 4.1.2 but I don't think any other carrier did.) i think that versions of cwm and the rom have to be compatible as well. I'd be curious if that makes a difference. Once again good luck
  23. ZTE Force

    ZTE Force Newbie

    PC cmd> ADB sidelload 1970.xyz.zip gives the following error
    * cannot read 'sideload' *

    where I just zipped the CWM backup folder of the "good" rom 1970xyz I had working for a few weeks was moved off the phone over to the PC to make space on the SDCard

    The phone boots into CWM fine volume down and into bootloader( i think)volume up ... but it bootloops my 4.1.2 stock ROM from shinru2004 simple power on ever since I did...the following

    The shinru2004 ROM was flashed as a backup folder right out of CWM ... probably why i'm in this mess to begin with

    Originally used to just use explorer to manually move around backups from phone to PC .... Device MGR has yellow errors "This device cannot start. (Code 10)"

    I cant get my working ROM back over there with ADB push or ADB sideload and i dont have any micro SD usb card reader ... unless i used somebody elses phone... that my work just for read/write purposes i suppose.. huh?

    Anybody know the correct directory path is it this??
  24. ZTE Force

    ZTE Force Newbie

    Anybody know how to use Odin... i've used it other phones to push over .tar compressed files but it's sort of tricky to get it just right

    PC cmd> ADB sideload 1970.xyz.zip gives the following error
    * cannot read 'sideload' *

    then i tried fix permissions from CWM and repeated above yielding
    error device not found

    should i get the ZTE drivers and re-install em ... think I should
    cuz after reading this post by bumptnate --that was the 1st thing he said was uninstall
    If you already have CWM working like me always had I suggest not meesing with the drivers since its caused me nothing but heartache ever since I did
    well i dont get an option anymore when synching up(bootlooping) so i am re-doing drivers myself per Junkie2100 http://androidforums.com/warp-seque...ide-checking-your-drivers-adb-connection.html

    can someboby post the drivers since they're not up onthe ZTE website
    there's Boost Force SD Card Upgrade Package(ZIP - 295MB) ?? any good ??

    Update: found a link ZTE Handset drivers. ZTE Handset USB Driver 5.2066.1.8
    reinstalled for what its worth still have "This device cannot start. (Code 10)"
  25. knoober

    knoober Android Enthusiast

    [ADB/FB/APX Driver] Universal Naked Driver 0… | Asus Eee Pad Transformer Prime | XDA Forums has been pretty reliable as far as drivers go. Works for every device I have. You'll have to read the thread to see if you want to try though.
    And another device probably will let you set the files where they need to be. It's worth a shot if you can't push them over adb. Sd card reader was a great investment for me, cuz now I can throw zip on a card if I have to make a quick swap/flash/ swap back and then everything's smooth sailing after that.
  26. ZTE Force

    ZTE Force Newbie

    I finally took the SD out of the phone and put the backup onto it manually.
    Just zipping the folders in windows does not work with CWM update/flash so i tried swapping the boot.img file into the new ROM from my working ROM and then I get an MD5 ckecksum error. Tried everywhich way... the biggest issue with the Shinru unmodified raw update is it bootloops but that is exactly what my goal is what I wish I could flash that one over more simply. Sawbones looks like modified the heck out of it... Did you ever get his last one running stably for yourself?

    Your ROM from superR... is that 4.0 or 4.1?

    I can probably debloat myself, and don't care one way or the other about deodex ... just want to repair data and go JB!:smokingsomb:

    My phone is from boost though I'd rather flash to Sprint now. Primarily the data networks are coded in the firmware differently... but anyway. Are most the ROMs from shinru & SuperR , Sawbones, et.al. mostly all Boost firmware?
  27. knoober

    knoober Android Enthusiast

    Have you tried restoring from a nandroid ? Its one more thing to try

    Please do forgive my poor memory, but Ive gone through atleast 3 different phones since this one (but I keep this one as a spare and it still runs) but I believe I did the full factory reset/cache wipe (data dalvik and cache) and then had to reflash the recovery.

    What carrier are you on? https://www.androidfilehost.com/?fid=23329332407583505 from this thread http://androidforums.com/threads/i-...sprint-rom-for-the-zte-force-4g.866711/page-2 is most likely the one I used, but I am not sure after so long. I do know that when I checked my backup files that the re-pack version is the one I have in there. You will definately want to make sure that you have the right CWM for your carrier version though.

    If you are on the same carrier all you *should* have to do *if* you problem is the same as mine was is : reflash your recovery partition with https://www.androidfilehost.com/?fid=23329332407583505 My theory is that the uppdate created some sort of corruption in the recovery partition -- which will be fixed by reflashing the partition

    Hope this helps :)
    MANLEY7878 likes this.

ZTE Force 4G LTE Forum

The ZTE Force 4G LTE release date was October 2017. Features and Specs include a 5.5" inch screen, 8MP camera, 2GB RAM, Snapdragon 427 processor, and 3000mAh battery.

October 2017
Release Date

Share This Page