1. Download our Official Android App: Forums for Android!

General Wrong location/location unavailable (not Eris specific)

Discussion in 'Android Devices' started by gingerbee, Jul 2, 2010.

  1. gingerbee

    gingerbee Newbie
    Thread Starter
    Rank:
    None
    Points:
    15
    Posts:
    10
    Joined:
    Jun 11, 2010

    Jun 11, 2010
    10
    0
    15
    i've had my phone about 3 weeks now. up until last week, the htc weather widget would update to my current location. when i was home, it would show the town i live in. i also had the google internet option to use my location and this would also work perfectly until last sunday.

    now, the weather location was stuck on miami no matter where i went (as far north as west palm beach) and the internet shows up 'location unavailable'. i have found out that the gps is picking up where i am in goggle maps but it seems that the cell towers are not as far as weather and internet location are concerned. i have tried all of the obvious settings.

    i did a factory reset and now my weather says ft lauderdale which is closer to me but still not my town. it does not update (manually either) as i move. the internet location still says location unavailable although for a fleeting minute after the factory reset, it DID locate me....then it was gone :thinking:

    so i called verizon, they didn't have a clue. then i took it to the store and it turns out EVERY phone the tech tried in the store had the same problem, including his. he told me it was a google problem and there was nothing he could do about it. i felt if i tried explaining how that would make it a verizon problem as well, it would be a losing battle :(

    i had these features when i got the phone and one day they disappear, i'm pissed, and verizon doesn't care! does anyone know how to get in touch with google?

    someone else HAS to have this problem! i have seen old posts about this but there hasn't been a solution.....
     

    Advertisement

  2. cableguynoe

    cableguynoe Android Expert
    Rank:
    None
    Points:
    163
    Posts:
    2,030
    Joined:
    Mar 30, 2010

    Mar 30, 2010
    2,030
    264
    163
    I'm a cableguy....really
    Monterey, CA
    I've had this problem for small periods... maybe like a day or so where i notice it's not updating.
    Not sure how long you've had this problem, but i would give it a few days to see if it doesn't just fix itself.

    I know you said you tried all the obvious settings, but just in case:
    Click on weather, then MENU-SETTINGS- update automatically.
    Also, try deleting the weather widget and adding it again.
     
  3. gingerbee

    gingerbee Newbie
    Thread Starter
    Rank:
    None
    Points:
    15
    Posts:
    10
    Joined:
    Jun 11, 2010

    Jun 11, 2010
    10
    0
    15
    i do have it set to update automatically, which it does not, but i'm not too concerned about that. i just wish it would locate me. i have tried to remove/reinstall it and that didn't work. even if it did, it seems to be tied to the internet 'location unavailable' problem too. i'm not technologically gifted but it seems as though the cell phone triangulation is not working for data apps. and yes, the setting is checked to use wireless networks.

    here's a question.....should google maps be able to locate me if i ONLY use wireless networks? i always use the gps but from what i understand, it should locate me to within several blocks. i tested it by turning off gps and using only wireless networks and google maps says 'your current location is temporarily unavailable'.

    so i would guess that my phone is just not communicating with the cell towers? but if this was true then i would not be able to use the phone (which i can) :thinking:

    this has been going on consistently for a week now
     
  4. cableguynoe

    cableguynoe Android Expert
    Rank:
    None
    Points:
    163
    Posts:
    2,030
    Joined:
    Mar 30, 2010

    Mar 30, 2010
    2,030
    264
    163
    I'm a cableguy....really
    Monterey, CA
    This not not true.
    You can be disconnected from any wifi connection or 3G(mobile network), and still be able to make phone calls.
     
  5. gingerbee

    gingerbee Newbie
    Thread Starter
    Rank:
    None
    Points:
    15
    Posts:
    10
    Joined:
    Jun 11, 2010

    Jun 11, 2010
    10
    0
    15
    so it's fair to say that my phone does not communicate with the cell towers...does anyone else have this problem? does anyone know how to get in touch with google?
     
  6. bridget4874

    bridget4874 Lurker
    Rank:
    None
    Points:
    5
    Posts:
    1
    Joined:
    Jul 15, 2010

    Jul 15, 2010
    1
    0
    5
    Real Estate Agent
    Ohio
    Hi GingerBee- I came across your post and was having the EXACT same issue! For the last hour I have tried it all!!
    My location was always my major city -and the google internet kept saying that it was unavailable. I have done every reset known to man and clicked everything!!

    This may work- it just worked for me a moment ago---
    go to your
    home screen then
    Menu-settings- wireless and networks-check the WI-FI box. Some how turning on the WI-FI actually Works!!
    I went right back to try it- and POOF- they all changed to the correct location and went back to the way they were!! YAY!
    Hope this helps!!

    :)
     
  7. nx1977

    nx1977 Android Expert
    Rank:
    None
    Points:
    163
    Posts:
    2,421
    Joined:
    Feb 8, 2010

    Feb 8, 2010
    2,421
    174
    163
    UK
  8. eddieg

    eddieg Member
    Rank:
    None
    Points:
    16
    Posts:
    60
    Joined:
    Feb 17, 2010

    Feb 17, 2010
    60
    2
    16
    I had the same problem with the weather app aswell. I dont know why this worked but it did. I did the airplane mode trick to fix my 50% without signal issue and guess what it also fixed my location issue in the weather app. Turn off the phone then turn it back on put it in airplane mode let it go to sleep for a minute wake up phone and turn off airplane mode.
     

Share This Page

Loading...