1. Download our Official Android App: Forums for Android!

Support Wrong time when text messages are received

Discussion in 'Android Devices' started by xAlbert, Nov 23, 2008.

  1. xAlbert

    xAlbert Lurker
    Thread Starter
    Rank:
    None
    Points:
    5
    Posts:
    5
    Joined:
    Nov 23, 2008

    Nov 23, 2008
    5
    0
    5
    everytime i get a text message, the time displayed is alwayz 5 hours behind...

    lets say its 5 pm and i get a text message,
    the text will say 12pm.

    since its in a conversation it displays in chronological order

    so the recieved text messages are alwayz bunched at the top and sent at the bottom.... i live in Vancouver, and got an unlocked g1. anyway to fix this time problem?
     

    Advertisement

  2. STORM3333

    STORM3333 Well-Known Member
    Rank:
    None
    Points:
    56
    Posts:
    160
    Joined:
    Oct 28, 2008

    Oct 28, 2008
    160
    6
    56
    I AM A CHEF BY TRADE AND NOW RUN A RESTAURANT
    CALIFORNIA
    seriously? as much as I praise my android and I always will text messaging and picture messaging is my biggest disappointment! I was just talking to someone at work about it who also has a G1 and we were in total agreement. I think this device was launched prematurely and alot of kinks weren't worked out, not complaining i'm just sayin! I am faithful we will get hella updates on alot of these issues though. I love this site, I love everyone connecting and relating to the same issues. love it! I didn't notice a large time difference in text messages sent now i'm gonna check my device and see if i'm having the same issue. I have to sadly admit I got days before I check text messages. smh@me
     
  3. justjimjpc

    justjimjpc Premium Member
    Rank:
    None
    Points:
    663
    Posts:
    10,543
    Joined:
    Nov 3, 2008

    Nov 3, 2008
    10,543
    210
    663
    Washington DC, USA
    I am texting with people in my same time zone and have not had any problem with the time stamps ...
     
  4. xAlbert

    xAlbert Lurker
    Thread Starter
    Rank:
    None
    Points:
    5
    Posts:
    5
    Joined:
    Nov 23, 2008

    Nov 23, 2008
    5
    0
    5
    im texting people in same time zone as well.. but still 5 hours behind :<..
     
  5. apaschea

    apaschea Lurker
    Rank:
    None
    Points:
    5
    Posts:
    1
    Joined:
    Dec 24, 2008

    Dec 24, 2008
    1
    0
    5
    hi im having the same problem. The time is wrong so all my messages are bunched up at the top. its really annoying because i have no idea whats going on. I have an unlocked g1 in toronto on the rogers network. I had the same problem with my iphone once and basically before there was an update, the fix was to set your clock back 5 hours. I tried it on the g1 and it worked. So i guess im going to use that until there is a permanent fix.
     
  6. punkzanyj

    punkzanyj Android Expert
    Rank:
    None
    Points:
    128
    Posts:
    1,012
    Joined:
    Oct 20, 2008

    Oct 20, 2008
    1,012
    72
    128
    Really? From my experience, I consider the G1 the best sms/mms device I've ever owned.

    I'm curious, what's not working for you?
     
  7. Ari2004

    Ari2004 Lurker
    Rank:
    None
    Points:
    5
    Posts:
    1
    Joined:
    Apr 20, 2009

    Apr 20, 2009
    1
    0
    5
    College
    London
    I'm from London and have the same problem, my G1 has been sent to T-Mobile engineers 3 times and they still can't seem to fix the problem. I'm not sure if it's just a bad handset.
     
  8. punkzanyj

    punkzanyj Android Expert
    Rank:
    None
    Points:
    128
    Posts:
    1,012
    Joined:
    Oct 20, 2008

    Oct 20, 2008
    1,012
    72
    128
    have any of you having this difficulty checked settings->date & time to make sure the timezone is set up correctly? I haven't ever had this issue, and I do NOT have the "automatic" setting box checked. Perhaps that will help?
     
  9. justjimjpc

    justjimjpc Premium Member
    Rank:
    None
    Points:
    663
    Posts:
    10,543
    Joined:
    Nov 3, 2008

    Nov 3, 2008
    10,543
    210
    663
    Washington DC, USA
    I turn my phone off at least once a day to reboot ... this updates the phone's time to the Phone Carrier's network time (if you select that option)

    I had previously noticed over a week's time the phone clock would not keep good time and I have seen it at least 10 minutes slow...

    But selecting the (network option) and power off / om would update thye clock ...
     
  10. Dippy

    Dippy Lurker
    Rank:
    None
    Points:
    5
    Posts:
    2
    Joined:
    Apr 27, 2009

    Apr 27, 2009
    2
    0
    5
    I also have this problem, had it for about 2 months now, and just put up with it, I hard reset my phone and it still did nothing, it's really annoying and I haven't got a clue how to fix it, anyone got any ideas?

    (I live in London, UK by the way)
     
  11. RozzaC

    RozzaC Android Enthusiast
    Rank:
    None
    Points:
    83
    Posts:
    647
    Joined:
    Feb 25, 2009

    Feb 25, 2009
    647
    10
    83
    Student
    London, UK
    I have no such problem...and I live in London as well...
     
  12. Dippy

    Dippy Lurker
    Rank:
    None
    Points:
    5
    Posts:
    2
    Joined:
    Apr 27, 2009

    Apr 27, 2009
    2
    0
    5
    A few of my friends have the same phone, I think it's something to do with DLS because it was never busted before then? It's so frustrating, and i'm stuck with this phone now. Have to use a buggy text program I downloaded from AM atm lol.
     
  13. RozzaC

    RozzaC Android Enthusiast
    Rank:
    None
    Points:
    83
    Posts:
    647
    Joined:
    Feb 25, 2009

    Feb 25, 2009
    647
    10
    83
    Student
    London, UK
    DLS? o_O
     
  14. boyincity

    boyincity Lurker
    Rank:
    None
    Points:
    5
    Posts:
    1
    Joined:
    Jun 4, 2009

    Jun 4, 2009
    1
    0
    5
    I just got my G1 dev phone today, and I was also experiencing this issue. After a bit of investigation, I've found that the issue is a code bug where the time zone modifier is is applied to the already modified time stamp when setting the time for incoming text messages. This might be specific to the firmware version i have. Right now i'm running 1.0 (haven't checked what other versions are currently available, if any).

    You can see for example if you are in the -5 time zone, and you get a message at 10:25am it will show up as 5:25 am for example.

    So currently, a "fix" would be to turn off the network time setting, set your time zone to the +0 (Western Europe/Casablanca) time zone, and then correct your time manually. Your text messages will now display in the correct order with the correct time.
     
  15. MrLuigi

    MrLuigi Lurker
    Rank:
    None
    Points:
    6
    Posts:
    4
    Joined:
    Jun 5, 2009

    Jun 5, 2009
    4
    2
    6
    Settings do not work on retail Dream units. From the look of it I am getting my test messages through the towers in Toronto instead of here in Vancouver. Hmm they better fix it soon.
     
  16. biancapruis

    biancapruis Lurker
    Rank:
    None
    Points:
    5
    Posts:
    2
    Joined:
    Jun 16, 2009

    Jun 16, 2009
    2
    0
    5
    yeah... I live in Florida, United States.. and it's doing it to me too, idk how to fix it either and I hate it; I wish there was a solution!!:mad:
     
  17. hmdsidd

    hmdsidd Newbie
    Rank:
    None
    Points:
    15
    Posts:
    10
    Joined:
    Jul 13, 2009

    Jul 13, 2009
    10
    0
    15
    Boyincity's way worked for me. thanks a lot, phew.
     
  18. titos1997

    titos1997 Newbie
    Rank:
    None
    Points:
    15
    Posts:
    14
    Joined:
    Jan 10, 2010

    Jan 10, 2010
    14
    0
    15
    Didn't seem to work for me
     
  19. titos1997

    titos1997 Newbie
    Rank:
    None
    Points:
    15
    Posts:
    14
    Joined:
    Jan 10, 2010

    Jan 10, 2010
    14
    0
    15
    Not to sound rude but what does this have to do with the time stamp not being accurate in messaging
     
  20. Cozanostra

    Cozanostra Lurker
    Rank:
    None
    Points:
    5
    Posts:
    1
    Joined:
    Dec 27, 2010

    Dec 27, 2010
    1
    0
    5
    If you have selected 'automatic' under your date and time options, then any received texts will be tagged with the time zone of the carrier message center,eg for Rogers it would be ontario. has nothing to do with the phone itself. This wasn't an issue with other phones because they use the phone time by default. To fix, simply disable automatic time. And don't blame the device right away. If you don't have the time to explore the capabilities of an android, then get yourself a blackberry
     
  21. cnruck

    cnruck Lurker
    Rank:
    None
    Points:
    5
    Posts:
    6
    Joined:
    Jan 5, 2011

    Jan 5, 2011
    6
    0
    5
    Surrey, BC
    I just downloaded 2.2 and now my incoming time stamp is correct. Before it was 5 hours earlier (live on the westcoast), had to scroll up to view a received message.
     
  22. CYJAToronto

    CYJAToronto Lurker
    Rank:
    None
    Points:
    5
    Posts:
    1
    Joined:
    Apr 12, 2011

    Apr 12, 2011
    1
    0
    5
    Unfortunately, the 2.2 upgrade did not fix the -4 hours text-received time. Did you change other settings with the upgrade?
     
  23. TyLord

    TyLord Lurker
    Rank:
    None
    Points:
    5
    Posts:
    6
    Joined:
    May 24, 2011

    May 24, 2011
    6
    0
    5
    I've got this problem too. I just switched carriers. Soon as i popped the new sim card in it started happening. My carrier has no idea.
     
  24. TyLord

    TyLord Lurker
    Rank:
    None
    Points:
    5
    Posts:
    6
    Joined:
    May 24, 2011

    May 24, 2011
    6
    0
    5
    The only fix i've found so far is from a program available on the market called: "SMS Time Fix"
     
  25. Etaneepitas28

    Etaneepitas28 Lurker
    Rank:
    None
    Points:
    5
    Posts:
    1
    Joined:
    May 30, 2011

    May 30, 2011
    1
    0
    5
    This worked for me, thank you
     
Tags:

Share This Page

Loading...