1. Download our Official Android App: Forums for Android!

WTF SD Card?

Discussion in 'Computers' started by ashykat, Jul 13, 2011.

  1. ashykat

    ashykat Android Expert
    Thread Starter
    Apr 27, 2009

    Apr 27, 2009
    Irvine, CA
    So, I was getting rid of my old phone and starting using an OG Droid for the time being, so I wanted to use my 16 GB SD Card instead of the 2 GB one in the Droid.

    I did a Titanium Backup of all the apps from my old phone, threw the card in the new one and did an app restore (just apps, no data). Everything went through fine, so then I used TB's copy user apps to SD Card feature.

    I went to check my free internal memory on the Droid and I noticed no change from before I copied to SD. I thought it was a bit weird and decided to just backup my SD card and reformat it since it's always a smart thing to do when putting a card from an old phone into a new one.

    Well, my phone says it formatted the card, but then I realized it didn't erase anything. I then reboot into recovery and use that option to format. Once again, it shows that the format is complete yet nothing on my SD card is erased. I start thinking, WTF?

    So, I mount the SD Card on my computer through the phone and format it that way on my Mac. Format complete, but it's still not. I try zeroing out the data, it completes, but it's still not formatted!

    I take the same steps on a PC using windows 7. Same result. I put it into an SD Card reader, and I'm told the disk is write protected. I check the adapters lock switch and it's not locked. I do all the little tricks there like putting tape over it but it still says it's write protected. I edit my registry files to see if that will work. Nope, still write protected. I try formatting it in a digital camera and in multiple phones. It still won't format!

    I've tried running CHKDSK on it (while mounted through the phone since through the adapter it's write protected therefore CHKDSK won't run) and it shows no errors on the disk. I've tested the adapter with other micro sd cards and they all work fine, so I know it's not the adapter.

    Does anyone have any clue what I can do here? Is my SD Card just dead?


Share This Page