1. Are you ready for the Galaxy S20? Here is everything we know so far!

Xperia sp can't read ntfs memory card?

Discussion in 'Android Devices' started by decade, Jul 10, 2013.

  1. decade

    decade Member
    Thread Starter

    Hi, want to ask why xperia sp can't read NTFS card? Is there any solution for this problem?
     



    1. Download the Forums for Android™ app!


      Download

       
  2. mshawnl

    mshawnl Member

    What size is it?
     
  3. decade

    decade Member
    Thread Starter

    It's 8GB class 4 memory card
     
  4. rbheromax

    rbheromax Android Expert

    The stock ROM prolly doesn't have NTFS drivers built in. You would have to grab source from Sony, and build the module and install it on your device.
     
  5. rbheromax

    rbheromax Android Expert

  6. rbheromax

    rbheromax Android Expert

    Your device may not support it at the kernel level. If the app doesn't work then your SOL.
     
  7. ThatOneRearEnd

    ThatOneRearEnd Well-Known Member

    The app is completely kernel-indipendent therefor requiring root access to get the NTFS stuff mounted... Tried it on my brothers Z and it worked without a flaw...
     
  8. rbheromax

    rbheromax Android Expert

    Actually I doubt that's the case, I think needs root to use Linux's mount binary which only # an run. No app could even mount NTFS If the kernel didn't because the kernel sits in the middle of everything. Now u could try in command line: "busybox mount /dev/block/mmcblk1p1 /sdcard" and this should get the job done if ur device supports it. But I doubt an app would include ".ko" files to be insmod'd for every device on every board type given that the ".ko" file is specific to ur phone and board type, maybe even kernel version but I haven't ran into that error when dealing with an building modules before. The Xperia Z is their flagship phone, of course it would support more than its redheaded little brother.
     
  9. ThatOneRearEnd

    ThatOneRearEnd Well-Known Member

    You haven't read the description of the app, have you? It uses an own driver to mount NTFS hence no kernel module is required... You are free to test it yourself and proove me wrong...

    I've got this working on a htc Hero and I haven't found any traces of NTFS support in its stock kernel...
     
  10. decade

    decade Member
    Thread Starter

    To use this app I have to root my phone right? Is it true rooting your phone will void the warranty? What is the easy way to root my sp?
     
  11. ThatOneRearEnd

    ThatOneRearEnd Well-Known Member

    Don't know about rooting this very phone in particular, but you have to unlock your bootloader prior rooting it.

    This will void the warranty, as it is stated on the offical Sony Bootloader Unlock page. It's your decision if you want to do this or don't... I haven't had any problems rooting all of my phones, so I can only speak for that part...
     

Sony Xperia SP Forum

Features and specs are not yet known.

unknown
Release Date
0
Reviews
Loading...

Share This Page

Loading...