1. Download our Official Android App: Forums for Android!

Support Xperia x10 camera can't save?

Discussion in 'Android Devices' started by EyhSteve, Sep 14, 2011.

  1. EyhSteve

    EyhSteve Lurker
    Thread Starter
    Rank:
    None
    Points:
    5
    Posts:
    6
    Joined:
    Nov 23, 2010

    Nov 23, 2010
    6
    0
    5
    Hey guys I keep getting an error everytime I take a picture with my phone. It says can not save. I just updated to gingerbread, is that the problem?
    Edit : I just restarted and when I try to open the camera it force closes saying android.process.media has stopped
     

    Advertisement

  2. beau420

    beau420 Android Expert
    Rank:
    None
    Points:
    143
    Posts:
    1,104
    Joined:
    Nov 10, 2010

    Nov 10, 2010
    1,104
    173
    143
    Computer Guy
    Ottawa
    Try going to settings -> Camera -> Clear Data.
    And restart phone and access camera app. maybe there's a glitch and it needs to repopulate.
    Similar solution works for those who had FC's with music player.

    http://androidforums.com/sony-ericsson-xperia-x10/407851-camera-problem-after-2-3-update.html

    If it still doesn't work, when you are in the Camera app, hit the Menu button (left button) and change the path where pictures are saved.

    Hopefully that fixes it and you aren't forced to format the SDCard
     
  3. EyhSteve

    EyhSteve Lurker
    Thread Starter
    Rank:
    None
    Points:
    5
    Posts:
    6
    Joined:
    Nov 23, 2010

    Nov 23, 2010
    6
    0
    5
    I can't figure out how to change the save location, the x10 doesn't have the stock android keyboard so I don't know if it'll let me ... is there any way to download the stock camera?
     
  4. beau420

    beau420 Android Expert
    Rank:
    None
    Points:
    143
    Posts:
    1,104
    Joined:
    Nov 10, 2010

    Nov 10, 2010
    1,104
    173
    143
    Computer Guy
    Ottawa
    Did you clear data?

    Setting->Apps->Camera->Force close and clear data

    That will prevent the error from happening.

    Apparently the stock camera always saves to the same location....the default location for pics on Android.

    If it is still giving an error about not being able to save the picture in a specific location, then it might not have rights to save to that location. That would leave me to believe you need to wipe the SDCard.

    What people should be doing when upgrading from 2.1 to 2.3 is to back everything up....contacts and all...then wipe the SDCard....remove all apps and install 2.3.

    I actually don't like or use the stock camera app.
     
  5. spikeithard

    spikeithard Android Expert
    Rank:
    None
    Points:
    83
    Posts:
    767
    Joined:
    Sep 23, 2010

    Sep 23, 2010
    767
    22
    83
    Male
    London Ontario Canada
    weird. under settings, I dont have 'camera'? yet I havent changed anything. still using stock camera
     
  6. 916x10

    916x10 Android Enthusiast
    Rank:
    None
    Points:
    73
    Posts:
    491
    Joined:
    Nov 13, 2010

    Nov 13, 2010
    491
    65
    73
    Nope, that's not the problem cause i'm on GB as well and my camera takes and saves pictures just fine
     
  7. theblonde315er

    Rank:
    None
    Points:
    5
    Posts:
    1
    Joined:
    Oct 2, 2011

    Oct 2, 2011
    1
    0
    5
    I was wondering if anyone had any solutions for this yet? I took one picture when I got my phone, and now I can't take anymore, and I had a wedding today and it wouldn't work! :( When i go to apps, there is no camera option to clear anything...
     
  8. 916x10

    916x10 Android Enthusiast
    Rank:
    None
    Points:
    73
    Posts:
    491
    Joined:
    Nov 13, 2010

    Nov 13, 2010
    491
    65
    73
    When you upgraded to GB, did you come from 1.6 or 2.1? Did you restore anything in GB once it installed or are you starting all over? Are you rooted? How did you update, flashtool, PC Companion, SEUS? There is clearly a conflict. Is the phone recognizing your sdcard? Go into settings/storage and see if it's recognizing it and if so, how much space is left. Then do what beau420 said, if that doesn't work, download a file manager like ASTRO (if you aren't rooted) or Root Explorer (if you are rooted), download this file and save it to your sdcard and using the file explorer, install it.

    What keyboard you have is irrelevant. You can't change the default save location.

    It won't be under settings, it'll be settings/applications/manage applications/all

    No more space on your sdcard? The camera app will be located at the path listed above
     
  9. spikeithard

    spikeithard Android Expert
    Rank:
    None
    Points:
    83
    Posts:
    767
    Joined:
    Sep 23, 2010

    Sep 23, 2010
    767
    22
    83
    Male
    London Ontario Canada
    Originally Posted by spikeithard [​IMG]
    weird. under settings, I dont have 'camera'? yet I havent changed anything. still using stock camera
    It won't be under settings, it'll be settings/applications/manage applications/all


    Nope.. still dont have 'camera' in there?!
     
  10. 916x10

    916x10 Android Enthusiast
    Rank:
    None
    Points:
    73
    Posts:
    491
    Joined:
    Nov 13, 2010

    Nov 13, 2010
    491
    65
    73
    Therin lies your problem! Download the file I listed in my previous post, save it to your sdcard, using a file manager, install it. Report back
     
    spikeithard likes this.
  11. spikeithard

    spikeithard Android Expert
    Rank:
    None
    Points:
    83
    Posts:
    767
    Joined:
    Sep 23, 2010

    Sep 23, 2010
    767
    22
    83
    Male
    London Ontario Canada
    put the file on my sd, then went to asto, clicked on the file and it had an option to browse and to open I think. I went with open and it showed me all the files... so i went back and chose browse, then I hit launch. it opened the actual camera app. and now in my app tray 'camera' is there again so I assume I have it now? but when I went to settings- manage apps, I didnt see it in the list?
     
  12. 916x10

    916x10 Android Enthusiast
    Rank:
    None
    Points:
    73
    Posts:
    491
    Joined:
    Nov 13, 2010

    Nov 13, 2010
    491
    65
    73
    Did you pick the "all" tab?
     
  13. spikeithard

    spikeithard Android Expert
    Rank:
    None
    Points:
    83
    Posts:
    767
    Joined:
    Sep 23, 2010

    Sep 23, 2010
    767
    22
    83
    Male
    London Ontario Canada
    sorry dont know what you mean?
     
  14. 916x10

    916x10 Android Enthusiast
    Rank:
    None
    Points:
    73
    Posts:
    491
    Joined:
    Nov 13, 2010

    Nov 13, 2010
    491
    65
    73
    See the tab at the top that says "All", tap it and look for the camera app in there.

    [​IMG]
     
  15. spikeithard

    spikeithard Android Expert
    Rank:
    None
    Points:
    83
    Posts:
    767
    Joined:
    Sep 23, 2010

    Sep 23, 2010
    767
    22
    83
    Male
    London Ontario Canada
    what program are you using? i use astro but it doesnt look like that
     
  16. 916x10

    916x10 Android Enthusiast
    Rank:
    None
    Points:
    73
    Posts:
    491
    Joined:
    Nov 13, 2010

    Nov 13, 2010
    491
    65
    73
    Please explain to me how you went to "settings/manage applications" and what list you were looking at.
     
  17. spikeithard

    spikeithard Android Expert
    Rank:
    None
    Points:
    83
    Posts:
    767
    Joined:
    Sep 23, 2010

    Sep 23, 2010
    767
    22
    83
    Male
    London Ontario Canada
    sorry that question doesnt make much sense?

    you mean when I went to settings/applications, what did the screen look like?

    Well it listed all my installed apps and programs but I have the stock one I guess because its blue backgroud and just says 'manage applications' at the top left. thats it.

    but again, 'camera' isnt in there.
     
  18. 916x10

    916x10 Android Enthusiast
    Rank:
    None
    Points:
    73
    Posts:
    491
    Joined:
    Nov 13, 2010

    Nov 13, 2010
    491
    65
    73
    Yeah, it doesn't make sense because to go to settings/applications/manage applications does not require the use of any app, so when you said you're using Astro to do that, it threw me for a loop. I figured you were looking around in Astro at the file system for the camera app, which is why I asked the question so I could get clarification. I'm still not quite sure what you did or how but not a big deal.

    So what version of Android are you on currently? If 2.3, yours should look pretty much identical to mine since WB rom is basically a modded/tweaked version of the stock rom. So from your homescreen, press the lower left button (hard button, aka menu button) and a screen will pop up, pick settings, then pick applications, then pick manage applications. The screen that comes up should look like mine. At the top of said screen, click on the tab that says "all" and scroll down a bit and you should see the camera app.

    Regardless...what exactly was your issue with the camera? You just jumped in and said you didn't have the camera app under settings...not exactly sure what your issue was, or if that was it.
     
  19. beau420

    beau420 Android Expert
    Rank:
    None
    Points:
    143
    Posts:
    1,104
    Joined:
    Nov 10, 2010

    Nov 10, 2010
    1,104
    173
    143
    Computer Guy
    Ottawa
    When I click under Settings->Apps->Manage Apps and click on the 'All' tab, I have camera in my list, but then again, I am running 2.3 and I have rooted.

    Not sure what you are trying to do now.

    If you want to use the default camera app I suggest you reformat your SDCard from your phone....maybe reflash for simplicity sake.

    Otherwise, remove the camera app or don't use it. Use another camera app.

    Or force close the camera app from the application list or from a task manager. Get the camera app to re-create it's settings, by doing something like finding the /sdcarcd/camera folder and deleting it and same with the /sdcard/dcim/camera folder. (or back up the data first if you want to be safe)

    Then start the camera app back up...or restart the phone. Let it recreate it's settings....not use the settings it had from a previous version, that is no longer fully compatible.....which is why it would have been way easier to format your SDCard about 2 weeks ago.
     
  20. spikeithard

    spikeithard Android Expert
    Rank:
    None
    Points:
    83
    Posts:
    767
    Joined:
    Sep 23, 2010

    Sep 23, 2010
    767
    22
    83
    Male
    London Ontario Canada

    I am on 2.2

    SO i dont have the 'all' feature. its ok. the camera seems to be saving ok now... it wasnt a few weeks ago. some videos saved and some didnt.
    I must have the 'camera' app on my phone because the camera opens when I press the side button for camera and the stock app is there. But I just dont see it in my app tray or in manage apps. odd.
     
  21. 916x10

    916x10 Android Enthusiast
    Rank:
    None
    Points:
    73
    Posts:
    491
    Joined:
    Nov 13, 2010

    Nov 13, 2010
    491
    65
    73
    So what was ur problem and what was ur goal?
     
  22. spikeithard

    spikeithard Android Expert
    Rank:
    None
    Points:
    83
    Posts:
    767
    Joined:
    Sep 23, 2010

    Sep 23, 2010
    767
    22
    83
    Male
    London Ontario Canada
    my problem was videos werent saving 100% a few weeks ago. some just didnt 'take' when i stopped recording.

    But i think its all good now.. and thanks
     
  23. 916x10

    916x10 Android Enthusiast
    Rank:
    None
    Points:
    73
    Posts:
    491
    Joined:
    Nov 13, 2010

    Nov 13, 2010
    491
    65
    73
    Your welcome, but please hit the thanks button
     
  24. Sam-SonyXperia

    Sam-SonyXperia Android Expert
    Rank:
    None
    Points:
    153
    Posts:
    1,042
    Joined:
    Jun 14, 2011

    Jun 14, 2011
    1,042
    151
    153
    As a side note with the earlier version of firmware it would be :

    Main Menu > Settings > Applications > Manage Applications > Menu Button > Filter > All > Then you will see camera.
     

Share This Page

Loading...