1. Check out our companion app, Forums for Android! Download from Google Play

General Xperia X10 Problem: Receivers (at other end) hearing sharp noise emitted by X10 during calls:

Discussion in 'Android Devices' started by prakashjam24x7, Jul 1, 2010.

  1. prakashjam24x7

    Thread Starter
    36

    Apr 28, 2010
    18
    2
    36
    There is a big issue with X10 which is not at all discussed anywhere in the forms and also this has been admited by the SE service center in Chennai INDIA.

    I got X10 on 28th Apr 2010 (banglore, India). i noticed that when ever i make calls via X10. all the receipients were complaining that they could hear a sharp noise randomly at the backgund while talking. first i thought this was due to Netwrok (as i could not hear it thou). then i tried changing the SIM and Network also. then i realised that this is caused due to Handset (xperia x10) and not by SIM card.

    I went to the service center and took the conversation recoding to them. they saw the issue and took a complaint. they tried various things and they replaced the Motherboard and gave me yesterday. 30Jun2010.

    Since yesterday i see that the Noise emitted has increased as all the receipients are telling that they could hear some disturbance in the background while taking with me via X10 (thou i cannot hear the same).
    Then i confronted with the service centre higher officials and asked them to see the issue. luckly during the call to the SE technical team they too heard the noise emitted by my Mobile hand set (X10).
    Till now i was thinking that this is a Unique case.
    They also told me that this is the second case which has come to them with this problem. there is some problem with the handset itself. they have asked me for 48hr to resolve the issue as they have putforth the question to SE Technical team somewhere else.

    This i am writing to let all Xperia X10 users to check with their friends weather while conversation via X10 do they hear some sharp noise (tuck tuck) at background. if yes take the handset with the recording of the conversation to nearist service center. but i really dont know what they will do about it.

    Regards,
    Senthilprakash Selvaraj
     

    Advertisement

    santu9191 likes this.
  2. prakashjam24x7

    Thread Starter
    36

    Apr 28, 2010
    18
    2
    36
    Update on my above post...!
    today i got the call from SE technical team. they told that this problem they noticed in another X10 used by their manager also it seems.
    2 days back they updated me that. they are applying the latest patch on both the mobiles (mine and their managers x10) and seeing weather this mentioed problem is getting resolved or not.

    Well today 17th July 2010 they called me and said that, the solution (applying latest patch released by SE) solved the issue on both the mobiles.

    Well Monday 19th Jul 2010 i will be getting my handset back. will update on the issue once i check for myself.

    PS: why is that no one else is replying to this post. is it like only few people face the issue? or is it that you did not notice it. i strongly suggest to test the same with your friends.



    Regards,
    Senthilprakash Selvaraj
     
  3. Zlanu

    Zlanu Well-Known Member
    15

    Jul 14, 2010
    64
    0
    15
    So all they did was put on the latest software patch and it was all okay? That's weird. I wonder what was the specific cause.
     
  4. prakashjam24x7

    Thread Starter
    36

    Apr 28, 2010
    18
    2
    36
    I am not satisfied by their answer. this is the 4th time i have given back the mobile to the service center... each time they say the problem is rectified...but it is not really...! let me get my mobile tomm.. and i will do nice proper testing..then only i will be satisfied..! will sure post on the update in next two days...!

    Regards,
    Senthilprakash Selvaraj;)
     
  5. miann

    miann New Member
    5

    Jul 19, 2010
    4
    0
    5
    i have this same problem... only seems to happen when the call is quiet though.. but its driving my gf nutz cause she wants be to be on the phone as she falls asleep
     
  6. etranger

    etranger Member
    5

    Jul 19, 2010
    6
    0
    5
    Hi,

    I've got the same problem. I just updated the firmware from R1FB001 to R2BA023 and the problem is still there.
    I'm in Canada, my operator is Fido, which runs under Rogers' network. I bought the phone from Turkey.

    Same thing applies to my dad's phone, same origin. He is on Rogers.

    New posters, please include your phone firmware version and which operator you use. Maybe there is actually a logical explanation to this mysterious noise.
     
  7. mashoo

    mashoo New Member
    5

    Jun 28, 2010
    2
    0
    5
    Had the same issue but i just got a replacement and it seemed to of went away. Some people complain about it like before but since i got a replacement it rarely happens and when it does it doesn't last for the duration of the call.
     
  8. miann

    miann New Member
    5

    Jul 19, 2010
    4
    0
    5
    I had the problem on the origonal firmware..

    ugraded from R1FB001 to Rogers: R2BA020 (07/02/2010, SEUS, no OTA)
    and the problem was gone for awhile but then came back.. but i think its less than before... I bought the phone through rogers and i am a rogers customer.. new sim card as well with the phone purchace.
     
  9. etranger

    etranger Member
    5

    Jul 19, 2010
    6
    0
    5
    have you tried to get rogers to fix the problem? if yes what did they say?
    Because since you got the phone from them it is their responsibility, isn't it?
     
  10. miann

    miann New Member
    5

    Jul 19, 2010
    4
    0
    5
    did realize it was my phone till i had owned the phone for longer then the 30 min/ 30 days return policy so i cant see why it would be covered by them... gonna send sony an email today
     
  11. etranger

    etranger Member
    5

    Jul 19, 2010
    6
    0
    5
    it would be covered by them because there is always at least a year long warranty on these. Since they brand and sell these phones you should be able to take this up with them.
    You're right, you can't just return it and get a new one but what we are talking about is an obvious defect. Let us know what SE or Rogers says and good luck!
     
  12. prakashjam24x7

    Thread Starter
    36

    Apr 28, 2010
    18
    2
    36
    Hi i have got my mobile after the firmware update.
    the problem is still persisting. no change.

    I am taking this up with higher officials in SE. lets see how it goes.

    will update once i get a response from them.

    PS: I want to know is their any Xperia X10 user who does not have this problem in his handset. if yes plz plz reply to this post. this will confirm that this problem is not in all the X10 hardware.

    if no then this is a serious problem with X10.

    so i urge all X10 users who dont have this problem to respond to this form.

    Regards,
    senthilprakash Selvaraj.
     
  13. johndub71

    johndub71 Member
    5

    Jul 25, 2010
    5
    0
    5
    crooked spire town
    I had a click in the ear peie when i updated to xxxxx24, it was caused my app killer. The phones proximity sensor would wipe off the screen during a call, app killer would delete files when sreen off, and screen would come back on again, with a resulting click in ear peice.
     
  14. prakashjam24x7

    Thread Starter
    36

    Apr 28, 2010
    18
    2
    36
    Update:
    today SE people told that they will replace my handset with the latest manufactured xperia handset. which they will receive by 2nd week of august.

    so lets see....weather the new handset what they will be giving me is ERROR free or not...!

    hoping for a solution for this problem.

    Regards,
    Senthilprakash Selvaraj
     
    upliftpeanut likes this.
  15. upliftpeanut

    upliftpeanut New Member
    5

    Aug 6, 2010
    4
    0
    5
    omg i cant believe i finally found someone with the same problem as me!!!!

    keep us updated coz i bought my phone overseas and it will be a real pain to send my phone back for repairs so would like to see if there's a simpler solution first...

    thx!!!!!!!!
     
  16. prakashjam24x7

    Thread Starter
    36

    Apr 28, 2010
    18
    2
    36
    guys...please update this forum if you have the same problem...!
    i ahve sent the link to SE team. i guess they too are monitoring it...!

    I will update u all once i get replacement on 2ed week of august...keeping my fingers crossed..!

    Regards,
    Senthilprakash.
     
  17. tinny9

    tinny9 Member
    5

    Jul 19, 2010
    9
    0
    5
    Engineer
    Patiala
    hey guys..........i'm from punjab (India) and i also have this problem. i purchased this handset 20 dayz back....
     
  18. tinny9

    tinny9 Member
    5

    Jul 19, 2010
    9
    0
    5
    Engineer
    Patiala
    hey buddy

    i have this problem also......i had removed the task killer but the problem still persists.....what shd i do?
     
  19. prakashjam24x7

    Thread Starter
    36

    Apr 28, 2010
    18
    2
    36
    Bro its not the task killer..its problem in the Hardware...! i am getting a replacement this week...lets see i wil update on the status..!
     
  20. hal752

    hal752 Well-Known Member
    16

    May 16, 2010
    47
    6
    16
    Sorry to be just jumping into the conversation, But I've never heard of this problem. I use to work for O2 repairs and returns, Also seems that all of you are out of Europe
     
  21. debz voom

    debz voom New Member
    5

    Aug 8, 2010
    1
    0
    5
    Hi I have had this phone for a short 2 weeks and I have got to say that I am pleased with all but the complaints from those I call saying about a noise in the background. they complain the noise in intermittent but very annoying sort of a spitting high pitched noise or a squeaky door. I myself don't hear the noise. I have posted on the SE forum but had no reply from them. Has anyone found a solution to this problem or does anyone know how long i have or if i can return the phone to my provider
     
  22. patr1ck

    patr1ck New Member
    5

    Aug 15, 2010
    2
    0
    5
    Having the same problem -loud and regular clicking noise can be heard on other end of a call from my x10 and i too thought it was a task killer problem until reading this!
     
  23. sharkhark

    sharkhark Well-Known Member
    38

    Aug 18, 2010
    205
    13
    38
    Franchise Owner
    Halifax, Nova Scotia
    same here. i just vented in another post...well my first actually about many issues i have with crashes and i didnt post this problem because i thought it was just me.
    My mother i called a few times in past couple weeks complained a couple times about high pitched short brief noises hurting her ear and she questioned what i was doing. when i said nothing, she said, you must be doing something, or moving around etc. i was not. not sure if its related or not but i am also using my blue tooth and getting on my end fairly consistent clicking like noises. not sure if its related.
     
  24. prakashjam24x7

    Thread Starter
    36

    Apr 28, 2010
    18
    2
    36
    Sadest day in my life :(

    Yesterday i got the replacement from Sony Ericsson. they gave me a fresh piece manufactured in July 2010.

    I tested today by calling my friends... :( the problem still persists.

    This is some problem in the mobile. till now SE has given me 3 replacements and in all replacements this problem is persisiting.

    So the conclusion isthat this is there in all the X10 sets and very few people have noticed it as the X10 owner wont hear this noise.

    I wont go back to SE anymore. I will wait for update from SE lets see what happenes. last three months i would have gone to service center Atleast 18 times.



    -Senthilprakash :(:(:(:(:(
     
  25. luke318is

    luke318is Well-Known Member
    56

    Jun 6, 2010
    147
    3
    56
    I have also had a few complaints about muffled and/or noises in the background. I read earlier that someone found the appkiller was causing some noise, and i have also noticed problems with the face proximity sensor cutting out and causing dropped calls. If the appkiller app is causing the face sensor to cut out, then it has a huge flaw that needs fixing. Maybe it is all related? i will try removing the appkiller, if everyone is not experiencing the problem, then it is probably app related.....
     

Share This Page

Loading...