1. Download our Official Android App: Forums for Android!

Support XT910 Damaged SD Card Error

Discussion in 'Android Devices' started by brenhat, Jan 9, 2012.

  1. brenhat

    brenhat Lurker
    Thread Starter
    Rank:
    None
    Points:
    5
    Posts:
    2
    Joined:
    Jan 9, 2012

    Jan 9, 2012
    2
    0
    5
    Ok, I have 2 x brand new RAZR XT910's. One is mine, one is my gf's. Both purchased for xmas.

    As our phones sadly did not come with SD cards! :( I bought (and checked compatibility) 2 x 32GB Samsung class 10 cards from an official source NOT ebay..

    My gf's phone has no issues. I put either of the new cards into her XT910 and no problem, I can format, transfer files via USB etc no issue and upon closing the connection I can see and hear all files after restarting her phone.

    HOWEVER

    With my XT910, I am able to transfer files to the card via USB etc HOWEVER!

    I always have 2 x issues.

    1) Sometimes after closing the USB connection (by changing from USB Mass Card reader to charge only) sometimes it cannot see either of the cards or pops up with empty card or damaged SD card and I am unable to format...

    2) Other times it can see all the files moved across and can read the files/play music etc ONLY UNTIL my phone is turned off and on again!
    Upon turning on it checks the card and says "Damaged SD Card". This ONLY happens after a restart.
    NOTE: It will have NO issue with the card until it has been turned off and on.

    Please also note: I have validated the 2 x new genuine 32GB Samsung SD cards and confirm they are NOT fakes.

    Any advice? I will be very unhappy if I have to send my phone back at my own expense and wait ages for a repair :( on a phone I have had for only a couple of weeks.........
     

    Advertisement

  2. Szadzik

    Szadzik Android Expert
    Rank:
    None
    Points:
    223
    Posts:
    5,413
    Joined:
    Feb 15, 2010

    Feb 15, 2010
    5,413
    715
    223
    Male
    FAS Admin
    If I were you I would first try to use a different card for some time to see and make sure it is not the card playing up. Once you eliminate that, it may mean that your phone is not working correctly and you might need to have it replaced.
     
  3. brenhat

    brenhat Lurker
    Thread Starter
    Rank:
    None
    Points:
    5
    Posts:
    2
    Joined:
    Jan 9, 2012

    Jan 9, 2012
    2
    0
    5
    Thanks however I have 2 x new 32GB memory cards and have the same issues :(
     
  4. Szadzik

    Szadzik Android Expert
    Rank:
    None
    Points:
    223
    Posts:
    5,413
    Joined:
    Feb 15, 2010

    Feb 15, 2010
    5,413
    715
    223
    Male
    FAS Admin
    I have been using the same Samsung 32GB Class 10 card as you since two months and have never had problems. If you have two cards and they both cause problems, you might try to do a hard reset and see if that helps. Also try formatting both one of the cards on you PC, putting it into the phone, formatting again and see how if that works. If it still gives you problems it will mean itis the phone. Try to get it repaired or replaced under warranty.
     
  5. you2

    you2 Android Expert
    Rank:
    None
    Points:
    93
    Posts:
    930
    Joined:
    Jun 29, 2010

    Jun 29, 2010
    930
    125
    93
    Vaguely it sounds like there is a contact issue with the phone. I.e, maybe one of the connectors is not making firm connection. I suppose it is possible there is some lint or similar but I would try to examine the pins to see if there is some obvious issue.

     

Share This Page

Loading...