1. Are you ready for the Galaxy S20? Here is everything we know so far!

'Your device is not compatible with this version'

Discussion in 'Android Devices' started by Coroxn, Apr 13, 2012.

  1. Coroxn

    Coroxn Lurker
    Thread Starter

    There are a lot of apps that my Samsung Galaxy Ace can't seem to work with-the Google Play store won't even let me view them! Games such as Battleheart, Temple Run, Jelly Defense and Rage of Bahamut, all show this error, and .apks don't work, just necessitate a force close.

    Is this a single error with my phone, or do all Galaxy Ace's have this issue?

    And, in either case, is it fixable?
     



    1. Download the Forums for Android™ app!


      Download

       
  2. KeithIsMe

    KeithIsMe Newbie

    all these games requirements are higher level . Some are armv7 . galaxy ace is armv6
     
  3. bmanrunning

    bmanrunning Lurker

    I have downloaded the Apo on my kindle fire and it does the same thing so I cant even claim my presents or anything sooooo lame. Will it ever change cuz i hope so and I have battleheart and temple run so please fix it ppl
     
  4. Deleted User

    Deleted User Guest

Samsung Galaxy Ace Forum

The Samsung Galaxy Ace release date was February 2011. Features and Specs include a 3.5" inch screen, 5MP camera, 278GB RAM, Snapdragon S1 processor, and 1350mAh battery.

February 2011
Release Date
0
Reviews
Loading...
Similar Threads - 'Your device compatible
  1. Punbas
    Replies:
    0
    Views:
    306
  2. Irfan Latif
    Replies:
    1
    Views:
    803
  3. Rifi2023
    Replies:
    2
    Views:
    1,248
  4. FMW
    Replies:
    3
    Views:
    1,086
  5. wizard7611
    Replies:
    5
    Views:
    2,646
  6. James NYC
    Replies:
    2
    Views:
    890
  7. gremlinkurst
    Replies:
    4
    Views:
    1,620
  8. vaf
    Replies:
    6
    Views:
    2,180
  9. Norox Baloch
    Replies:
    1
    Views:
    1,707
  10. 1337xhoax
    Replies:
    10
    Views:
    2,545

Share This Page

Loading...