1. Check out our app, Forums for Android! Download and leave feedback here!

Support Youtube app "Sorry this video cannot be played"

Discussion in 'Android Devices' started by PhaseIII, Jul 18, 2010.

  1. PhaseIII

    PhaseIII Member
    Thread Starter
    16

    May 10, 2010
    12
    1
    16
    Posted this at a different android forum, posting here as well to maybe find a fix quicker..
    ---
    VERY annoying youtube issue..
    With just about ANY video i try to play on youtube while using EVDO, i am greeted with this message after about a 30 second "loading" loop

    [​IMG]


    I have been able to find others with this issue.. but no fix:
    Android Youtube App Problems - YouTube Help
    YouTube on the HTC Hero
     

    Advertisement

  2. RiverOfIce

    313

    Mar 30, 2010
    1,715
    1,254
    313
    In exile
    From most common to least common reasons.

    1.) It is full flash video, the htc evo only supports flash lite.
    2.) The creator of the video has marked it for desktop only, so it will not play on a mobile phone. This can be down with added scripts or done by mistake, by including scripts that can not be ran on the phone.
    3.) It is a music video or format that is not support by the htc evo for streaming. Some content is copyrighted and google can not let you download it to your phone
    4.) Youtube is having server problems, and the video can not be displayed.
    5.) It is mature content that requires you to log in.
    6.) The youtube app has received an error.


    Most video on youtube is for full flash only, not flash lite, you are goin to have to wait for 2.2.

    Some content is locked by the creator for desktops only. Other content that contains pop up windows or other media like embed ads will not work.

    But here is the great news. You do not have to use the stupid app, it causes more headaches then it actually fixes. But you are still going to have to wait for full flash, sorry.
     
  3. PhaseIII

    PhaseIII Member
    Thread Starter
    16

    May 10, 2010
    12
    1
    16
    I don't belive any of those can explain the issue... why? Because the videos play flawlessly while on wifi
     
  4. RiverOfIce

    313

    Mar 30, 2010
    1,715
    1,254
    313
    In exile
    What video?
     
  5. PhaseIII

    PhaseIII Member
    Thread Starter
    16

    May 10, 2010
    12
    1
    16
    any video
     
  6. RiverOfIce

    313

    Mar 30, 2010
    1,715
    1,254
    313
    In exile
    Ok no problem here.

    Try this. Go to web browser and under settings, click reset to default. This will undo your browser settings, you will need to redo your home page and stuff.

    Next thing is to reinstall the YouTube app from the market.
     
  7. PhaseIII

    PhaseIII Member
    Thread Starter
    16

    May 10, 2010
    12
    1
    16
    How do i go about reinstalling the youtube app?
     
  8. dimwit

    dimwit New Member
    5

    Mar 6, 2011
    1
    0
    5
    Hi all,
    I was having the same youtube/sprint tv/etc "video will not load" or "video cannot be played" issue. Just called Sprint tech support, bumped up to level 2, knew exactly the problem and sent an over-the-air update and everything is working perfectly now. Whole process took about 15 minutes! I recommend making the call!
     
  9. katebell1977

    katebell1977 Member
    5

    Aug 23, 2010
    7
    0
    5
    Orange County California
    i had to have someone uninstall it and reinstall it for me and then it worked fine. the geek squad guy at best buy did it for me
     
  10. TheEngineer

    TheEngineer Well-Known Member
    53

    Feb 23, 2011
    268
    55
    53
    Yes, I reported this way back on SprintUsers.
    3.70 update killed your streaming music? Here's the fix. - SprintUsers.com

    Sprint now can also push the settings to your Evo (and now the Evo Shift). If they do not know what you are talking about, refer them to the Known Issues of the Evo where the instructions for them will be shown (along with screenshots for the reading-impaired.)

    Expect the problem on other phones as the proxy settings are pushed out and until Google and/or the developers recode.
     
  11. ramasas3

    ramasas3 New Member
    5

    Mar 9, 2011
    1
    0
    5
    I had the same problem but I reset my (Dolphin HD) browser settings and then updated the YouTube application from the market. Now most of the videos play or at least give a polite message "This video cannot be played on mobile".
    That's much better.
     
  12. andy2005

    andy2005 New Member
    5

    Sep 3, 2011
    4
    0
    5
    I fixed it by cleaning cache and Just uninstalled Adobe Flash player.
     
Tags:

Share This Page

Loading...