1. Are you ready for the Galaxy S20? Here is everything we know so far!

z4 root app not working

Discussion in 'Android Devices' started by longdaddy, Dec 15, 2010.

  1. longdaddy

    longdaddy Well-Known Member
    Thread Starter

    I can't seem to get this app to work it gets stuck on the spinning wheel then after a while it just freezes the phone any ideas?

    1. Download the Forums for Android™ app!


  2. mxsjw

    mxsjw Android Expert

    Settings > Applications > Development > Make sure USB debugging is checked?
  3. doniago

    doniago Android Enthusiast

    When I ran z4 it took a -very- long time to finish (15-30 minutes). Others have reported that if you cycle the battery then run z4 it goes faster.

    I think there's already a few threads about this, particularly in regards to the recent update?
  4. longdaddy

    longdaddy Well-Known Member
    Thread Starter

    It's checked
    What do you mean cycle the battery? Can you link me to some of those threads? thanks
  5. androy

    androy Android Enthusiast

    Mine worked on the first try and took about 30 seconds with the latest OTA. It's weird that some people are having issues and some are not.

    I did an SBF to stock then updated to the newest OTA. My whole system was completely stock when I ran z4root.. Maybe that's the problem?
  6. doniago

    doniago Android Enthusiast

  7. longdaddy

    longdaddy Well-Known Member
    Thread Starter

  8. DangerMouse

    DangerMouse Lurker

    For the life of me I can not seem to get z4root to work for me with the v2.3.340 OTA after I lost my root from updating. I tried the battery pull method... did not change anything. Z4 root still sits there with the spinning image while it says Running exploit in order to obtain root access... this happens when I select the permanent root option. Temporary root seems to complete through... but doesn't give me root access. Should I try the unroot option and then retry? Any other tips? Is anyone else having this issue?
  9. colchiro

    colchiro Extreme Android User

    Try uninstall, reinstall, root again.
  10. DangerMouse

    DangerMouse Lurker

    Well looks like it worked this time... I don't know what the deal is with the z4 root but I've seen some people say it takes up to 2 hours, and some only 15 seconds.

    More feedback on this subject HERE.

    EDIT: I did not use the unroot method.
  11. colchiro

    colchiro Extreme Android User

    I was one of the first ones to update to OTA 340. When I noticed root wasn't working, I clicked on "root" and after about 10 seconds the boot animation came up, but I was rooted. :D
  12. Tiffaneys

    Tiffaneys Lurker

    The first time I tried it didnt work. It froze and I had to take the battery out and reboot. When I tried it the second time It worked!!!! :D
  13. Riverman

    Riverman Well-Known Member

    It took a couple of hours the second to last time I ran it. The time after that, it crashed my phone. After rebooting, it completed in about a minute.
  14. dblack9

    dblack9 Member

    this app never worked for me.
    i had to root the manual way via terminal emulator.
  15. liltenou

    liltenou Lurker

    The app works fine. You just have to be patient with it. I have a droid x.

    My first try was a fail. It got "stuck" at the spinning wheel for about 2 minutes then I got impatient and pulled the battery early.

    Second attempt worked fine. I selected permanent root, allowed the phone to do its thing for about 15 (maybe more) minutes, then the phone rebooted itself. Once done it was rooted fine. I knew because of the super user icon in my drawer.

    Its been working fine since.
  16. levthane

    levthane Lurker

    Same problem, all fixed now via terminal emulator.
  17. Eryl Flynn

    Eryl Flynn Android Enthusiast

    Z4 version 1.3 didn't work for me, but 1.0 did. Might try an older version of the app see if that works.
    CraigAD89 likes this.
  18. CraigAD89

    CraigAD89 Lurker

    So when I first ran Z4root, I tapped 'temporary root,' and it seemed to work flawlessly.
    I immediately installed some random Rom that looked alright from Clockworkmod. After some research, I really wanted to install the Rubix rom instead..
    However my phone was no longer rooted and clockworkmod did not reboot my DX into Recovery mod, subsequently I could not install the rom.
    Decided to run Z4root again however it did not work. Kept freezing, kept exiting, and even restarted my phone once however when I booted back up, phone was still not rooted. I literally went through the process about 15 times. Some BS, I know haha.
    Anyways, finally installed z4root 1.1 instead of 1.3, put my phone into airplane mode, and it seems to have worked...
    Still working on getting Rubix though. Good luck to all you z4root users.
  19. Aypse

    Aypse Member

    The first time I tried Z4, it was stuck for about 30 minutes. Since then I reboot prior to running it and since then I have never had it take more than a few minutes.
    Mikeyz likes this.
  20. TBoomer

    TBoomer Newbie

    I always get stuck on my first try. I have always just exited with the home button and reselected z4 from the app drawer. Works fine the second time every time. I guess everybody's DX is different.
  21. chrisvr6

    chrisvr6 Newbie

    So i can z4 root with the ota gb?
  22. scary alien

    scary alien not really so scary
    VIP Member


    Even GingerBreak won't root GingerBread for the X...you can only get root on the DX (currently) by installing the two-part, pre-rooted .zip from P3Droid.

    Z4root will work on 2.2/Froyo, though.

    [edit: although I am puzzled by CraigAD89's post above...was he on Froyo?]
  23. xmike

    xmike Well-Known Member

    +1 for reboot phone after installing the app. Works for me everytime.
    Mikeyz likes this.

Motorola Droid X Forum

The Motorola Droid X release date was July 2010. Features and Specs include a 4.3" inch screen, 8MP camera, 512GB RAM, TI OMAP3630 processor, and 1540mAh battery.

July 2010
Release Date

Share This Page