1. Are you ready for the Galaxy S20? Here is everything we know so far!

[ZIP] MMS FIX FOR CM/AOSP/AOKP (THANKS wolfu)

Discussion in 'Android Devices' started by davidmargolin, Nov 16, 2012.

  1. XAL2

    XAL2 Android Enthusiast

    Fantastic.
     

    Advertisement

  2. XAL2

    XAL2 Android Enthusiast

    I second this
     
  3. youaregreat

    youaregreat Well-Known Member

    Neither pacman nor aokp are without issue. pacman gives me reboot/bootloops until i clear cache, and lockscreen shortcuts don't stick.
    aokp won't stop telling me i have a voicemail. only ran the rom for about an hour before that became too annoying.
     
  4. Chingling

    Chingling Android Enthusiast

    Flashed the themed version and MMS still doesn't send. You only have to flash, correct? Running Dirt AOKP 3.5.2
     
  5. FatalIll

    FatalIll Well-Known Member

    Same problem. I flashed the "Stockthemed" ontop of Dirt AOKP 3.5 (Inc 3.5.2) and I can receive MMS, send and receive texts but can not send MMS.

    Tried stock, chomp, hancent all over 3g and wifi.
     
  6. Chingling

    Chingling Android Enthusiast

    Exactly, me too! I received my friend's MMS just a little bit ago, and then I tried sending and it would just get stuck on sending. I thought I was going crazy, cause others said that they could send and receive on Dirt AOKP. How are you guys doing it?
     
  7. mysticalnyte

    mysticalnyte Well-Known Member

    Dumb question: Will the Themes on the first page work with Sense/Senseless ICS ROM's i.e. MidnightROM or Mobster ROM?
     
  8. davidmargolin

    davidmargolin Android Expert
    Thread Starter

    very dumb question, those roms have mms working already
     
  9. Kahroo

    Kahroo Android Expert

    Works with PACman ROM for me.
     
  10. ramjet73

    ramjet73 Android Expert

    Have you tried the manual method in the OP of wolfu's thread to see if that works for you. He was using Dirt AOKP when he discovered the fix.

    ramjet73
     
    Chingling likes this.
  11. mysticalnyte

    mysticalnyte Well-Known Member

    I like the look of them and was curious as if I was to replace what I currently have visually.
     
  12. crashnova

    crashnova Member

    ok im kind of confused here. to download we must right click the link and click save link as, correct? now to install this do we copy whats in the downloaded xml to the existing xml or completely overwrite the existing xml?
     
  13. davidmargolin

    davidmargolin Android Expert
    Thread Starter

    kk... not so dumb question... go ahead and try it out... report back...
     
  14. mrawesome22

    mrawesome22 Android Enthusiast

    Wow.
     
  15. crashnova

    crashnova Member

    didnt know being unsure was a crime. thanks for the help tho.
     
  16. FatalIll

    FatalIll Well-Known Member

    For whatever reason the APN reverted itself for me. If you go into Voice Dialer and say "Open A-P-N" and go into the "Sprint" APN, the MMSC SHOULD be "http://mmsc.vmobl.com:8088/mms?" but reverted itself to sprintpcs for me.

    If you change it back to "http://mmsc.vmobl.com:8088/mms?" and hit Menu and Save, I was able to send MMS without issue.
     
  17. ramjet73

    ramjet73 Android Expert

    In fairness to you, the file was described in the instructions as build.prop, which is in the /system directory, when the downloaded file is actually apns-conf.xml and belongs in the /system/etc directory, so you had a reason to be confused.

    And yes, it's always better to ask if you're not sure. ;)

    ramjet73
     
    crashnova likes this.
  18. mysticalnyte

    mysticalnyte Well-Known Member

    I get a message that says: "Unfortunately, Messaging has stopped."
    Worth a try though. BTW, I'm on MobsterROM HD.
     
  19. ramjet73

    ramjet73 Android Expert

    I flashed the stocktheme version of the zip file on AOKP 3.5.2, then booted into Android and checked the /system/etc/apns-conf.xml and it still showed the VM settings. But when I used voice dialer to "open apn's" the sprint settings showed, so there must be a difference between the one being used by the system and the version in /system/etc.

    While reviewing the version in /system/etc I noticed the following comment:
    That may be the reason why the current version of the zip file isn't working.

    I'll update the zip file to copy the same xml file to that location and see if that fixes it.

    ramjet73
     
  20. xkravenx

    xkravenx Member

    Running PACMAN rom. I can confirm this works!!!

    1.-Flash one of the MMS apps from the first page.
    2.-Change the APN setting according to the XML file.
    carrier="Sprint"
    mcc="310"
    mnc="120"
    apn="Sprint"
    user="Sprint" server="*"
    password="*"
    mmsc="http://mmsc.vmobl.com:8088/mms?"
    authtype="3"
    Reboot
    Works.

    FYI: Most of the settings were aplied by the ZIP flash. Except for the mmsc setting.
     
    jjohn7293 likes this.
  21. krowley3

    krowley3 Well-Known Member

    This is strange since I took the apns-config from AOKP 3.5 to begin with. If you don't figure it out, i can have a look tomorrow. We may just need to edit the script to install to both locations. I have a feeling the user below is getting the same error if that is the case. Thanks for all the support you offer ramjet. I see you on every forum I frequent helping out. Definitely appreciated by many.

    If ramjet or someone else doesn't figure this out tonight, I will try to fix this tomorrow.
     
  22. cocheese101

    cocheese101 Newbie

    I think I figured out what we need from lens' MMS apk for our MMS to work, cause I know have MMS on jb miui. Its the mms-config in the app itself. I broke both down and changed em out.
     
  23. Prinny

    Prinny Resident Linux Nutcase

    Mind posting it for us? ;)
     
  24. cocheese101

    cocheese101 Newbie

    The how to or the apk. If its the apk, you'll have to give me min.
     
  25. cocheese101

    cocheese101 Newbie

    Prinny and karlyy7x like this.
Loading...
Tags:

Share This Page

Loading...