1. Are you ready for the Galaxy S20? Here is everything we know so far!

[ZIP] MMS FIX FOR CM/AOSP/AOKP (THANKS wolfu)

Discussion in 'Android Devices' started by davidmargolin, Nov 16, 2012.

  1. karlyy7x

    karlyy7x Member

    Alrighty so it didn't work quite right on Gangnam. I had the lens apk, I did the APNs this morning, then flashed the zip in the afternoon. Even tried with chomp, I was able to send but not download MMS. In the midst of that it got stuck on sending over WiFi. I must have missed something but switched to aokp

    & as it has been said it does work on aokp, the group messaging is strange but I don't get MMS that often to mind, it downloads in the lens apk but it's blank, just using chomp when I need to view the picture now

    Gotta say, I love this community for the great work :D
     

    Advertisement

    Prinny likes this.
  2. Prinny

    Prinny Resident Linux Nutcase

    Karlyy, I'll see if I can get gangnam working kater
     
  3. karlyy7x

    karlyy7x Member

    Awesome! I wasn't too savvy to try and keep working it out through the night, btw when it got stuck sending over WiFi I just rebooted the phone and sent the MMS in 3G first, just mentioning :)

    I can test out cocheese's miui apk though, I'll edit in a few

    - Well, I had a feeling miui wouldn't work on aokp, doh xD it doesn't show up
     
  4. dwappo7851

    dwappo7851 Well-Known Member

    what kernel are you using?
     
  5. Prinny

    Prinny Resident Linux Nutcase

    Karlyy, why not try out PACMan? It works great, IMO. I'm using it right now with the MMS patch. Been doing it since earlier today, and no issues. Just Go SMS won't work, if you like that app.

    (Off topic: 7x? Avenged Sevenfold fan?)
     
  6. ramjet73

    ramjet73 Android Expert

    It turned out to be more complicated than I thought.

    Apparently there is no directory named "apps/common/res/apns.xml" and I think that refers to the source tree. I did find this thread on XDA that references an apn.xml in framework-res.apk but I think that only applies to Sense based ROM's.

    Anyway, for some reason the 99MMS.sh script in the installation zip file wasn't deleting the telephony.db and it's journal file as intended, so I took that out and replaced it with inline commands in the updater-script to delete those files. That forces the default apn template (apns-conf.xml) to be used to rebuild the database at boot time. Otherwise you have to use the voice dialer and "open apn", then either edit the existing parameters or choose "Reset to default" using the menu option from the main screen and that will force it to update using the apns-conf.xml configuration.

    So the updated zip file for installing the stock theme version and the VM apn is attached. If someone wants to test that and it works, we can update the other versions, including the mmsmiui.apk if that is needed.

    ramjet73
     

    Attached Files:

    karlyy7x, mrawesome22 and EHokie like this.
  7. EHokie

    EHokie Android Enthusiast

    Way to go, ramjet! All good for me on Gangnam.
     
    ramjet73 likes this.
  8. wolfu

    wolfu Well-Known Member

    I'm Working on getting VVM working
     
    wigginst likes this.
  9. MtnDew31693

    MtnDew31693 Member

    I can also confirm ramjet's latest zip to be working on gangnam. So nice to have MMS again! For the record it also worked on aokp.
     
  10. wigginst

    wigginst Android Expert

    Think I found the one you talked about in your original post about this. You flashed the zip I am guessing?
     
  11. mrawesome22

    mrawesome22 Android Enthusiast

    Works on Mazda's 3.5.2

    Snappy too.
     
  12. wolfu

    wolfu Well-Known Member

    yes and now I have VVM still testing it out I didn't want to put something on here that didn't apply so I moved the post
     
  13. wigginst

    wigginst Android Expert

    Cool. Have to do anything else with settings? It is amazing how fast these fixes have come. I think all of this only leaves 3d not working now correct? I can't think of anything else missing.
     
  14. Hedied4me

    Hedied4me Member

    So I have lensflared dark MMS app installed I cleared cache I installed this zip but it still sticks at sending when sending a picture message. Go figure what am I doing wrong. (cdma vm user here on gangam cm10)
     
  15. wolfu

    wolfu Well-Known Member

    I didn't do anything else with the settings.
    just sent a 2 more voice mails and it's working great.
    I put the link to the zip on the Post I just made about this.
    I've had a couple days off and figured I'd play with my phone lol.

    I bet there's a solution for the 3D as well... someone will figure it out.
     
  16. karlyy7x

    karlyy7x Member

    I have pacman downloaded raring to go, actually lol I'm just trying out AOKP for maybe a week then switch. Are you able to view the picture in the apk(s) from OP?

    (Just got everything set up on aokp, even with Titanium it's a drag D: I do like GO, but it's so bloated, I'm starting to like the simplicity of chomp and yes, a7x fan)
     
  17. jjohn7293

    jjohn7293 Android Enthusiast

    Have you tried this?

    http://market.android.com/search?q=pname:com.concentriclivers.mms.com.android.mms
     
  18. wigginst

    wigginst Android Expert

    So in pac man I did a clean update of my rom . Used the flash able version. It did change the apk but I had to go in to apn to change the setting in there as it was still the sprint setting to get it working. This was using the dark version from the original post. Did not try the revised version from back a few posts.
     
  19. krowley3

    krowley3 Well-Known Member

    Thank you ramjet. That is great. I really appreciate the help with this.

    Here are the updated zips with Ramjet's fixes. Please update the OP.

    Stock
    Themed
    Len_Flare Original
     
  20. davidmargolin

    davidmargolin Android Expert
    Thread Starter

    updated... thanks all involved..

    now on the topic of getting 3d...
    since we haven't had success with getting 'htccamera.apk' over on aosp and building a fresh app is not an option for us at the moment, i decided to take some time (im at home sick this entire week) and look into the lg thrill... though it is a gingerbread device, it isn't as confused up as sense files... i wanna see if we can get that over on our device... is this possible??? if needed/wanted, i can upload camera and gallery apk files from that device
     

    Attached Files:

  21. crashnova

    crashnova Member

    A lot of progress being made. Thanks for the hard work. Is anyone still trying to get native MMS apk on cm10 working or already have it working? Krowleys fix didn't work. Keep it up guys.
     
  22. Prinny

    Prinny Resident Linux Nutcase

    Yep. It works just fine for me on PACMan. Using Chomp and it works fine.
     
  23. krowley3

    krowley3 Well-Known Member

    Ok so I just had a big breakthrough. I have MMS sending and receiving using the latest CM10 MMS.apk from Dastins ROM. This is JB MMS with all the features and should have sms split and quick reply with popup! This is what we all wanted.

    Updated download in thread or OP

    PS. This is pure WIN!
     
    karlyy7x, droiddekka, XAL2 and 3 others like this.
  24. wolfu

    wolfu Well-Known Member


    I just tryed it on aokp and it worked i didn't remove the old one it defaulted to this one after reboot. nice ....
     
  25. EvoLIntenT

    EvoLIntenT Newbie

    Will this work on AOKP!! Oh and thanks for everyone's hard work...

    Nevermind already answered.. Thank all of you for getting this to work...
     
Loading...
Tags:

Share This Page

Loading...