1. Are you ready for the Galaxy S20? Here is everything we know so far!

[ZIP] MMS FIX FOR CM/AOSP/AOKP (THANKS wolfu)

Discussion in 'Android Devices' started by davidmargolin, Nov 16, 2012.

  1. notebooko

    notebooko Android Enthusiast

    So I deleted the mms.apk from system/app and edited the lines out. Upon trying to flash the new zip im getting an error saying:
    "Error in /sdcard/Download/CM10MMS with MmsFix+cache.zip"
    "(Status 6)"
    "Installation aborted"
     

    Advertisement

  2. Prinny

    Prinny Resident Linux Nutcase

    Status 6? That's a syntax problem. Could you open the updater-script in CODE tags for me so I can see if I can figure out the syntax issue, please?
     
  3. notebooko

    notebooko Android Enthusiast

    [HIGH]ui_print("MMS Fix for Virgin Mobile");
    ui_print("Mounting system...");
    run_program("/sbin/busybox", "mount", "/system");

    ui_print("Extracting new files...");
    # copy system content to the system directory on your device
    package_extract_dir("system", "/system");

    ui_print("Fixing Permissions...");
    set_perm(0, 0, 0644, "/system/app/Mms.apk");

    ui_print("Unmounting system...");
    unmount("/system");

    ui_print("Mounting data..");
    run_program("/sbin/busybox", "mount", "/data");

    ui_print("Deleting telephony database...");
    delete("/data/data/com.android.providers.telephony/databases/telephony.db");
    delete("/data/data/com.android.providers.telephony/databases/telephony.db-journal");

    ui_print("Deleting dalvik cache...");
    delete_recursive("/data/dalvik-cache");

    ui_print("Unmounting data...");
    unmount("/data");

    ui_print("Installation complete!");
    [/HIGH]

    Wish I could be of more help. Sorry. :thinking:
     
  4. Prinny

    Prinny Resident Linux Nutcase

    No worries. GIve me a few minutes and I'll see what I can bake up here...

    Edit:

    How big is the zip while on your SD card? I know if you eject it too early it'll do that.

    Edit 2:

    and try this in your updater-script:

    Code (Text):
    1. ui_print("MMS Fix for Virgin Mobile");
    2. ui_print("Mounting system...");
    3. run_program("/sbin/busybox", "mount", "/system");
    4.  
    5. ui_print("Extracting new files...");
    6. # copy system content to the system directory on your device
    7. package_extract_dir("system", "/system");
    8.  
    9. ui_print("Fixing Permissions...");
    10. set_perm(0, 0, 0644, "/system/app/Mms.apk");
    11.  
    12. ui_print("Unmounting system...");
    13. unmount("/system");
    14.  
    15. ui_print("Mounting data..");
    16. run_program("/sbin/busybox", "mount", "/data");
    17.  
    18. ui_print("Deleting telephony database...");
    19. delete("/data/data/com.android.providers.telephony/databases/telephony.db");
    20. delete("/data/data/com.android.providers.telephony/databases/telephony.db-journal");
    21.  
    22. ui_print("Unmounting data...");
    23. unmount("/data");
    24.  
    25. ui_print("Installation complete!");
    Edit 3: Make sure after flashing, wipe cache/dalvik cache.
     
  5. notebooko

    notebooko Android Enthusiast

    The zip is 2.13 MB. Hmm.. getting the same error (status 6).
     
  6. Prinny

    Prinny Resident Linux Nutcase

    Weird...I JUST flashed it and it worked with that script...You copied the new zip with that, right? Not just updated the one on your SD Card? I think its a bad copy...So re-download...make that your updater-script...cop yto SD card and flash again
     
  7. notebooko

    notebooko Android Enthusiast

    Oh! I was using the old zip and just updating it. I will update a new zip and get back to you.

    EDIT: Upon flashing I'm getting another error now, status 7...
     
  8. Prinny

    Prinny Resident Linux Nutcase

    Okay. I got another idea. What ROM are you using? Post a link. I'll try to manually patch it. Then you can try the new one I try
     
  9. notebooko

    notebooko Android Enthusiast

  10. Prinny

    Prinny Resident Linux Nutcase

    Alright give me about...20-30 minutes and I'll send it up to my dropbox and see what we can do.
     
    notebooko likes this.
  11. Prinny

    Prinny Resident Linux Nutcase

    This post pertains to S2 users. I know its in the Evo V thread, but someone came here to ask. V users, do NOT flash this. As I am NOT responsible for bricks that occur.


    https://www.dropbox.com/s/hs2lhz47y8pwuo4/pa_d710-2.54-11NOV2012-170026_VM.zip

    Flash, try MMS. If it works, sweet. If not I have a few other ideas...

    Open voice dialer, say Open A-P-N-S. Make sure the right APN is there.

    Then go to /data/data/com.android.providers.telephony/databases with a file explorer that allows root exploring. Delete telephony.db and telephony.db-journal. Reboot. Try again.

    That's the best I can do, really. So I hope it works for you!

    Edit: And for kicks and giggles, after deleting those two files, go to recovery and wipe cache/dalvik-cache. Couldn't hurt.
     
  12. notebooko

    notebooko Android Enthusiast

    Thanks so much! I'm downloading it now and will report back to you as soon as I get it up and running.
     
  13. droiddekka

    droiddekka Well-Known Member

    Is this for everyone? or just miui users?
     
  14. Prinny

    Prinny Resident Linux Nutcase

    That's for Galaxy users. Lol. I attempted to help a galaxy user. I'll edit that post.

    What MIUI are you using?
     
  15. notebooko

    notebooko Android Enthusiast

    Hey Prinny, both sending and receiving now work! Thanks so much! I will forward people to your post if they want mms working on their phones with paranoid android. Although if we update will the settings stick? Again, thanks so much.
     
  16. Prinny

    Prinny Resident Linux Nutcase

    The settings will not stick, sadly. You'll have to patch them manually every time I believe. Only update though if its a serious one. If you don't need it, don't update!

    Glad I got it working, though!
     
    notebooko likes this.
  17. notebooko

    notebooko Android Enthusiast

    Okay, the ROM seems pretty much full featured and I haven't run into any problems with it so probably won't have to update for a while. Really glad that you could get it working for us. I know a lot of people will be switching over to Paranoid Android because you got it working. Thanks from all of us! :D
     
    TheBritton likes this.
  18. Prinny

    Prinny Resident Linux Nutcase

    No problem! Glad I was able to get it up and running. Good to know if I ever get an S2 ;)
     
    TheBritton and ellementz323 like this.
  19. wigginst

    wigginst Android Expert

    Anyone managed to get this to work on the slim bean rom?
     
  20. marco562

    marco562 Well-Known Member

    I got a problem here, I'm using gangnamstyle ROM (sprint version) I did the MMS fix I can receive and send MMS to other people but for some reason I cannot download or see this particular person's media messages is weird..is any one else having this problem..by the way he has sprint network idk if that could be the problem?? Just saying... this a screenshot of how his media messages show up on my phone.

    [​IMG]
     
  21. Kahroo

    Kahroo Android Expert

    Yeah I have that problem with one friend. But if you go and save attachment you're able to see what they have sent ya
     
  22. dstrcto

    dstrcto Lurker

    That's the exact problem I was having that I mentioned before. No idea how to fix it. I'm not sure if sprint includes odd markup or what in their MMS messages. I have a feeling it has to do with the apk we're using.
     
  23. OneEyedSniper

    OneEyedSniper Newbie

    Does your friend have an iPhone? That seems to be the only phone i have trouble with receiving MMS. But that's only due to group messaging, and not picture messaging.
     
  24. marco562

    marco562 Well-Known Member

    My friend doesn't have the iPhone he has HTC evo 4g (non 3D or LTE first gen. I believe).
     
  25. krowley3

    krowley3 Well-Known Member

    I may have found the problem.

    Check here and let me know!
     
    ramjet73 likes this.
Loading...
Tags:

Share This Page

Loading...