1. Are you ready for the Galaxy S20? Here is everything we know so far!

[ZIP] MMS FIX FOR CM/AOSP/AOKP (THANKS wolfu)

Discussion in 'Android Devices' started by davidmargolin, Nov 16, 2012.

  1. krowley3

    krowley3 Well-Known Member

    Shouldn't need to reflash the fix. Make sure you are setting the permissions. add the lines to the bottom of the build.prop. Before flashing the VM rom you can open the archive(.zip), pull out and edit the build.prop, then flash the rom. My recommendation would be to use the Sprint version with my flashable fix until Dastin cooks in the fix to the official VM version. I just put that up so that he knows the problem.
     

    Advertisement

    ODGeek likes this.
  2. ODGeek

    ODGeek Well-Known Member

    Flashing the fix and adding the lines to build.prop (and ensuring correct permissions on build.prop) fixed MMS on my phone.

    Apparently, when I tried the fix, and it didn't work, I restored my backup, so the fix was not there today when I added the lines to build.prop...

    Thank you for your help & for finding this fix!
     
  3. droiddekka

    droiddekka Well-Known Member

    Also, using the current dark theme:

    Replying to a mass text is broken. Your reply will be sent to EVERYONE that received the mass text, and not just the original sender.


    Anyone else noticing this?
     
  4. nsciucco

    nsciucco Android Expert

    ok Trouble with MMS. I have tried editing the MMSC and flashing the MMS fix.. with no luck... any ideas?

    _

    edit- all set. I tried the mms fix again after a fresh install. all set
     
  5. droiddekka

    droiddekka Well-Known Member

    is anybody running a properly functional inverted version of this fix?


    anybody?


    the rest of my rom is blacked out except mms and it looks ghetto as fock. if i'm missing something post up a link or something.
     
  6. droiddekka

    droiddekka Well-Known Member

  7. Palmetto Fellow

    Palmetto Fellow Android Expert

    Tagged for future reference.
     
  8. droiddekka

    droiddekka Well-Known Member

    I said it works perfectly but it doesn't.

    The group recipient problem still exists. I think this issue deserves its own thread.
     
  9. wigginst

    wigginst Android Expert

    Mazda had now posted the aokp 4.2.2 version. Was wondering if there was one of these fixes that could work with it?
     
  10. davidmargolin

    davidmargolin Android Expert
    Thread Starter

    take the one from dastins 4.2.2... works like a charm... steal the apk and then get the correct apns in there...
     
  11. droiddekka

    droiddekka Well-Known Member

    Does this fix the group recipient problem also?
     
  12. Kahroo

    Kahroo Android Expert

    Where is the CM10.1 fix zip?
     
  13. Prinny

    Prinny Resident Linux Nutcase

    Here
     
    Kahroo likes this.
  14. Kahroo

    Kahroo Android Expert

    That makes the messaging app FC every time I try to send a pic.
     
  15. Teh_Kitteh

    Teh_Kitteh Member

    FYI:

    Plus

    Equals working MMS on Dirty Unicorns 4.2.2.

    I think that will be added to build.prop in the next update, so you will no longer need it, and will only need to flash the zip.
     
  16. Kahroo

    Kahroo Android Expert

    Did that and it FCed every time I wanna send a pic. Going to back up and reflash the ROM
     
  17. Revenant Ghost

    Revenant Ghost Android Expert

    I had that same issue with AlienDroid.
     
  18. Kahroo

    Kahroo Android Expert

    Did you ever figure out how to fix it?
     
  19. Revenant Ghost

    Revenant Ghost Android Expert

    Unfortunately, no. :( Having no MMS was kind of a dealbreaker for me, so I went back to Mobster.
     
  20. Kahroo

    Kahroo Android Expert

    D;
     
  21. Prinny

    Prinny Resident Linux Nutcase

    Kahroo...did you do a clean flash of the ROM?
     
  22. Teh_Kitteh

    Teh_Kitteh Member

    Yesterday I tried, and MMS was force closing for me. I think I know why.

    Are you deleting mms.apk first? If so, don't.
    Just flash the zip, don't worry about deleting mms.apk.

    I think that's why it worked for me this time, I'm not sure.
     
  23. Kahroo

    Kahroo Android Expert

    I did. I was on PAC ROM before then I wiped Cache, Dalvik, and Factory Reset in TWRP. and it didn't work. I will reflash the ROM later when I have some free time.

    I didn't delete any MMS.apk just flashed the ROM, GAPPS (4.2.2 ones), and the CM10.1 MMSFix+Cache zip
     
  24. Kahroo

    Kahroo Android Expert

    Must have been a bad flash. Cause I reflashed the ROM and the fix and MMS works.
     
  25. Revenant Ghost

    Revenant Ghost Android Expert

    Well, I reflashed the AlienDroid ROM and MMS does work without the MMS fix. It just took a while longer than I expected and needed to have 3G data on. I was thinking that all JB ROMs have issues with MMS.

    That's why it doesn't pay to assume everything. Oh well. :p
     
Loading...
Tags:

Share This Page

Loading...