1. Check out our companion app, Forums for Android! Download from Google Play

Root Zte avid boot problems

Discussion in 'Android Devices' started by pcwebiz, Mar 15, 2013.

  1. pcwebiz

    pcwebiz Active Member
    Thread Starter

    Sep 11, 2011
    Las Vegas, NV
    Hello all,

    I have had my Avid since 1-11 and have not had any problems with it until yesterday. I took it off the charger and tried to power it up. The red light came on, blinked and stayed on. The metropcs screen came up and was frozen and would not go any further. I tried Power + Vol up and Power -V and nothing. The phone is frozen on the metro screen and would not do anything else. You can not get into recovery mode, FB or any other mode. The phone is stuck on stupid.

    I googled the problem here and I didn't find any information about the AVID but I did find alot of information about the same problem with other ZTE phones. No solutions posted. I was hoping to find a fix on this site and there was nothing posted wich is a good thing. Hopefully it was just an isolated incident.

    Good news is the metropcs corperate store gave me a new replacement phone for only $16 right there in the store and I didn't have to wait. I thought I would post this so that if this happens to anyone else you will know there is no fix for the problem. You will need a new phone. The insurance metroguard wont cover it. You will need to take it to a corperate store if this happens to you.



  2. dadcup

    dadcup Well-Known Member

    Jan 29, 2012
    Did you have the old one if so check if you can get in ftm from there you can flash stock image do it fastboot

Share This Page