1. Are you ready for the Galaxy S20? Here is everything we know so far!

ZTE Majesty Usb device not recognized when connected to win 7 pc

Discussion in 'ZTE' started by compguy1974, Oct 15, 2014.

  1. compguy1974

    compguy1974 Lurker
    Thread Starter

    I have a ZTE Majesty phone model z796c android v 4.1.2 my problem is most ofthe time but not every time I connect this phone with any Usb cable (the phone will charge) but it shows the message "Usb device not recognized" when connected to my win 7 pc. this has steadily gotten worse over time I can no longer transfer pics and files due to this I have tried everything I know please help.

    I am a computer/electronics tech with almost 20 years experience so I am not a noob but this is about o aggravate me.

    So far I can tell you this is what I know and have done so far.

    1.To ensure it is not the Pc & that it is virus free, I have completely formatted (high level format not just a standard format) then reloaded with a fresh instal of win 7 + all updates.

    "same issue still there"

    2. Downloaded any Dell updates, bios updates, and installed as directed etc.

    "same issue still there"

    3. requested help from Microsoft neither their tech nor myself could find any issues that may be causing this.

    4. Contacted (well tried to) ZTE no help, nothing, nada, zip!

    I have changed every available setting dealing with usb or pc connectivity that I can find. from charge only, install driver, media device (mtp) * (this is the option that was working perfectly and still on the rare occasion it wants to), to camera (ptp).

    Originally the Joinme software had me check the option USB debugging under developer options, I have tried unchecking this and going back to checked as it had me set up with no solution to the problem.

    Also when first connected the phone installed the Joinme software/drivers it will no longer do that or give me that option.

    HELP PLEASE frustrated!:mad:
     



    1. Download the Forums for Android™ app!


      Download

       
  2. epp

    epp Well-Known Member

    Go to Settings/Connect to PC. There will be four options. Install Driver is one of the options.

    Although I have only used USB to charge the phone, that option might be of some help.

    Have you contacted ZTE USA http://www.zteusa.com/ There is a contact link on their site.
     
  3. compguy1974

    compguy1974 Lurker
    Thread Starter

    Thanks, I have tried that but it has not worked so far it only installed the driver & the Joinme software the 1st time it was connected and if I put it on that settings it does nothing now. I have contacted ZTE they insisted it was the computer (software/possible viruses etc.) that is the main reason I formated the computer even though it was clean to begin with. I am trying to find on their site where I can download the Joinme software again to see if that helps but so far I have not been ale to, I will try to contact them again about that though thanks for reminding me of the contact info.
     
  4. epp

    epp Well-Known Member

    I'm curious as to whether this might be normal behavior?

    I use Linux at home and the other night, I used USB for the first time, to charge the phone and a similar message came up on the screen when Linux detected the phone, that it wasn't recognized.
     
  5. compguy1974

    compguy1974 Lurker
    Thread Starter

    I am not sure but I can tell you it had steadily gotten more frequent and ANNOYING! It has now become a daily issue each time I try to download my pics from the phone (it will charge no matter what) it had gotten to the point where I was installing the usb drivers from the joinme software I had saved when I downloaded it to my laptop after 1st getting the phone (just a side note that was odd to me, but zte no longer offers joinme for download). Today even those drivers no longer allow me to use it as ANY kind of usb device yet all my other usb connected devices (external HDD, printers, or Jump drives from usb 1 to usb 3 work fine with out this message) I am really stumped I even reset the phone to factory specs per someone from ZTE but yet ZTE does not offer any other downloads or much support.
     
  6. amyhenry

    amyhenry Lurker

    I know what u mean this phone has drove me batty I worked on this problem for days.
    This is my solution:

    1:Google play station download pdanet+

    2: Google Play Station Fox-Key its a paid download. (about $10.00)

    3: activate debugging on phone

    4: On PC download Pdanet

    5: When everything is downloaded and u followed all the directions there u have on you're PC app Pdamt+ 2 choices

    1: u can use WiFi

    2: u can use Bluetooth

    Mine only worked on Bluetooth but I tried both. With these apps the the WiFi Share even works.
    I hope this helps u out u. THIS PHONE IS ALL I WILL SAY. BYE
     
Loading...

Share This Page

Loading...