1. Are you ready for the Galaxy S20? Here is everything we know so far!


Discussion in 'Android Devices' started by madvane20, Jun 6, 2017.

  1. madvane20

    madvane20 Newbie
    Thread Starter

    Will type up better guide later on gonna include my ota i pulled as well maybe help someone

    btw do at ur own risk im not responsable if u mess the phone up
    added batch script hope it works to automate the process and guide u.
    you can download it this https://forum.xda-developers.com/attachment.php?attachmentid=4181698&stc=1&d=1497456929 extract it go into the folder find root.bat double click file.
    or just follow the guide below

    1.need to get temp root with king root first grab that here https://kingroot.net/ grab file for android not windows version
    grab this file https://forum.xda-developers.com/att...1&d=1497364232
    2.once extracted go inside folder. hold down sift key and right click inside the folder. click open command window here
    3.type this "su[​IMG]
    then continue guide
    4. type this "getprop ro.product.name"
    should show output "ZTE_BEAM"
    5. type this "setprop persist.sys.k ZTE_BEAM"
    6. type this "getprop persist.sys.k"
    output "ZTE_BEAM"
    7. type this "cd /dev/block/platform/soc.0/7824900.sdhci/by-name/"
    Lets backup recovery
    8. type this "dd if=recovery of=/sdcard/recovery.img"
    Lets write boot to recovery!
    9. type this "dd if=boot of=recovery"
    10. type this inside of adb shell "reboot recovery"

    if u get black screen just hold power down to reboot

    once booted up
    11. type this "adb shell"
    12. type this "su"
    13. type this "id"
    should show this output
    "uid=0(root) gid=0(root) context=u:r:shell:s0"
    then to set permissive
    14. type this "setenforce 0"
    15. type this "getenforce"
    output "Permissive"

    16. to test if mount system rw while still root type "mount -o remount,rw /system"
    if it mounts no errors then system is writeable
    if for some reason u cant write to system u can try
    run this command in adb shell or terminal

    reboot disemmcwp

    to re-enable write protection issue this command

    reboot emmcwpenab
    working on replacing king with supersu til then perm root with kingroot
    and u wanna donate for my hard work click here http://paypal.me/riley60
    to restore recovery back to stock u can do once u have perm root do this to restore recovery
    type this inside of adb shell dd of=recovery if=/sdcard/recovery.img
    i dunno if root stays though after that also hit the thanks button if my post was helpful
    original guide here
    thanks jcase for his guide for me to base on

    ota file attached may help some that are bricked

    Attached Files:

    #1 madvane20, Jun 6, 2017
    Last edited: Jun 19, 2017
    bcrichster and James L like this.

    1. Download the Forums for Android™ app!


  2. Mikestony

    Mikestony ~30% Carbon Black ±
    VIP Member

    JustinCase link Error 404, can you please fix?
    Have you tried this on your device? Success?
  3. madvane20

    madvane20 Newbie
    Thread Starter

    that is my device i had to modify his guide for it to work on the warp 7 i can try fix his link but all the info u need is there i can record a video if u like
    bcrichster likes this.
  4. madvane20

    madvane20 Newbie
    Thread Starter

    video is uploading now
    as well this is where i started at https://forum.xda-developers.com/t/zte-warp-7 then find my post
    after i got a mod to get us a forum for the phone someone did post my post with info which i just made my own thread with info easier to find and added here
    #4 madvane20, Jun 6, 2017
    Last edited: Jun 6, 2017
    roadkill42 likes this.
  5. madvane20

    madvane20 Newbie
    Thread Starter

    video posted
    #5 madvane20, Jun 6, 2017
    Last edited: Jun 6, 2017
    roadkill42 and Mikestony like this.
  6. shezzy

    shezzy Android Enthusiast

    After this step:

    10. then type "reboot recovery"

    if u get black screen just hold power down to reboot

    Mine always goes to black screen so I'm forced to reboot. Do you just continue with the guide after rebooting? Because when I test the write mount line it always comes up with an error and when I reboot my phone I lose root.

    Also after "uid=0(root) gid=0(root) context=u:r:shell:s0"

    it shows an error of : syntax error: 'gid=0' unexpected.
  7. madvane20

    madvane20 Newbie
    Thread Starter

    i fixed that it should display after typing id. if u follow the guide kingroot temp root then step by step type reboot recover while in shell still black screen hold power let it reboot continue guide. i added some to guide that may or may not help
    #7 madvane20, Jun 7, 2017
    Last edited: Jun 7, 2017
    roadkill42 likes this.
  8. madvane20

    madvane20 Newbie
    Thread Starter

    everyone get their phones rooted ok added to guide to make things easier
    #8 madvane20, Jun 12, 2017
    Last edited: Jun 13, 2017
  9. madvane20

    madvane20 Newbie
    Thread Starter

    added batch script
  10. shezzy

    shezzy Android Enthusiast

    #10 shezzy, Jun 17, 2017
    Last edited: Jun 17, 2017
  11. madvane20

    madvane20 Newbie
    Thread Starter

    yea on xda some said they couldnt root once they updated so its probly best for now not to update
  12. Warpydoodle

    Warpydoodle Lurker

    Any progress on installing Supersu? Can't you just install supersu after you get root? I am trying to get wifi tether for root working and it does not appear to work with Kingroot.

    Also if anyone knows of working hotspot app it would be appreciated.
  13. Warpydoodle

    Warpydoodle Lurker

    Still looking for a supersu method. Have not tried any methods yet but want to see if anyone has succeeded before giving it a try.
  14. hokiescoot

    hokiescoot Member

    I have a Boost Warp Sync and this phone seems like it would be a nice upgrade with the extra storage. I was thinking about getting one as they are fairly cheap to get, but I am surprised there does not seem to be much interest here. Was hoping it would catch on and folks would start posting recoveries, custom roms and such.
  15. bcrichster

    bcrichster ROMinator

    The problem I'm seeing here, is that it looks like you're having to write the boot.img (kernel) to the recovery partition to get RW capabilities. Just like the original Zmax Root methods (before @hroark13 found the disemmc terminal cmds). No, you can't "just install" SuperSu over KingRoot. Sorry.. Not without a custom recovery like TWRP. You probably don't have RW permissions on the boot partition either, hence the Root difficulty.. Madd props to you guys having gotten Root tho, I really thought it wasn't happening and quit watching the forum. Well done.
  16. madvane20

    madvane20 Newbie
    Thread Starter

    i updated my guide with screen shots on xda will add here later til then heres the link https://forum.xda-developers.com/android/development/zte-permroot-t3618060
    yea at first i didnt think i was gonna get root but kept trying researching reading then figured out a way. hope everyone can root their devices successfully.:)

    if we can find a way to unlock bootloader access then we can try for twrp supersu root etc atm we have no access

ZTE Warp 7 Forum

The ZTE Warp 7 release date was September 2016. Features and Specs include a 5.5" inch screen, 13MP camera, 2GB RAM, processor, and 3000mAh battery.

September 2016
Release Date

Share This Page