1. Are you ready for the Galaxy S20? Here is everything we know so far!
Thread Status:
Not open for further replies.

Root ZTE Zmax Pro Official Root Discussion

Discussion in 'Android Devices' started by anubis2048, Jan 14, 2017.

  1. Unforgiven

    Unforgiven ...eschew obfuscation...
    Moderator

    I addressed it earlier. If you are going to work together for a solution, then you will need to work together. I've determined that the occasional off-topic posts are far less detrimental to the flow of the thread and have less distracted from the overall topic than the incessant "this is off topic" and "mods deal with this" posts.

    The quoted post does not attack other members, addresses the manufacturers ability to potentially collect info from the phone (and I've seen this verified from other ODMs the OP mentioned including Huawei), and quite honestly makes that same point that I am that the calling out and complaining about off topic posts does more harm to the thread staying on topic that the occasional post that isn't laser focused on tactical attempts at gaining root.

    If anyone in this thread isn't satisfied with my non-action please start a thread in the Private Chat with Staff area. Only the person starting the thread, moderators, and admin will be able to see the thread.
     

    Advertisement

  2. Billyckansbar

    Billyckansbar Newbie

    “That could also be the reason why you menaces are having just as hard of a time even soft bricking your phones.”

    This is the reason I asked it deleted. I feel attacked! I just want root and that makes me a menace, how? obviously he is not here to help only to name call. he wanted attention now he has it
     
  3. Beany23

    Beany23 Member

  4. Greysworld007

    Greysworld007 Well-Known Member

  5. loonycgb2

    loonycgb2 Android Enthusiast

    If anyone is willing please get me a copy of /system on there device and let me know what ota you are on.

    Since DD does not work then try

    busybox commands to copy
    cp -a /system /writabledirectory

    That way someone can connect to computer and zip/rar the folder and upload
     
  6. Bret_75

    Bret_75 Lurker

    Hello,
    Everyone First post ever, off topic a tad,
    Excellent thread, Both this and the off topic!
    Had to join up just to get involved.
    Read some great remarks here.
    Topic seemed to get heated, up and down, very interesting pointers on both sides the " nay sayers " and yay sayers"
    I have a simple question if any of you don't mind taking the time to educate me its much appreciated!
    The question of not being able to update no matter wich method of trying.
    tried all options that i could find.
    update always says device rooted or system contents changed..
    I'm on 08 btw
    So if I couldn't update no matter what, I've decided to dig in! ()
    Has anyone been able to force an update? (if same situation as me) as in the normal stock in settings.
    I wanna help toooo!!!
    I have a feeling someone is going to get this!
     
    scary alien likes this.
  7. Greysworld007

    Greysworld007 Well-Known Member

    The answer is: DO NOT UPDATE
     
    Jimmy Dixx likes this.
  8. Jimmy Dixx

    Jimmy Dixx Well-Known Member

    Also if its telling you you are rooted, get a root checker app and run it.
     
    michaelchristian147 likes this.
  9. Tarik Baker

    Tarik Baker Newbie


    ITS AMAZING THIS PHONE CANT BE ROOTED, BUT DOWNLOAD THE WRONG APP, LOL BOOT LOOPS, CRASHES, OVERHEATS ETC LOL WHAT IS ZTE PROTECTING???
     
    messi2050, Ethorbit and Jimmy Dixx like this.
  10. A subsidized handset ;)
     
  11. Bret_75

    Bret_75 Lurker

    Root checker apps are failing because of wrong pathing maybe?
    Some body mentioned in this thread, maybe this is already rooted?
    Has anybody found it?
    If im still on stock there should be no references to super user or 'su' in any area that is readable correct?

    Terminal, see the error?
     

    Attached Files:

    #1762 Bret_75, Mar 27, 2017
    Last edited: Mar 27, 2017
  12. messi2050

    messi2050 Android Enthusiast

    Guys to save the time of anyone checking this thread, there are only 2 possible ways to root this device :
    1) grab the zte signed programmer for this phone so we can flash any file we want in edl mode (same way as the zte axon 7 people did)
    2) find an exploit in the android system e.g dirtycow that enables us from disabling selinux and push our changes (low chance)
     
  13. jhgfrtu

    jhgfrtu Well-Known Member

    Dirtycow will not work due to locked bootloader. A zte engineer who will put his or her job on the line for you guys to obtain root. Never...
    Again I want people to wake up and root another phone. That's all no harm no foul.
     
  14. Mr. Bret_75, it seems as though you have root from these screen shots. Want you to download a superuser management app like supersu, and then try a root checker app. What I can infer from those screenshots is that you have root 100%


    Also if you could go into settings the dev options and post a screen shot here. I would like to know what the option right above debbuging says..

    I very much think that is factory root on this device. And I think it lies in data/data somewhere

    Plus can you tell me what build you're on and what if any rooting apps/exploits you have tried with no success/little success
     
    #1765 BluntBlowin994, Mar 27, 2017
    Last edited: Mar 27, 2017
  15. armandop_

    armandop_ Member

    It seems as if he has the su binaries as the terminal recognizes the su command

     
    BluntBlowin994 likes this.
  16. Precisely and I want to know how he managed to get them into data/data/ nonetheless. Root is closer than we think guys
     
  17. loonycgb2

    loonycgb2 Android Enthusiast

    That su user is a temp user made by androidterm app.

    If he has system root then it would be a # and not a $.

    You can copy a su file to the sdcard and try to run commands against it, but without the right permissions you cant do system wide changes.
     
  18. biledigger

    biledigger Well-Known Member

    It seems the owner process 0666 is the root owner for the phone on my end. 0660 is root host as well. Screenshot_20170328-114728.png
     
    JIMMYHENDRIX likes this.
  19. biledigger

    biledigger Well-Known Member

    I have mentioned this a long time ago when we very first started to work with thia phone. Coild someone please find out what this RIDLClient.exe is and what it is for? I believe they use it to change global parameters from a PC. Screenshot_20170328-115609.png
     
    JIMMYHENDRIX likes this.
  20. loonycgb2

    loonycgb2 Android Enthusiast

    I was asking if someone could send me a full /system copy so i could decompile some files and look for any possible exploits at the system level.

    I already have a kernel compiled and plan to try to make a virtual hdd version of the phone to use in an emulator until i can get a phone to use.
     
  21. Piplup702

    Piplup702 Member

    I'm uploading it to my Google drive right now, will edit this post with a link. Would like to say every file got a operation not permitted error but I think everything is there considering it's like 2.5gbs before I compressed it
     
  22. Jimmy Dixx

    Jimmy Dixx Well-Known Member

    This is what i am getting when I try and copy /system
     

    Attached Files:

  23. Piplup702

    Piplup702 Member

    I got the same error but it still worked
     
  24. Piplup702

    Piplup702 Member

    All files seem to be there
     

    Attached Files:

ZTE Zmax Pro

ZTE Zmax Pro
Loading...

Share This Page

Loading...