2.2 + Root: No audio from internal speaker on phone


Last Updated:

  1. totaldis

    totaldis Well-Known Member This Topic's Starter

    Joined:
    Apr 8, 2010
    Messages:
    57
    Likes Received:
    6
    Hey All!

    Just put the latest ROM on my phone last night and rooted.
    I was all excited adding my apps back and setting the phone up that I neglected to test the phone.

    I received a phone call today and couldn't hear anything. Like the person on the other end muted their phone. Now the kicker, if I put the phone on Speakerphone I can hear the caller just fine (as fine as pre 2.2). I looked around and haven't been able to find any reference to this. Has anyone seen this before or possibly know a fix?

    This is the guide I followed:
    Howto: HTC Droid Incredible Leaked Froyo 2.2 Update - Technology - Jonamerica.com

    Here is the ROM:
    new_leak.zip - 4shared.com - online file sharing and storage - download
     

    Advertisement
  2. totaldis

    totaldis Well-Known Member This Topic's Starter

    Joined:
    Apr 8, 2010
    Messages:
    57
    Likes Received:
    6
    To make this maybe a bit easier to understand/diagnose.

    I have updated this phone twice now hoping it would fix the issue.

    1. Install Radio dinc_ota.zip dinc_ota.zip Baseband (2.05.00.06.11.).
    2. Unrevoked3
    3. ROM
    4. RUU Back to old radio/ROM.
    5. Repeat

    I've noticed that I lose sound after the radio install. So it has nothing to do with the root or ROM.

    I followed these instructions: Howto: HTC Droid Incredible Leaked Froyo 2.2 Update - Technology - Jonamerica.com

    This hasn't happened to anyone else? Is there another dinc_ota.zip everyone is using that I'm not?
     
  3. yojoe600

    yojoe600 Well-Known Member

    Joined:
    Apr 14, 2010
    Messages:
    2,188
    Likes Received:
    207
    try a different rom and that will tell you if its the rom or not
     
    totaldis likes this.
  4. totaldis

    totaldis Well-Known Member This Topic's Starter

    Joined:
    Apr 8, 2010
    Messages:
    57
    Likes Received:
    6
    I know it's not the ROM, it is caused by the radio update linked above.
     
  5. josh5137

    josh5137 New Member

    Joined:
    Aug 9, 2010
    Messages:
    1
    Likes Received:
    0
    this happened to my incredible too once i did the radio update before i ever changed the rom i cant find anything about fixing it
     
  6. sturvey

    sturvey New Member

    Joined:
    May 4, 2010
    Messages:
    4
    Likes Received:
    1
    Same problem here. Had to go back to Radio v1. Definitely a v2 problem. Looked around other forums, see the same thing going, no fix that I've found.
     
  7. totaldis

    totaldis Well-Known Member This Topic's Starter

    Joined:
    Apr 8, 2010
    Messages:
    57
    Likes Received:
    6
    Oooh I love that my thread was resurrected! Yea, this is what is stopping me from running Froyo right now. I wish I could but I don't have an answer for this. I asked over in XDA Forums as well with no responses.

    Any clever users out there know what's going on?

    I think I'm going to try the new radio baseband 2.15 and see if I have the same problem.. Will report back.
     
  8. Jabul

    Jabul Member

    Joined:
    May 22, 2010
    Messages:
    8
    Likes Received:
    0
    same problem here. I tried both 2.xx radios and they both did the same thing to the internal speaker. I had to revert back to 1.xx radio and that fixed the problem.
    I have found no other reference to this problem. Must be rare which really sucks. I was looking forward to the upgrade.
     
  9. pkmn760

    pkmn760 Well-Known Member

    Joined:
    Apr 22, 2010
    Messages:
    155
    Likes Received:
    29
    This may not help but froyo requires the 2.15 radio to be fully functional, aside from that try installing a new rom and maybe advanced nandroid restore just the system files from a rom that worked?

    DISCLAIMER: make sure it wont do anything bad, it is just an idea and I dont know if it will work or brick your phone :)
     
  10. Jabul

    Jabul Member

    Joined:
    May 22, 2010
    Messages:
    8
    Likes Received:
    0
    actually sounds like a good idea. I'll try this when I get off work. thanks bro
     
  11. Rudelou

    Rudelou New Member

    Joined:
    Aug 26, 2010
    Messages:
    1
    Likes Received:
    0
    I'm going through the exact same thing. I'm still trying to figure out a way to downgrade my radio. Anybody know the easiest way to do this without breaking anything else lol.
     
  12. totaldis

    totaldis Well-Known Member This Topic's Starter

    Joined:
    Apr 8, 2010
    Messages:
    57
    Likes Received:
    6
    Yup, tried new baseband 2.15 to test the audio, still same problem. I just don't know what gives? I guess I will just have to wait for the OTA to come over. Which means I will have to revert back to original radio and stock rom w/o root.
     
  13. redlegend

    redlegend Active Member

    Joined:
    Apr 29, 2010
    Messages:
    39
    Likes Received:
    0
    I'm having the same issue. Used the 2.2 RUU with 2.15 radio, now no sound from internal speaker. I still can't figure out how to go back to 2.1 or 1.x radio (though haven't spent enough time searching the forums yet, just worried about not being rooted since I used the RUU).

    pkmn760, what do you mean Froyo won't be fully functional without 2.15? Do you know what will be missing? The old radio worked fine for me, service and speed wise, I really just wanted the software upgrade. thanks
     
  14. totaldis

    totaldis Well-Known Member This Topic's Starter

    Joined:
    Apr 8, 2010
    Messages:
    57
    Likes Received:
    6
    So I applied the OTA update hoping that all the previous leaks baseband just had something wrong in them which was causing a select number of phones to have no audio from internal speaker.

    Nope.

    Latest and greatest OTA official from Google w/ baseband 2.15 still has the audio issue. This tells me a couple of things.

    1. More people may start showing up that were too scared to upgrade before the official OTA with the same problem.

    2. I'm going to have to revert my phone to original 2.1 and S-ON so I can return use it in the mean time while I setup some sort of return with Verizon.

    Before assumptions are made, unrevoked forever was not run before this all was tested (i.e., not the cause). I have the issue with both 2.05 and 2.15 radio.

    Still looking for some gurus for an inside tip... but I fear a return is probably in order.
     
  15. Miami211

    Miami211 Well-Known Member

    Joined:
    Dec 8, 2009
    Messages:
    56
    Likes Received:
    2
    same problem here :( do the bluetooth headpieces work?
     
  16. totaldis

    totaldis Well-Known Member This Topic's Starter

    Joined:
    Apr 8, 2010
    Messages:
    57
    Likes Received:
    6
    I haven't verified if BT works, but the speaker phone works.
     
  17. woop

    woop novacane (OFWGKTA) VIP Member

    Joined:
    Feb 7, 2010
    Messages:
    5,053
    Likes Received:
    1,542
    From what I've been hearing, it isn't just people who manually installed the OTA, but is also affecting people who got the OTA thru Verizon.
     
  18. redlegend

    redlegend Active Member

    Joined:
    Apr 29, 2010
    Messages:
    39
    Likes Received:
    0
    I can confirm this, I just received the OTA, updated, and now no sound from internal speaker. calling VZW for support now
     
  19. Miami211

    Miami211 Well-Known Member

    Joined:
    Dec 8, 2009
    Messages:
    56
    Likes Received:
    2
    let us know what happens!
     
  20. iowabowtech

    iowabowtech root@android:/ #

    Joined:
    May 2, 2010
    Messages:
    12,067
    Likes Received:
    8,534
    Very interesting. FWIW, I've been on both the 2.05 radio linked above and the 2.15 radio without issue on either. Seems like there's another variable that's eluding us.

    Has anybody gone back to the original stock radio to see if the problem remained?
     
  21. redlegend

    redlegend Active Member

    Joined:
    Apr 29, 2010
    Messages:
    39
    Likes Received:
    0
    after 30 min with tech support, they didn't do anything I couldn't have done, disappeared to consult with others, came back and offered to send me a replacement. I asked for a higher level tech, but was told there's nothing they'll be able to do either, but that they could send me a new phone. I told them that it's not a hardware issue, as the speaker worked fine with 2.1, but since the udpate an hour ago, no speaker. I finally gave up and told them fine, send me another. Perhaps it's the way the new software interacts with particular devices? perhaps ones that have a slightly different internal component, manufactured by someone else? i don't know, just throwing out ideas. now i have to worry about what kind of screen the replacement will come with... off to research whether or not I'll get an LCD or AMOLED...

    iowa, yes, i've gone back to stock (rom and radio) and sound returns to speaker. it seems to be only SOME devices with the 2.2. FWIW, I had the same issue when I tried to run one of the early leaked OTAs AND the 2.2 RUU. I thought it was something specific to something 'unofficial', but when i got the legit notice via VZW, i thought 'alright, now the true test' and these are the results - still an issue. i'm baffled. thanks to all who've helped, for now, reverting to 2.1...
     
  22. woop

    woop novacane (OFWGKTA) VIP Member

    Joined:
    Feb 7, 2010
    Messages:
    5,053
    Likes Received:
    1,542
  23. redlegend

    redlegend Active Member

    Joined:
    Apr 29, 2010
    Messages:
    39
    Likes Received:
    0
    i wonder if we could start an "official those-who-lose-ear-peice-volume-with-2.2 thread" so that all of us who are experiencing this issue can post what steps/solutions VZW is offering to everyone. it seems to be a fairly substantial amount, definitely in the minority though, of people. it's definitely a software thing, so I'd hate to send back my original for a refurb only for them to figure out in a couple weeks how to fix it. i've got the screen protector applied PERFECTLY to mine now, a first for me... I'd hate to give that up over a software issue
     
  24. woop

    woop novacane (OFWGKTA) VIP Member

    Joined:
    Feb 7, 2010
    Messages:
    5,053
    Likes Received:
    1,542
    Thats what I was on the fence about too, as its obviously a software issue (since my phone worked fine before). But at this point in time, I really didn't have a choice. I wasn't about to use my speakerphone in the office for phonecalls and the only option I had was to send my original Incredible back for a refurb.
     
  25. redlegend

    redlegend Active Member

    Joined:
    Apr 29, 2010
    Messages:
    39
    Likes Received:
    0
    i went ahead and did it anyway, since i figured the broader discussion belonged outside the 'Root' subsection. although I suppose it could be considered a troubleshooting topic. youre a mod though, I guess you can make that call ;) and yes, I know what you mean, I actually had to take a call in my office today on speakerphone, as I dashed for the conference room...
     

Share This Page

Loading...