Root All-One-Guide to Rooting, Deodexing, and Installing a Custom ROM/Theme (And How to Unbrick Droid X)

Discussion in 'Android Devices' started by mygamjaishot, Oct 20, 2010.

  1. hob0d4n

    hob0d4n Well-Known Member
    36

    Jan 4, 2010
    159
    7
    36
    California
    where can i find the usb drivers so it can be found in windows 7?
     

    Advertisement
  2. hob0d4n

    hob0d4n Well-Known Member
    36

    Jan 4, 2010
    159
    7
    36
    California
    nevermind found it
     
  3. t0adman

    t0adman Well-Known Member
    26

    Aug 25, 2010
    94
    3
    26
    Yep, you did. Now that the first post has been updated (it wasn't THAT bad to begin with) I edited my post. I agree that it's a very helpful guide and I'm grateful to the OP for sharing.
     
  4. t0adman

    t0adman Well-Known Member
    26

    Aug 25, 2010
    94
    3
    26
    Where? I'm having brutal MTB USB Driver failures. :eek:
     
  5. mygamjaishot

    mygamjaishot Active Member
    33

    Sep 7, 2010
    43
    53
    33
    SF Bay Area
    thanks for the suggestions!
     
  6. hob0d4n

    hob0d4n Well-Known Member
    36

    Jan 4, 2010
    159
    7
    36
    California
  7. hob0d4n

    hob0d4n Well-Known Member
    36

    Jan 4, 2010
    159
    7
    36
    California
    ok so i rooted my X then dl'ed Droid X Recovery Bootstrap and i allowed permission. Then i backed it up and now when i try to restore it had MD5 mismatch. Helppp pleasee
     
  8. wbmason1

    wbmason1 New Member
    5

    Mar 4, 2010
    1
    0
    5
    Thanks for the great post, REALLY helpful!!! I just have a couple questions:

    1) When changing roms, do I go back into bootstrap and run bootstrap recovery EACH TIME or do I just do it the first time?

    2) When I try to make a backup with Rom Manager, it just reboots to the M logo and hangs there until I do a battery pull, does anyone have any suggestions on how to fix this? I can make a backup through bootstrap but I can't name it or anything.

    I think that's all for now, thank you again for all your help!!!!!
    Slacker

    EDIT: After installing the 928 rom as suggested, when it went to reboot the screen stayed on the M logo but the phone was running as normal. I got an email notification and everything! How the heck does that work? lol I did a battery pull and it's rebooting fine now. The rom took even though I had to do a battery pull, CRAZY!!!
     
  9. Steven58

    Steven58 Reformed PH
    VIP Member
    3,823

    Feb 19, 2010
    32,921
    25,271
    3,823
    Male
    +1 to OP for being helpful. Thank you! (Makes my job easier! ;))
     
  10. ECFfighter7232

    ECFfighter7232 Well-Known Member
    163

    Jul 21, 2010
    1,493
    336
    163
    Maryland
    did you rename the backup? if so did you put any spaces in the name? if the answer to both is yes then take the spaces away.
     
  11. Bobt39

    Bobt39 New Member
    5

    Oct 27, 2010
    2
    0
    5
    Thanks for the guide - I successfully rooted my phone. However, I am having an issue with the deodexing. Everything goes well until I install the 928 theme from the zip file. It reports that it was successful, and so I select 'reboot system now'. It reboots and freezes at the M. This has happened twice, but both times I have been able to recover by pulling the battery, then restoring my old (rooted, not deodexed) rom.

    Can anyone help me with this?
     
  12. mygamjaishot

    mygamjaishot Active Member
    33

    Sep 7, 2010
    43
    53
    33
    SF Bay Area
    Are you working with stock froyo 2.2? or a custom rom you installed earlier? It's possible that the 928 file you downloaded could be corrupted (I downloaded my file from the same site I provided in the guide) so you could try redownloading the file. Otherwise, if you don't want to mess around with it a fix would be to dl the stock froyo 2.2 from Home and reinstall the stock SBF file through RSD lite. The instructions are found in the section labeled "unbricking your droid x".
    Cheers,
    E
     
  13. Bobt39

    Bobt39 New Member
    5

    Oct 27, 2010
    2
    0
    5
    I started with stock froyo. I will try redownloading the 928 file.

    Edit: It worked!
     
  14. t0adman

    t0adman Well-Known Member
    26

    Aug 25, 2010
    94
    3
    26
  15. cdmoore74

    cdmoore74 Well-Known Member
    16

    Jul 19, 2010
    64
    3
    16
    Got a question. Everything is working great but I have the itch to try a different rom. Should I restore the backup I made first and use "928DroidBlackGlassX-DroidX-OTA2315-DeOdexEERR-THEME.ZIP" again and then follow the rom install instructions? I assume when you deodex the process is not permanent and can be undone with your backup.
     
  16. mikepic

    mikepic Well-Known Member
    53

    Jul 17, 2010
    220
    53
    53
    Analyst
    CT
    I've seen a lot of "how to" posts but this one gave me the confidence to actually go through with it.

    Thanks a ton! I've successfully applied some custom roms thanks to you OP.
     
  17. mygamjaishot

    mygamjaishot Active Member
    33

    Sep 7, 2010
    43
    53
    33
    SF Bay Area
    in order to install a different ROM you most likely will have to be deodexed so I would leave the 928 theme with deodex installed and create a backup of that then just install your new deodexed ROM using bootstrap over the one you currently have installed. If anything goes wrong, you have either of your backups to fall back to.
     
  18. Weegie5

    Weegie5 Member
    15

    Jul 20, 2010
    21
    0
    15
    engineer
    Lehigh Valley, PA
    I've been rooted for several weeks now and am finally interested in installing some ROMs/themes. I saw this thread and the great feedback it got and thought I'd give it a go. Unfortunately the 928 BG install didn't go as scripted:

     
  19. mxsjw

    mxsjw Well-Known Member
    143

    Jul 7, 2010
    1,311
    171
    143
    Clarification for you on 5 and 6.

    make sure you are pressing "Bootstrap Recovery" 1st
    wait for the pop up that says "Success!" and press "OK"
    now you can press "Reboot Recovery"...it will reboot and you should be into clockwork
     
  20. mygamjaishot

    mygamjaishot Active Member
    33

    Sep 7, 2010
    43
    53
    33
    SF Bay Area
    @Weegie5
    Try the transfer via USB sometimes a file can become corrupted through wireless transfer. Some people have been having issues with the 928 zip file itself but after redownloading the file and placing it on the root of the sdcard via usb they seemed to have no issues.

    Also, there may have been a step that you missed with respect to your Bootstrap recovery issue . I think mxsjw covered that in the post above. Good luck!
    E
     
  21. dhoffman1421

    dhoffman1421 Well-Known Member
    78

    Jul 27, 2010
    620
    49
    78
    Software Professional
    SF Bay Area
    Damn that traps a lot of people, me included.

    The 928 BGX file is huge, I would not rely on a file obtained via Bluetooth.
     
  22. mygamjaishot

    mygamjaishot Active Member
    33

    Sep 7, 2010
    43
    53
    33
    SF Bay Area
    yeah the file is fairly big for BT xfer so yeah there's a big chance that was the problem
     
  23. bigshotproducer

    bigshotproducer Well-Known Member
    53

    Jul 1, 2010
    473
    25
    53
    Television Producer
    Virginia Beach
    Thanks so much for this post! I was just what I was looking for! I just rooted But ROM's were making me a bit unsure! This made it seem easy...thanks again!!
     
  24. lancedriskell

    lancedriskell Well-Known Member
    26

    Aug 16, 2010
    63
    6
    26
    Project Manager
    Alabama
    this is the last thing on the command prompt, after i double clicked the doroot file... (Step 7)

    adb connection will be reset. restart the adb server on desktop and re-login. could not kill pid 20091: no such process

    what do i do now?
     
  25. droid507

    droid507 Active Member
    15

    Sep 19, 2010
    39
    0
    15
    worked like a charm...I got it to work without any trouble. Thanks to OP for dumbing it down for ppl like me..

    Much appreciated
     

Share This Page

Loading...