1. Introducing Channels - a new way to chat with other Android users!
    Dismiss Notice

Android 2.0 Exchange Issue


Last Updated:

  1. jhzafrani

    jhzafrani Member This Topic's Starter

    Joined:
    Nov 18, 2009
    Messages:
    10
    Likes Received:
    0
    Here is an interesting issue. I did a hard reset of the phone earlier today. Now, when setting up the exchange account, it works fine and brings in emails but only up to the time when I reset the phone. Any email past 7:15 does not show up. Forcing a refresh comes up with a message saying that it is not able to connect to exchange.

    Any ideas?

    Thanks in advance,

    Jim
     

    Advertisement
  2. jhzafrani

    jhzafrani Member This Topic's Starter

    Joined:
    Nov 18, 2009
    Messages:
    10
    Likes Received:
    0
    Solved it. It was a bad email message. Discovered it when the exchange backup came back with an error about that message. Deleted the message from the mailbox and the phone worked just fine.
     
  3. Dochavoc

    Dochavoc New Member

    Joined:
    Nov 20, 2009
    Messages:
    4
    Likes Received:
    0
    I thought we could keep this as a "Exchange Problem" thread. Glad you found your solution.

    My problem is that I cannot use my Droid to set my "Out of Office" message on my exchange account.

    Seems like that is pretty important for people who are checking e-mail with their phone. Has anyone else noticed this? Or am I just missing something?
     
  4. alset

    alset New Member

    Joined:
    Dec 1, 2009
    Messages:
    2
    Likes Received:
    0
    I'm curious: are you guys using the built in Exchange with Android?

    I am confused about how the carriers handle the Exchange accounts...
    I am not a "business customer" with Verizon, and thus am not paying the extra $15 a month for "corporate email" services. I tried to sync the built in Exchange with my Exchange server, but it never worked (had issues with "invalid login name/password").

    To circumvent this situation, I downloaded the app Exchange by TouchDown (NitroDesk, Inc.) and was successfully connected and synced with my Exchange server in under a minute.

    Is it probable that the built in Exchange service has been blocked (by Verizon) because I am not a "business customer" or paying the $15 a month extra for the Exchange email service?
     
  5. alset

    alset New Member

    Joined:
    Dec 1, 2009
    Messages:
    2
    Likes Received:
    0
    I just tested out the "Out of Office" feature in the Exchange by TouchDown app and it worked.

    There is a 5 day free trial of the app, and then I believe it costs $19 to purchase the full version. I figure a $19 one-time purchase of this app is much cheaper than a recurring $15 fee paid to Verizon to have access to corporate Exchange service.
     
  6. barry99705

    barry99705 Well-Known Member

    Joined:
    Nov 9, 2009
    Messages:
    876
    Likes Received:
    20
    If your work place has an exchange server you can connect directly to it, no extra charges from Verizon. You only have to pay the business fees if you want Verizon to be your exchange server. As for the out of office thing, I just log into webmail with the browser to set it. Outlook doesn't even do it right with our exchange server. It's exchange 2003 by the way.
     
  7. cdodge

    cdodge Well-Known Member

    Joined:
    Nov 24, 2009
    Messages:
    358
    Likes Received:
    14
    I liked touchdown as well but it kept duplicating my contacts every time i copy them to the phone contacts. I wish they were able to sync directly to the phone contacts.

    i was going to use touchdown and have it sync mail, calendar, tasks, only and then have the built in exchange interface still running to sync contacts but i would imagine having both accounts setup with push e-mail would kill the battery fairly quickly

    there is yet to be a good "full" exchange option for android. Hope it gets released soon or i may have to go back to my winmo phone :(
     
  8. gmauser71

    gmauser71 Member

    Joined:
    May 3, 2010
    Messages:
    10
    Likes Received:
    0
    out of office issue here too on HTC Incredible. Says unable to get your out of office settings from the exhcnage server right now. Please try again later......
     
  9. vadakr

    vadakr New Member

    Joined:
    Mar 1, 2010
    Messages:
    3
    Likes Received:
    0
    It works great on EXCH 2003. There's a free version of the app that checks whether the app can talk properly with your EXCH server. If it shows you your Out of Office status and message correctly, then buy the paid version of the app (it's only $0.99).
     
  10. uabtodd

    uabtodd Member

    Joined:
    May 30, 2010
    Messages:
    8
    Likes Received:
    0
    a co worker of mine got a droid yesterday and I am trying to help him set it up. we got his exchange email working this morning while using his verizon data connection. he later set his phone up to access the office wifi connection, and now his exchange email will not sync. If he turns wifi off and forces his phone to use his mobile data, it works. I know the reason for this is because the server address to access the exchange server is different if you are trying to access it from inside the office network as opposed to trying to access it from another network.
    my question is this, is there a setting that he can toggle to make just his email connect via verizons network, and keep everything else connecting via wifi?
    On my nokia, in my mail for exchange settings, i have a setting for default access point, and i set it to AT&T internet and can browse the web and what not over the office wifi and have my exchange keep working over 3g. just wondering if the droid has a similar setting somewhere.
     
  11. paradox183

    paradox183 Well-Known Member

    Joined:
    May 31, 2010
    Messages:
    104
    Likes Received:
    12
    The server address would only be set up wrong if his phone was configured to use the internal address. Under that configuration the phone would only be working on the internal wifi and not 3G. Instead, your coworker's problem is the exact opposite.

    Is anyone else having this issue at your company? If so, chances are this is actually a configuration issue with your company's LAN/router/firewall. If your firewall does not have "loopback" connections enabled (where a device on the LAN can access another device on the LAN via that device's WAN address) then the exact scenario you mentioned in your post will play out. I know this because I had to enable loopback connections on my network at work in order for people to use their Exchange sync on the internal wifi.

    Ask your IT admin about this and point them to this document - Technical Note - SonicOS Enhanced 2.0: Configuring DNS NAT Loopback - File Info & Download - SonicWALL, Inc.. This applies specifically for SonicWALL devices on an old firmware, but the basic concept should apply to any make of network appliance. In the PDF, "LAN Server Object" refers to your Exchange server's internal IP address and "WAN Server Object" refers to your Exchange server's Internet/external IP address.
     

Share This Page

Loading...