android mid 7 inch not booting?


Last Updated: 2012-12-09 12:41:33
  1. trunks217

    trunks217 New Member

    hello! I have a problem, when ever i open my android mid 7 inch tablet it opens with the android man the it goes into a picture saying android until it looses battery. I tried pressing a the volume buttons plus the power bottum and i see the android man with a "!" on him.

    I would post some pics but i dont know how.
    This is my first post so i will post pics after.

    Advertisement
  2. Digital Controller

    Digital Controller The Real Bass Creator Guide

    First off welcome to the forums :)

    So have you tried accessing recovery mode...it is done by holding volume up/down then pressing power. I see you tried but please have patience and try again.

    Please get back to me with results.

    Thread moved into General Tablet Talk
    mikedt likes this.
  3. trunks217

    trunks217 New Member

    its the same thing. thanks for greeting me btw. I hooked it up to my laptop but it says system missing something i think.
  4. mikedt

    mikedt 你好 Guide

    Seems to be a no-brand budget Chinese device of unknown manufacture. Given what it is, I suspect the software has become corrupted, damaged or erased, rendering it bricked and unbootable. The software ROM would have to be re-loaded, which is more than likely not available. Probably best to return it for refund or replacement.
  5. trunks217

    trunks217 New Member

    Thanks! We got it free so returning it would be a problem :p
    Can i bring it to the nearest electronic shop?
  6. mikedt

    mikedt 你好 Guide

    So it wasn't that Ebay vendor you posted earlier? Where it says item location: Slough, United Kingdom, it's more likely Shenzhen or Hong Kong, China. :rolleyes:

    Was it a gift or a prize or something? Contact the person who gave it you, see where they got it.

    I'm sure an electronic store, e.g. Best Buy, wouldn't be interested, unless they sold it to you.

Share This Page