Apps wont openSupport


Last Updated:

  1. lusafdie

    lusafdie Member This Topic's Starter

    Joined:
    Mar 10, 2013
    Messages:
    7
    Likes Received:
    1
    Hi, some of the apps I downloaded recently form the play store won't open on my phone (motorola XT890, razr i): I click, a loading sceen from the app or just a black screen appears for about 10 seconds and then it takes me back to the original home screen. One of the apps I'm having trouble with was working fine until about two weeks ago, others weren't opening from the beginning.

    I tried uninstaling and installing, I tried a factory reset (which made me lose all my pictures), I don't know what to do anymore! Anyone had this happen to them or know what can it be/how to fix it?

    Thanks!
     

    Advertisement
  2. argedion

    argedion The TechnoFrog Moderator

    Joined:
    Jun 20, 2011
    Messages:
    6,358
    Likes Received:
    6,254
    all i can think of is that the apps are not compatible with your device. Can you tell us the names of the apps. Could be others have had trouble with these apps.
     
  3. lusafdie

    lusafdie Member This Topic's Starter

    Joined:
    Mar 10, 2013
    Messages:
    7
    Likes Received:
    1

    I thought about that too, but in the play store they appear as compatible. Candy crush saga wouldnt work from the beginning and viber stopped working a few weeks ago. I've had this happen with some other apps I can't remember but deleted after not being are to use them.
     
  4. ocnbrze

    ocnbrze DON'T PANIC!!!!!!!!! Moderator

    Joined:
    May 13, 2010
    Messages:
    23,597
    Likes Received:
    14,436
    moved you to the android lounge.

    did you take any ota's recently? sometime when you go from gingerbread to ics for example some of the apps are not compatible any more.
     
  5. jmar

    jmar Nexican VIP Member

    Joined:
    Sep 27, 2010
    Messages:
    4,851
    Likes Received:
    3,131
    My belief here is that you are using an Intel x86 based phone and not ARM based. Someone correct me if I am wrong but couldn't this be the root of the problem?

    For example, Koush recently release his Superuser app on the Play Store and in the description he purposely points out that it has full compatibility with ARM and x86 chipsets.

    Food for thought.

    jmar
     
    argedion likes this.
  6. lusafdie

    lusafdie Member This Topic's Starter

    Joined:
    Mar 10, 2013
    Messages:
    7
    Likes Received:
    1
    I don't know what otas are :/, but I didn't really do any updates or anything of the sort.

    And yes, I do have an Intel based phone, so jmartino you could be right on your comment. Ill look into that. (I don't know if it explains why Viber worked until a few weeks ago, but you could be right)
     
  7. jmar

    jmar Nexican VIP Member

    Joined:
    Sep 27, 2010
    Messages:
    4,851
    Likes Received:
    3,131
    I'm just speculating but it seems logical to me. I remember reading about compatibility issues with Intel based phones. My understanding that app devs add some code in the app for compatibility sake. Now I'm no dev and don't claim knowledge, but I do read a lot of Android articles, daily.

    Gonna move your thread to the RAZRi forum. Hope that's cool. It will get the right set of eyes on this issue.
     
    ocnbrze and lusafdie like this.
  8. jmar

    jmar Nexican VIP Member

    Joined:
    Sep 27, 2010
    Messages:
    4,851
    Likes Received:
    3,131
    You're right, Viber not working out of the blue seems weird and probably unrelated. Sounds like the app dev messed up something. I'm subscribed to this thread so I will keep an eye out for ya.
     
    ocnbrze and lusafdie like this.
  9. flashsam

    flashsam Well-Known Member

    Joined:
    Oct 1, 2010
    Messages:
    67
    Likes Received:
    11
    Candy Crush doesn't work with Intel phones. The specs on their website say it must be Arm processer only. I've emailed them to find out if they intend to update their app to work with Intel but no reply as yet.

    Viber updated their app the other week and since then it is not compatible with Intel anymore. They are aware of the issue and have released a new 2.3.5 version of Viber which is compatible but not from the play store.

    See link below to get the new Viber apk which does work with our phone:
    http://forum.xda-developers.com/showthread.php?t=2182205#post38974676
     
    jmar and lusafdie like this.

Share This Page

Loading...