1. Introducing Channels - a new way to chat with other Android users!
    Dismiss Notice

Astro File Manager: please help with networking setup (SMB Module on Windows Server)


Last Updated:

  1. Dr_koolaid

    Dr_koolaid New Member This Topic's Starter

    Joined:
    Apr 3, 2010
    Messages:
    3
    Likes Received:
    4
    I'm at a loss trying to get Astro to communicate with my Windows XP home computer. I downloaded the SMB module for my MotoDroid, but am not really clear on how to configure my Windows Networking settings and what exactly needs to be entered in Astro's configuration settings. Is there a guide on how to do this on the web?.. if so, I haven't been able to find it.

    Any help would be greatly appreciated.

    I've also contacted Metago.. maybe they'll help.
     

    Advertisement
  2. UncleMike

    UncleMike Well-Known Member

    Joined:
    Nov 15, 2009
    Messages:
    2,319
    Likes Received:
    482
    It's working fine for me. What goes in each field seems straight forward, but I did leave the Domain blank (I have no domain controller) and Directory blank (I assume this is a subdirectory of the share, but I'm not sure), so you might want to try leaving them blank to simplify things to start. Also, I DID NOT enter any leading or trailing backslashes in any of the fields. The only other thing I can suggest is making sure you're on Wifi, and to double check your user name and password.

    Edit: I just realized I missed big part of your message. Your Windows XP machine must have sharing enabled, and possibly require that simple sharing be disabled. You'll also need to share at least one folder, and grant (at a minimum) read permission to the share for the user name you want to use from your phone.

    If you have a home network, I would make sure that file sharing works between PCs before bringing your phone and/or Astro into the picture.
     
    Dr_koolaid likes this.
  3. Dr_koolaid

    Dr_koolaid New Member This Topic's Starter

    Joined:
    Apr 3, 2010
    Messages:
    3
    Likes Received:
    4
    Thanks. I guess I didn't realize that server= my ip address. I got it working. here's the reply I got from Metago:

    We're still working on the SMB docs. Here's a quick start guide. Let me know if you have specific questions.


    SMB Quick start:

    Click the Network button in the toolbar (far right), click the New button, select Windows Server and enter these fields:


    Label: icon label (optional)
    Server: remote IP address (required)
    Share: a windows share (optional)
    Domain: a windows domain (optional)
    Directory: a directory under the share (optional)
    User Name: (required)
    Password: (required)


    You can click Test to try the settings and then click Save. Now click the newly created icon and you should be connected to your server. If you have problems, try entering only the required fields first and then enter optional fields one at a time to narrow down the problem.
     
    latinmaxima, aj88cab and Inno like this.
  4. daft009

    daft009 Member

    Joined:
    Dec 15, 2009
    Messages:
    6
    Likes Received:
    0
    is there a way to get this to work with just simple file sharing enabled?
    so no username/password is required?
     
  5. airbrat

    airbrat New Member

    Joined:
    Jun 29, 2010
    Messages:
    1
    Likes Received:
    0
    I'm decent at setting up windows networking, but not too familiar with linux/smb...yet.

    Dumb Question: Are you talking about the IP of the phone or the computer you're trying to connect with?

    Thanks
     
  6. ionizer

    ionizer Well-Known Member

    Joined:
    May 12, 2010
    Messages:
    56
    Likes Received:
    10
    the key for me was switching the server to an ip address
    i had been using the host name, thanks
     
  7. vaccdroid

    vaccdroid Well-Known Member

    Joined:
    Jun 6, 2010
    Messages:
    118
    Likes Received:
    11
    WHat is the Username and Password for. I have no passwords to log onto my PC and what is the user name. PC user name ??
     
  8. dijitz

    dijitz New Member

    Joined:
    Jul 8, 2010
    Messages:
    4
    Likes Received:
    2
    I second this question as I am not very experienced with networking. I have no passwords for the PC or shared folders, so I am not sure what to enter in these fields.
     
  9. 0sync0

    0sync0 Well-Known Member

    Joined:
    May 22, 2010
    Messages:
    107
    Likes Received:
    0
    I like Astro but I use ES File Explorer for accessing files on my network. With ES it was very easy to browse my network and bookmark shared drives for future access.
     
  10. Dr_koolaid

    Dr_koolaid New Member This Topic's Starter

    Joined:
    Apr 3, 2010
    Messages:
    3
    Likes Received:
    4

    You can't have a home network if you don't share folders. Also, I believe you must use Windows login and set user accounts/permissions. Just set up one and use that as your username. If you don't set a password, then leave this field blank.
     
    dijitz likes this.
  11. begem0t

    begem0t New Member

    Joined:
    Jun 24, 2010
    Messages:
    1
    Likes Received:
    1
    The easiest solution - install Estrongs File Explorer (ES File Explorer). Then just browse the windows network.

    Added bonus is that it has Task manager and Application Manager.
     
    goracin6 likes this.
  12. goracin6

    goracin6 Member

    Joined:
    Jun 13, 2010
    Messages:
    8
    Likes Received:
    0
    The easiest solution - install Estrongs File Explorer (ES File Explorer). Then just browse the windows network.

    I could not get Astro to work, so I went w/ ES F/E. This works great! Done a scan, found my desk top, viewed all files and folders that I wanted to...BUT cannot open any document. Word, Excel, PDF, MP3, etc. Everytime I click on the files it says "Sorry, No Application Installed." I can open these types of documents that are attached to an email.
    Anyone have any suggestions??
     
  13. lenardzelig

    lenardzelig New Member

    Joined:
    Aug 22, 2010
    Messages:
    4
    Likes Received:
    0
    I can get Astro to work just fine if I'm connected to my home router via wireless and use my laptop's local IP address as the network address. Anyone got any tips on how to get connectivity using 3G from a remote location. I'm guessing it's got something to do with using my router IP address and portforwarding the incoming connection to the laptop's local IP address but I'm reaching (=way beyond) the limits of my knowledge. Anyone able to help me out, please?
     
  14. speedy1979

    speedy1979 Member

    Joined:
    Aug 22, 2010
    Messages:
    8
    Likes Received:
    1
    I can use Estrongs File Explorers LAN function just fine. But when I try using Astro File Explorer I receive the following error message.

    [​IMG]

    Does anybody know what this means.
     
  15. Schenley

    Schenley New Member

    Joined:
    Apr 6, 2010
    Messages:
    2
    Likes Received:
    0
    It means you need to use Estrongs... :D



    That's how I fixed it.
     
  16. speedy1979

    speedy1979 Member

    Joined:
    Aug 22, 2010
    Messages:
    8
    Likes Received:
    1
    I guess I'll continue using Estrongs.
     
  17. anthgav

    anthgav Well-Known Member

    Joined:
    Apr 20, 2010
    Messages:
    177
    Likes Received:
    24
    To get it to work you probably have to go into your routers configuration screen and open up port 445 and point it to the IP address of your server whether that be PC or a storage unit. Port 445 is required for SMB protocol. When setting the file explorer to access the server use IP address not name of server.

    I am sure this will solve your problem.
     
  18. ascl

    ascl New Member

    Joined:
    Sep 12, 2010
    Messages:
    1
    Likes Received:
    0
    Now it's working!!!
    I had the same problem and spent hours to fix the problem..
    My settings in windows 7 are the default ones.
    The only thing I had to change to make it work was to add the forward slash after the IP.
    Old config:
    Server:192.168.1.3
    New Config:
    Server:192.168.1.3/

    That solved the problem.
    Remember to set the username and password in the phone the way you have in your computer.

    I think the router has nothing to do with the problem, because if you are connected using wifi, the router does not apply any filter to your packets to switch packets in the internal network. The only thing you have to be sure of, is to be connected to the wifi from your phone.
     
  19. oliverjames

    oliverjames Member

    Joined:
    Jul 29, 2010
    Messages:
    12
    Likes Received:
    1
    I have finally connected my HTC Desire to a computer running XP family edition, on my home/office network.

    These are the basic settings in Astro SMB:

    Select "New Connection"
    Connection type <SMB>
    select:-
    Server, then enter the IP address in format< xxx.xxx.xxx.xxx\> of the XP machine one wishes to connect to, then select
    User Name, and enter <guest>

    Then select "test". Hopefully this will work for you also, in which case select "save" to place an icon on your Astro network page.

    All other entries blank; the Label entry can be completed by entering the name of the connection but this wasn't required to get connected.

    The connection came up quickly and gave access to all directories on the XP machine that have been configured to allow network sharing.

    I cannot stream over this connection but can copy files from the XP machine to my HTC.
     
  20. drksilenc

    drksilenc Well-Known Member

    Joined:
    Apr 16, 2010
    Messages:
    420
    Likes Received:
    68
    except for the main reason for this to work for me is viewing photos and guess what ESTRONGS is broke for that reason so quit spewing estrongs out your mouth
     
  21. TravisZ

    TravisZ Active Member

    Joined:
    Sep 18, 2010
    Messages:
    26
    Likes Received:
    0
    I just installed and can view photos on networked drives with no problem but trying to open an avi or mkv just give the no application error
     
  22. Flavy

    Flavy Active Member

    Joined:
    May 10, 2010
    Messages:
    27
    Likes Received:
    1
    I'm also getting the smbexception message. Did anyone find a solution to this error? I'm using Windows 7 and have a folder shared. Thanks for the help.
     
  23. esmann

    esmann New Member

    Joined:
    Sep 13, 2010
    Messages:
    3
    Likes Received:
    0
    thank you so much for the "guest" tip, now it works here ;-)
     
  24. lucifer6642

    lucifer6642 New Member

    Joined:
    Nov 11, 2010
    Messages:
    2
    Likes Received:
    0
    Me too :(

    EStrongs worked first time but I like Astro. I don't want to have to set up an SFTP server just for this
     
  25. Flavy

    Flavy Active Member

    Joined:
    May 10, 2010
    Messages:
    27
    Likes Received:
    1
    I received an email from the Astro developer. This is a known issue for 64bit Windows 7 machines. There currently is no eta for a fix :(
     

Share This Page

Loading...