Aviator Root


Last Updated:

  1. Now534

    Now534 Active Member This Topic's Starter

    Joined:
    Apr 11, 2012
    Messages:
    35
    Likes Received:
    10
    I take no credit in this but trying something out and seeing if this is a way to root this phone. i have successfully done it as well as a few others.

    PLEASE POST IN THIS THREAD IF THE SUPERONECLICK METHOD WORKS FOR YOU!

    What you will need:
    Odin 3 v1.85
    SuperOneClick (SuperOneClick - Download.com)
    Your Phone

    Download this (aviator root tar. If mac download the one for mac) (http://teamuscellular.com/Forum/files/category/4-samsung-aviator/)

    Boot phone into Downloader mode
    Pull battery reinsert hold volume down and plug usb cable in

    Flash the .tar in PDA mode. Let it restart (should go into USB Debugging mode if not put in Debugging Mode)

    Open up SuperOneClick and click Root.

    Let it install SU and Busybox.

    Open Superuser up in the phone (if not installed download from play store) hit the settings button and update SU.

    It should update. To verify root download Root Checker from the Play Store.

    Enjoy your Rooted Aviator

    If it does not work follow the instructions in this thread: Galaxy S aviator root - Galaxy S Aviator Development - TeamUSCellular

    http://www.youtube.com/watch?v=rE60AodZvgM
     

    Advertisement
  2. Zebulon

    Zebulon Well-Known Member

    Joined:
    Dec 28, 2010
    Messages:
    370
    Likes Received:
    60
    Awesome, thanks a lot! I'll give it a try as soon as I can.
     
  3. AFVet

    AFVet New Member

    Joined:
    May 8, 2012
    Messages:
    1
    Likes Received:
    0
    It worked. Root survived a reboot as well, so it's permanent.

    A couple of notes.

    The download.com link to SuperOneClick appears to point to a corrupt zip - couldn't open it after multiple attempts. I had a later version of SOC on my PC (2.3.3), and it worked like a champ.

    You may be prompted to install a couple of drivers when running the root exploit in SOC - just say yes, and click through the Windows warnings.

    Final note - You have my undying THANKS for getting this working. The bloatware on this device was driving me nuts. I really like the Aviator, and can't wait for ROMs, but just being able to get rid of the bloatware is a lifesaver. THANK YOU!!!
     
  4. Now534

    Now534 Active Member This Topic's Starter

    Joined:
    Apr 11, 2012
    Messages:
    35
    Likes Received:
    10
    Glad to hear this worked for you i take no credit for this it all goes to Imnuts from XDA. Though me and another guy from TeamUSCellular tried out the SOC and wanted to test it out further and see if it was easier to do which it sounds like it is. Hopefully this weekend if i get some time i will make an actual how to video for some people that like to watch videos instead of reading text.

    Thanks for reporting back that it works. Hopefully soon we can dip into some ICS roms.
     
  5. joe.russell

    joe.russell Member

    Joined:
    Aug 12, 2010
    Messages:
    11
    Likes Received:
    0
    I'm having an issue running superoneclick. I have windows running on a virtual machine on my mac, and it keeps saying error when I try to open the application. Tried two different versions. I haven't ever had problems running windows programs or downloading roms and root for my other phones. Any ideas?

    Thanks!
     
  6. Now534

    Now534 Active Member This Topic's Starter

    Joined:
    Apr 11, 2012
    Messages:
    35
    Likes Received:
    10
    Not so sure on a mac i've never quite messed with one. A guy on TeamUSCellular has a mac and went this route it might be worth a try for you.

    Galaxy S aviator root - Galaxy S Aviator Development - TeamUSCellular - Page 2
     
  7. mcblazin420

    mcblazin420 Member

    Joined:
    May 8, 2012
    Messages:
    9
    Likes Received:
    0
    I can vouch for the fact that the mac instructions work super well... Less than 10 minutes and I was done!
     
  8. joe.russell

    joe.russell Member

    Joined:
    Aug 12, 2010
    Messages:
    11
    Likes Received:
    0
    hmmm.... I believe I've downloaded everything I need, but I'm a little confused by the instructions. How do I unzip the file? I try opening it, which can't be done on mac. Forgive me, as I have never rooted a phone this way, so this is a new experience.

    Thanks!!

    Also might be worth mentioning that I have the rooted file downloaded on my phone, but I haven't been able to use Superoneclick.
     
  9. mcblazin420

    mcblazin420 Member

    Joined:
    May 8, 2012
    Messages:
    9
    Likes Received:
    0

    Which file are you trying to unzip? You say that you have already flashed the rooted file... are you trying to unzip the su binary?
     
  10. joe.russell

    joe.russell Member

    Joined:
    Aug 12, 2010
    Messages:
    11
    Likes Received:
    0
    im supposed to unzip some zImage. like i said im rly confused. if someone wants to pm with more specific directions thatd b great. i dont wanna hog all these posts. thanks!
     
  11. Now534

    Now534 Active Member This Topic's Starter

    Joined:
    Apr 11, 2012
    Messages:
    35
    Likes Received:
    10
    on the Aviator_Root.tar.md5 file erase the .md5 extention from it to creat Aviator_Root.tar use Winrar (or mac suitable extractor) inside is zImage. If you want me to reup the file without the .md5 i will do so right now.
     
  12. joe.russell

    joe.russell Member

    Joined:
    Aug 12, 2010
    Messages:
    11
    Likes Received:
    0
    that would certainly save me some time. what would be left to do after i get that file then?
     
  13. Zebulon

    Zebulon Well-Known Member

    Joined:
    Dec 28, 2010
    Messages:
    370
    Likes Received:
    60
    I can't seem to get Odin 3 v1.85 to work on my computer. Will Odin 3 v1.3 work instead? That's what I've used to work on my Mezmerize, and I know it will work on my computer.

    EDIT: scratch that, I just didn't realize I had to run it from the folder with the configuration settings file. I just got my phone rooted, so I'm pretty darn pumped.
     
  14. Now534

    Now534 Active Member This Topic's Starter

    Joined:
    Apr 11, 2012
    Messages:
    35
    Likes Received:
    10
  15. musmagic

    musmagic Member

    Joined:
    Dec 22, 2010
    Messages:
    6
    Likes Received:
    2
    I tried the OneClick method yesterday and it worked.....no problems.

    Still trying to figure out how to get rid of the damn Amazon icons.....seems uninstall didn't remove everything.....
     
  16. Now534

    Now534 Active Member This Topic's Starter

    Joined:
    Apr 11, 2012
    Messages:
    35
    Likes Received:
    10
    I used Titanium Backup to remove all the uneeded apps.they don't seem to show up in my app menu.
     
  17. northmendo

    northmendo Member

    Joined:
    Aug 28, 2010
    Messages:
    8
    Likes Received:
    0
  18. Now534

    Now534 Active Member This Topic's Starter

    Joined:
    Apr 11, 2012
    Messages:
    35
    Likes Received:
    10
    To be honest i am not sure. I do not have a mac to test on. Odin flashed the root file and then SuperOneClick did the rest for me.
     
  19. mcblazin420

    mcblazin420 Member

    Joined:
    May 8, 2012
    Messages:
    9
    Likes Received:
    0
  20. alreadyinuse

    alreadyinuse New Member

    Joined:
    May 12, 2012
    Messages:
    3
    Likes Received:
    1
    After I read the directions more carefully.... use PDA mode. Powered off and on and I still have root access. First time I 've rooted a phone so now to figure out what to remove and how to get rid of that stupid thether stop.
    THANKS!
     
  21. Now534

    Now534 Active Member This Topic's Starter

    Joined:
    Apr 11, 2012
    Messages:
    35
    Likes Received:
    10
    You can pretty much get rid of all the amazon stuff, imdb, and anything else you won't use. Im using Wireless Tether and it works for me.
     
  22. mplusp67

    mplusp67 New Member

    Joined:
    Aug 10, 2011
    Messages:
    2
    Likes Received:
    0
    >>Boot phone into Downloader mode
    >>Pull battery reinsert hold volume down and plug usb cable in

    After I do this, I get a screen that comes up, "Downloading... do not turn off target", and it just hangs there.....


    NEVERMIND, I got it to work..... Thanks...
     
  23. Violatedsmurf

    Violatedsmurf Member

    Joined:
    Jan 22, 2011
    Messages:
    5
    Likes Received:
    0
    I see there is a mac technique but is there a Linux based root technique for this phone also?
     
  24. mcblazin420

    mcblazin420 Member

    Joined:
    May 8, 2012
    Messages:
    9
    Likes Received:
    0
    The entire Mac process is done via the command line/Terminal, so I believe you could theoretically get the Linux versions of Heimdall and the Android SDK (for ADB) and adapt the instructions.
     
  25. VoltronMaximus

    VoltronMaximus Well-Known Member

    Joined:
    Sep 27, 2011
    Messages:
    304
    Likes Received:
    81
    Im doing this phone for a friend of mine and just need to verify some things. First, to put phone into download mode, is it camera button + power button + volume down? Second, is it necessary to unplug the battery? Im basicly just unsure of the beginning steps, but Im pretty good with Odin and OneClickRoot from what Ive done on other Android devices. Thanks for the help:D
     

Share This Page

Loading...