Bluetooth won't start


Last Updated:

  1. T-Keith

    T-Keith Well-Known Member This Topic's Starter

    Joined:
    May 1, 2010
    Messages:
    397
    Likes Received:
    33
    I noticed today my bluetooth wont start. I've run into this before, but I don't know how I fixed it. Using switchpro, cyanogenmod pull down or settings, bluetooth won't turn on. It says updating bluetooth settings, but then never turns on. Has anyone run into this?

    Rooted Eris, with Nonsensikal.

    -Keith
     

    Advertisement
    bbqdays likes this.
  2. Podivin

    Podivin VIP Member VIP Member

    Joined:
    Nov 29, 2009
    Messages:
    3,679
    Likes Received:
    881
    If you have any remembered devices under the BT settings, delete them and see if it helps.

    If that doesn't work go into menu > settings > applications > manage applications > all
    Then 'clear data' under Bluetooth Share.

    I'm using Nonsensikal and the BT works fine (use it nearly every day), so I'm sure it's not a problem with the ROM itself.
     
    bbqdays likes this.
  3. T-Keith

    T-Keith Well-Known Member This Topic's Starter

    Joined:
    May 1, 2010
    Messages:
    397
    Likes Received:
    33
    Somehow my battery died last night, even though it usually never does, and now everything works fine.

    Also, you can't delete remember devices unless bluetooth is turned on.
     
  4. T-Keith

    T-Keith Well-Known Member This Topic's Starter

    Joined:
    May 1, 2010
    Messages:
    397
    Likes Received:
    33
    Well, the problems are back. I tried clearing the bluetooth share from titanium backup, but no luck. Anyone have any ideas?
     
  5. IzelTokatl

    IzelTokatl Well-Known Member

    Joined:
    Dec 11, 2009
    Messages:
    580
    Likes Received:
    90
    I've gotten this randomly on various roms, reboot always works.
     
    bbqdays likes this.
  6. T-Keith

    T-Keith Well-Known Member This Topic's Starter

    Joined:
    May 1, 2010
    Messages:
    397
    Likes Received:
    33
    Well it's working again, but for me rebooting never works. Just waiting a while(when I no longer need it) fixes it.
     
  7. T-Keith

    T-Keith Well-Known Member This Topic's Starter

    Joined:
    May 1, 2010
    Messages:
    397
    Likes Received:
    33
    I'm having this problem a lot on GSB 1.7, seemed better on GSB 1.5. Now I've found that rebooting doesn't fix, but clearing Dalvik cache does. Still this is not something I want to do every time I get in the car.

    I can't be the only person with this problem?
     
  8. bbqdays

    bbqdays New Member

    Joined:
    Jan 1, 2012
    Messages:
    1
    Likes Received:
    0
    I just bought an expensive pair of bluetooth earbuds. Went to connect them to my Verizon Android Eris for the first time, and the checkbox to enable bluetooth wouldn't work! I thought I would have to return my headset, until I came across something of a solution here. Thanks much to IzelTokatl for hinting that a reboot would work, because that did work! First I tried mhotovec's recommendation of clearing data, and thank you for the idea but that didn't work. I wish it would have, because although rebooting did work, it doesn't sound like a solid long-term "fix." At any rate, this bluetooth wireless headset thing is awesome! Hoping to eliminate stress at work with some unobtrusive music. This may also pay benefits with hands-free telephone calls, hadn't thought of it in that light. Thanks all for posting to this topic! -bbq
     
  9. stuartdm

    stuartdm New Member

    Joined:
    Apr 29, 2013
    Messages:
    1
    Likes Received:
    0
    Sorry, I know this thread is a little old now, but just upgraded Motorola Atrix to CyanogenMod 10.1 and despite trying everything above, still can't enable Bluetooth. The little toggle button on settings just flickers and stays off.

    Any assistance or other suggestions most appreciated :)
     
  10. krosenqu

    krosenqu Member

    Joined:
    Apr 9, 2010
    Messages:
    13
    Likes Received:
    3
    Droid Bionic with Cyanogen 10.1 RC1.

    I had the same issue with Bluetooth not turning on. Rebooting or pulling the battery don't work for me.

    My phone would completely lock up when connected to my car stereo over bluetooth. I'd be listening to a podcast on stitcher radio and the phone would freeze about 20 minutes into listening. I'd pull the battery and reboot. After this, bluetooth wouldn't work. Nothing I did except restore from a safestrap backup worked. I did this cycle several times. I'd restore from a backup, and then it would lock up the phone. I'd reboot and bluetooth was permanently off and then I'd restore from the backup again.

    UNTIL I installed Cyanogenmod 10.1 RC2. Now its working. It remains to be seen if it will lock up again when connected to bluetooth. I will find out tomorrow during my commute to work.
     

Share This Page

Loading...