[Boost Mobile] [OUTDATED][GUIDE][MD7][MG2] Rooting & Recovery for Galaxy S3(Boost)


Last Updated:

  1. Austrie

    Austrie Well-Known Member

    Rooting & Recovery Guide
    Guide For Getting Root And CWM Recovery On The Galaxy S3(Boost)​

    Download Mode = Press And Hold Volume Down, Home, And Power Button At The Same Time
    Recovery Mode = Press And Hold Volume Up, Home, And Power Button At The Same Time

    Requirements:
    Samsung Galaxy S3(Boost)
    Windows PC
    USB Cable

    Steps:

    1. Download ClockWorkMod(CWM) Recovery, Samsung Drivers, Odin 3.04, and Root From Recovery Zip
    2. Install The Downloaded Samsung Drivers
    3. Plug In GS3 Into PC(Powered ON)
    4. Place Root From Recovery Zip On SD Card(Internal Storage)
    5. Unplug GS3 From PC
    6. Place Odin Folder and CWM File In A Folder On Your Desktop
    7. Open The Odin Folder In The Folder On Your Desktop
    8. Right Click The Odin EXE And Click Run As Administrator
    9. Once In The Main Menu Of Odin, Click The PDA Button
    10. Navigate To The CWM File And Double Click It
    11. Once Back To The Odin Main Menu, Uncheck The 'Auto Reboot' Option If Checked
    12. Make Sure The 'F. Reset Time' Option Is Checked

    13. Power Off Your GS3
    14. Take Off The Back Cover Of Your GS3
    15. Go Into Download Mode
    16. Once Your Phone Power ON To Download Mode, Let Go Of The Buttons
    17. Press Volume Up To Continue
    18. Plug Your GS3 Into PC (Your Computer Might Say Installing Drivers, Let It Do So)
    19. A Blue Box Should Pop Up In Odin Saying 'com#' (# = a number)
    20. Click The Start Button
    21. It Should Take 10 Seconds, Once Odin Says 'PASS' You May Unplug Your Device
    22. Pull Your Battery Out Then Place It Back In
    23. Go To Recovery Mode
    24. Let Go As Soon As Your Device Lights Up
    25. Use The Volume Up And Down Buttons To Navigate And The Power Button To Choose
    26. Navigate To 'Install From SD Card' And Select It
    27. Navigate To 'Choose Zip From Internal SD Card'
    28. Navigate To The Root From Recovery Zip And Select It
    29. Select 'Yes', Then Select 'Go Back' Once The Installation Is Finished
    30. Then Finally Select 'Reboot System Now'
    Now You Are Rooted With A Custom Recovery!​

    Video: How to Root the Sprint / AT&T / T-Mobile Samsung Galaxy S III - Latest - YouTube

    Advertisement
  2. Austrie

    Austrie Well-Known Member

    Rooting & Recovery Guide(Mac & Linux Version)
    Guide For Getting Root And CWM Recovery On The GS3(Boost)​


    Requirements:
    Mac OSX or Linux Computer(With A Password)
    Samsung Galaxy S3(Boost)
    USB Cable

    Steps:
    1. Download Motochopper And Move Them To Your Desktop
    2. Turn On USB Debugging, Go into 'Settings' Then 'Developer Options' And Check The Option 'USB Debugging'. Then Plug In Your GS3
    3. Open Terminal And Type Each Line Of These Commands:
    [HIGH]cd Desktop
    cd motochopper
    chmod 755 *
    sudo sh run.sh[/HIGH]
    5. Once The Program Have Started, Press Enter Key on Keyboard And Allow USB Debugging On Your Phone If The Option Appears
    6. Once The Process Have Finish Press Enter Again
    7. Once Your Device Powers Back On, Go To Play Store And Download ROM Manager And Click 'Flash ClockWorkMod Recovery'
    Now You're Rooted With A Custom Recovery!​
    galaxyx, boosted150 and mauricio1717 like this.
  3. Austrie

    Austrie Well-Known Member

    FAQ


    Q: What Is Root?
    A: Root is having complete control of your phone, like being Administrator on a PC, and being able to change the phone to the user's liking; similar to Jailbreaking on iOS.(Simplified)

    Q: What Is A Recovery?
    A: A recovery is part of the phone that helps you flash ROMs, Kernels, etc.(Simplified)

    Q: Do I Lose Any Data Doing This Method?
    A: No, you do not.

    Q: Is This Free?
    A: Yes, it is. There is a one-click method by another dev at XDA, but it will cost you money.

    Q: Will This Work On Boost Too?
    A: Yes, I also have this guide in the boost mobile gs3 section.

    Q: Austrie Why Are You SOOO Awesome?
    A: Cause I was born that way :smokingsomb:
  4. Austrie

    Austrie Well-Known Member

    Thanks

    QBKing77(Youtube) - Original Video
    Techfanatic9(Android Rootz) - Linux Guide
    6Burgh(Howard Forums) - For Being My Tester
    Spacepanda(Android Forums) - For Being My Tester(Linux)
    Team Epic(XDA) - CWM For GS3, Root From Recovery Zip, and providing Samsung Tools​
  5. TheBritton

    TheBritton Resident Galaxy Cat Guide

    Stickied! :D
    smith058 and EarlyMon like this.
  6. Stlouizsin

    Stlouizsin Well-Known Member

    Thank you to all that helped dev and test.
  7. Austrie

    Austrie Well-Known Member

    Linux and Mac OSX guide add!
    GodManGordo, EarlyMon and TheBritton like this.
  8. septembersrain

    septembersrain 句_句 Smurfing Awesome VIP Member

    Thanks for this guide. Just got my S3 today. ^_^
  9. septembersrain

    septembersrain 句_句 Smurfing Awesome VIP Member

    Can also confirm that this works with the Odin V1.85 I had on my work computer.
    Am rooted and happily removing bloatware as we speak! ^_^

    Is there a list of "Safe to remove" apps?
    I know some of them but probably not all of them.
  10. HiiiPowers

    HiiiPowers Well-Known Member


    Since your rooted stock before you remove too much you want to look into making a flashable zip of stock boost firmware just for everyone because I know someone will accidentally forget to make a backup and flash a different rom
  11. septembersrain

    septembersrain 句_句 Smurfing Awesome VIP Member

    How do I do that? Just a normal nandroid?
    Wouldn't that also have my information?
    I just used TiBU to freeze the bloat, I didn't remove it yet.
  12. HiiiPowers

    HiiiPowers Well-Known Member

  13. septembersrain

    septembersrain 句_句 Smurfing Awesome VIP Member

  14. HiiiPowers

    HiiiPowers Well-Known Member


    Thanks :) now we can test roms without the worry of not being able to go back to stock
  15. septembersrain

    septembersrain 句_句 Smurfing Awesome VIP Member

    Need someone else to turn my nandroid into a flashable .zip.
    I don't have the time, Nor do I have tools needed on my work computer.
    I got a promotion at work, So I have even less time...

    Let me know if you want my nandroid. Message me. Thanks.
  16. mauricio1717

    mauricio1717 Member

    Hi,
    I tried to download the CWM recovery file but once it is on my desktop is unreadable...suggestions please???
    Downloads

    CWM Recovery: http://k0nane.info/rom/ecm/CWM-Recovery-LTE-SGS3-v5.tar.md5
    Samsung Drivers: http://org.downloadcenter.samsung.c...ng_USB_Driver_for_Mobile_Phones_v1.5.14.0.exe
    Odin 3.04: http://k0nane.info/rom/ecm/Odin3-v3.04.zip
    Root From Recovery Zip: http://k0nane.info/rom/ecm/TeamEpic-Root-from-Recovery-v5.zip
    Motochopper: motochopper.zip | Tool by techfanatic9 - AndroidRootz.com for Galaxy S 3[/QUOTE]
  17. mauricio1717

    mauricio1717 Member

    hi, I downloaded the CWM recovery file, and once is on my desktop, the file is unreadable...any suggestions please???
    its a md5 file.
  18. DjiET

    DjiET Member

    wow you are amazing. this was the easiest rooting i have ever done.. I have rooted several htc devices and it required so much more work!! thanks a million... let the fun begin
  19. mauricio1717

    mauricio1717 Member

    Thank you bro for this awesome posting.
    excuse mi ignorance, but when I downloaded the CWM recovery file and I opened a window pops up and it says that windows can not read it and in order to do so windows needs to know what program created it, so I am basically stock. any suggestions will be greatly appreciated.
    Thanks.
  20. smith058

    smith058 Guides Guide

    just bought boost mobile S3 today...

    i flashed cwm via odin... every thing appeared to go correctly... booted into cwm fine...

    but when i go to "choose zip from sdcard" it don't work, i get "E: can't mount /sdcard/"
    i redownloaded, reflashed, checked sdcard... idk

    any help please

    ==== EDIT ====
    i just tried a data/factory reset from cwm... it went through the motions and when i rebooted nothing has changed... if re-flashed cwm 7 times now and re-downloaded it 4 times... i don't know why its not working properly... I'm running stock out of the box model number SPH-L710, build number jz054k.l710vpamd7

    i cant even do a data/factory reset from the regular system because it reboots and still tries to wipe it from cwm

    ==== EDIT ====
    my cwm cant mount to any thing... all failed... cant mount anything, cant backup any thing, cant install anything...
    W: failed to mount /dev/block/mmcblk0p17 (no such file or directory)
    W: failed to mount /dev/block/mmcblk1p1 (no such file or directory)
    W: failed to mount /dev/block/mmcblk1 (no such file or directory)
    E: can't mount /cache/recovery/log
    E: can't open /cache/recovery/log
    E: can't mount /cache/recovery/last_log
    E: can't open /cache/recovery/last_log
    E: can't mount /sdcard/

    ==== EDIT ====
    i just flashed in twrp... it to is having the same problems... cant mount anything, cant backup any thing, cant install anything...


    ==== EDIT ====
    do not use this restore recovery to stock
    http://forum.xda-developers.com/showthread.php?t=1743780
    it bricked my phone... i think it changed the boot.img... i could not make a backup with cwm... so i guess i will replace the phone and try again tomorrow


    .
  21. smith058

    smith058 Guides Guide

    ok... just replaced the phone... second phone fresh out of the box, same issue!

    odin flashes smoothly
    [HIGH]<ID:0/004> Added!!
    <OSM> Enter CS for MD5..
    <OSM> Check MD5.. Do not unplug the cable..
    <OSM> Please wait..
    <OSM> CWM-Recovery-LTE-SGS3-v5.tar.md5 is valid.
    <OSM> Checking MD5 finished Sucessfully..
    <OSM> Leave CS..
    <ID:0/004> Odin v.3 engine (ID:4)..
    <ID:0/004> File analysis..
    <ID:0/004> SetupConnection..
    <ID:0/004> Initialzation..
    <ID:0/004> Get PIT for mapping..
    <ID:0/004> Firmware update start..
    <ID:0/004> recovery.img
    <ID:0/004> NAND Write Start!!
    <ID:0/004> RQT_CLOSE !!
    <ID:0/004> RES OK !!
    <ID:0/004> Completed..
    <ID:0/004> Added!!
    <OSM> All threads completed. (succeed 1 / failed 0)
    [/HIGH]

    but when i go into cwm, all the mounting point seem to be wrong
    can't mount anything, can't backup/recover any thing, can't install anything, can't wipe anything, can't show logs, cant do anything but reboot...

    .

    please help... i need root for a few main apps i use

    .
  22. 666wicked666

    666wicked666 Active Member

    First off Thankz to all that makes this possible...I have followed things in the OP but I get a failed after about 30 seconds or so after hitting start with odin...I'm sure not seeing any others failing so I'm gonna bet I'm missing something...I get a blue com box put CWM file in the PDA slot then unchecked auto reboot and made sure F.reset was checked and hit start then failed ....any help would be appreciated in advance


    edit: I re-downloaded CWM and odin and all went smooth this time...Thankz again to ALL who make this possible and to all future DEV
  23. smith058

    smith058 Guides Guide

    yeah... i have root!!!
    NOT by the op method above....

    i ended up getting root from the donate version of "SAMSUNG GALAXY S3 UNIFIED TOOLKIT V7.5.1 found here... http://forum.xda-developers.com/showthread.php?t=1746680

    i donated to get support for "sprint android version 4.1.2 bmd4" which is in toolkit version 7.5.1...

    after getting bootloop on the last phone (with no odin recovery yet) i didnt have the balls to try any other opptions other than (#1 flash unsicure boot image and root) i was scared out of my mind until the phone rebooted :D
    but it worked...

    good luck to anyone else that tries

    I HAVE ROOT!


    ==== EDIT ====
    I noticed for some reason the mobile network (LTE / CDMA) does not work after this rooting method... however mobile network (CDMA) does work... so no 4G f for me at the moment. But I still get 3g... I can't do a prl update nor a profile update. .. cwm still has bad mounts and won't work... every thing else seems ok.
  24. smith058

    smith058 Guides Guide

    Just curious... those of you that have rooted using this method, what building number are you on?
    I've rooted many phones and have not had any problems like I'm having with this phone... I'm just curious if there are different build numbers out there..


    My phone info is: model number SPH-L710, build number jz054k.l710vpamd7

Share This Page