1. 2015 is going to be a great year for Android! Why wait??
    Samsung Galaxy Note 5 | Samsung Galaxy S6 | HTC One M9
  2. New Forum Created: Samsung Gear VR!

Can someone help me install a Custom ROM? [ROM/MOD] 4.1.2~Jellybean~AoCP CP 4.6


  1. kilbert

    kilbert Member

    The instructions seem simple:
    from :http://forum.xda-developers.com/showthread.php?t=1870926

    *Make sure you are on gingerbread bootloaders before flashing this rom

    HOW TO INSTALL 1. Factory Data reset 2. Wipe Dalvik 3. Format System 4. Install Zip from Sdcard 5. Boot up 6.Install GApps 7. Enter google info
    (May have to remove external sdcard if coming from gingerbread)
    (Do not flash gapps for ics, or you will lose your camera)


    :confused: But I cannot even get to the first step!

    My phone is on 2.3.5 factory gingerbread from keis update. So I am going to assume those are the GB bootloaders. Is that correct? or are they a custom GB bootloader?

    Factory wipe is no problem.
    Dalvik /format- I cannot find Dalvik option anywhere. Same for format, other than sd card?

    Any help is appreciated.

    Advertisement
    :
  2. lunatic59

    lunatic59 Moderati ergo sum Moderator

    Are you sure you want to go through all that? I've got CM10 running on a Captivate just fine and it seems a lot less complicated.
  3. kilbert

    kilbert Member

    No I am not sure, especially since I am confused as hell.

    Is CM10 easier to install /stable?

    Thanks!
  4. lunatic59

    lunatic59 Moderati ergo sum Moderator

    Once you've got your phone rooted and custom recover installed, it's dead simple. Give me a minute, I think I have the instructions around here somewhere.
  5. lunatic59

    lunatic59 Moderati ergo sum Moderator

  6. lunatic59

    lunatic59 Moderati ergo sum Moderator

    Once you're rooted you should already have clockwork mod installed. Hold vol up, vol down and power until you get to to this screen :

    [​IMG]

    Then you use the vol up/down keys to highlight the options and the home key to select. Backup and restore is the options you want. (That's a nandroid). Backup the phone so you can revert back to this point in the very slim chance something goes wrong.

    This was something i wrote for someone flashing the ShoStock2 rom on the Galaxy S2, but it's pretty much the same for any rom on the Captivate, too. The difference would be that ShoStock includes a kernel and gapps (the Google apps like the Play Store, maps, gmail, etc.). Many roms you have to install them separately. With CM10 you will need the gapps package as well.

    Step 1. Back up your phone. Use the vol. up/down buttons to highlight Backup and restore. Press home to select. Choose backup and perform a backup to save your phone in this state should something happen during flashing. This takes a while and may appear to stall several places during the backup. Let it run and be patient. When it's done, use the back key to return to the main CWM menu (above).

    Step 2. Select wipe data/factory reset. This will remove your personal data and put the phone in a clean state. It is important to do this when flashing any rom. When that option is highlighted, press home to selct. You'll have to scoll again to the confirmation and press home again. This operation is pretty quick. When done, press the back button as many times as necessary to get to the main CWM screen.

    Step 3. Clear the cache. Some say this is optional for roms, but because ShoStock includes a new kernel too, I always do this. Same method ... highlight wipe cache partition. Press home to select. Scroll to confirmation and press home again to wipe. Then back to the main CWM screen.

    Step 4. Install ZIP from SD card. Highlight and press home to select. Scroll to the ShoStock zip file which will be pretty far down if you have a lot of folders on your sd card. when you have that highlighted, press home to select and again confirm as before. Now you are installing the rom. This takes a while as it flashes a new modem, new kernel and then installs the rom. Let it run and be patient. When it is done, go back to the main CWM screen and reboot. The first time it boots it sits on the splash screen a while while it builds the files, so again, be patient.

    Congrats, you are done :D
  7. kilbert

    kilbert Member

    Thanks for your help!!
    Working on installing software- have an issue with keis- it has been stalled for over an hour here: [​IMG]

    , not sure i need it if I plug in phone, the win7 sees it & it is @ 2.3.5 Gingerbread. I upgraded it a while ago, and do not care about anything that is on the phone- it can all go.

    I was curious, this guide is to install CM10 - Is that Cyanogen Mod 10, or Clockwork Mod 10. I am looking for the correct downloads. I have the Samsun USb drivers installed, korn kernel (7.05), odin (3c1.85- installed fine) & want to make sure I get the correct Google apps & ROM.
    I am getting this one:
    CyanogenMod Downloads
    cm-10.0.0-captivatemtd.zip

    This is the Gapps
    Latest Version/Google Apps - CyanogenMod Wiki
    Goo.im Downloads - Downloading gapps-jb-20121011-signed.zip

    (cyanogenmod10=jellybean).


    I will attempt to use ODIN to Korn Kernel next.
    Do you see any obvious errors here?
  8. kilbert

    kilbert Member

    Thank You.

    KornKernal & root (busybox & root) installed.
    w00t!

    Thanks.

    Had some issues with kernel- had no progress bar on device or odin, and when tried to start over got a screen with a [phone ! computer] on it, was able to get a successful flash eventually. had to do it 3x, once nothing, 2nd time fail, 3rd time was a charm.

    Now I am confused.
  9. lunatic59

    lunatic59 Moderati ergo sum Moderator

    Did you have another version of Kies installed? The only reason you need to install kies is for the drivers, so if they are recognizing the phone, then you don't need to finish, although it is a little disturbing that it would hang like that.

    What I would do, is to tray and cancel the install. If it is truly locked, reboot your PC and see if the phone is still recognized.

    I would still try and get a working copy of Kies mini installed somewhere because , heaven forbid, something goes wrong, you'll need it to update back to 2.3.5.

    Everything else looks right. CM10 (CyanogenMod 10 = Jelly Bean) and gapps are good.

    You might want to put the CM10 and gapps files on your phone before you root it with Odin. If I recall correctly, Korn breaks wifi so any file transfers have to be done by cable. CM10 will replace korn with it's own kernel, so it's no big deal, but it makes it cumbersome of you were copying files via wifi.
  10. lunatic59

    lunatic59 Moderati ergo sum Moderator

    Are you confused how to proceed or why it took three time to flash correctly?
  11. kilbert

    kilbert Member

    EDIT: I am a dim-wit instructions are in this thread post 6. Following them now.

    Thanks for your help

    A ? popped into my head:

    Can I get back to stock or a different ROM if I don't like it or features I need are not working?

    Ignore this:
    I am confused as to how to proceed.

    Boot into syscorp recovery by holding vol+/- & power, release @ATT
    I got that.
    I placed the gapps / CM10 on internal sd.

    Do I perform a nandroid backup?- I am confused by the thread referenced above. I found that option in the recovery menu.

    Then what is next?
    Do I choose install ZIP from SD?

    Do I need to choose format or any other options first?

    Sorry I am so lost. Thanks For your help
  12. kilbert

    kilbert Member

    I re-read above, I am supposed to reboot. again
    Ignore dimwit moment #2
    Thanks!

    I performed the above step in #6.
    I wiped/factory reset. Cleared cache. found .ZIP on SD for CM10. clicked install. IT rebooted at att screen a few times, and now:

    I am at a clockwork recovery screen v6.0.1.5 (different from the initial syscorp 5.something recovery screen),

    :confused:do I choose reboot or install from SD?

    Thansk!
  13. kilbert

    kilbert Member

    I give up how do I install gapps?
    Thanks
  14. lunatic59

    lunatic59 Moderati ergo sum Moderator

    First thing is relax. We'll get this done. I am at work now so I apologize if i disappear for an hour here and there. If you'd like I can get some more eyes on this thread.

    Am I to assume that you got CM10 installed? When you say you got stuck on the AT&T screen, that's just the delay in the first boot after flashing.

    You install gapps that same way you installed CM10. Boot into recovery (clockwork mod) by holding down the volume buttons and power as you did before, then select install from zip and this time select the gapps file. Let it install -- it should be pretty quick, and then reboot the phone.

    If you want to go back to stock, there is a one-click file for the Captivate (i897) on XDA. I'll see if I can find that if you need it. But that file takes you all the way back to 2.1 and you'll need kies mini installed to update to 2.2 and then finally 2.3.5.
    kilbert likes this.
  15. kilbert

    kilbert Member

    Sorry I was getting excited. My apologies. I appreciate all the help you give in the forum (I did a massive amount of reading), and to me. I tried to read the answer but was getting frustrated with my google-fu.

    I got Cm10 installed and it works fine, I installed Googleapps from the same clockwork menu, and it works fine. Thank you.

    There was some confusion on MY part, but re-reading made me see the err of my ways, and I had some dimwit moments. Your instructions were fine.

    I am now running cyanogen 10, and love it. I may try to flash a diff ROM one day or maybe go back to stock if I ever trade this in, if all I need to do is boot to clockwork and select a new zip.

    THANK YOU for helping me! :)
  16. lunatic59

    lunatic59 Moderati ergo sum Moderator

    That's what we're here for. :)

    Don't worry about a little panic in the beginning, it's like the first time you go on a date and ... um ... maybe that a little too personal, but you get the idea. :) And once you get the hang of it... ;) ;) ;)

    As far as the roms, I've tried a few but always end up going back to CM10 mostly because of the wide testing user base, plain vanilla implementation and classy graphics. Of course, the Captivate is now three generations back for me so I don't use them that much, especially since I just got a Nexus 4 to play with. Still, it's a much maligned device and with Jelly Bean has a good bit of life left in it.

    Enjoy!
Loading...

Share This Page