Can someone help me make android apn proxy settings work?

Last Updated:

  1. msnuser111

    msnuser111 Well-Known Member This Topic's Starter

    Apr 13, 2010
    Likes Received:
    I have tried this on a g1 on anything from 1.0 to 2.2,a cliq and a cliq xt both on 1.5,and on an htc hd2 running 2.1 and 2.2. What happens is no matter what I type in as the proxy in apn settings,it is completely ignored. I am using the sidekick prepaid plan,which blocks ports 80 and 443,so no web browsing normally,but a proxy works if used on port 9201. i have tested this in windows mobile and it works perfectly,so I know it is not a plan issue,it is android that ignores the settings.When I try it in windows mobile,all apps follow the settings and everything works,but in android the browser will follow the settings,but everything else still trys to connect normally without the proxy so I keep getting notifications saying I have a sync error with my account,and no apps other than the browser will connect. market keeps saying it can't connect,retry or cancel and maps just says data connection lost,retrying. those are just 2 examples. On the HD2 builds,I have a unique situation because it is using rmnet to connect instead of a direct ppp connection,and it works occasionally. If I type in the settings,about 1 in 3 boots it will connect and works great,until i drop signal then back to no connection,even after I get signal back.I have no idea what makes it work or not work,but I have never had a successful proxy connection when android is using ppp to connect,and a very inconsistent connection pattern when using rmnet. Windows mobile works every time on the same phone,same settings,same sim,so I know it is possible,this is an android bug.
    Anyone know how to make this work correctly all the time? Preferably with ppp,but if you have something that will make rmnet work,that's fine too,I just want data. It sucks not being able to use anything on the go.I have to boot into windows mobile to use google maps. :(


Share This Page