1. Hot New Devices! HTC One M9 | Samsung Galaxy S6 | LG G4

Cant download certain Apps!Support


  1. Transidian

    Transidian New Member

    I wanted to download the New Temple Run and when I found the link I realised it was for Versions 2.1 and up but it said on the top of the page that my device wasnt compatable!?
    I have Android 2.3 on the ZTE Blade 2 and I dont understand why it wont work on my phone if ive got a phone better than the required, please help!? :confused:

    Advertisement
  2. fuzzface

    fuzzface Well-Known Member

    The incompatibility isn't just concerning the version of Android, but also factors such as RAM and processing speed.

    Unfortunately the crescent (blade2) is a low end handset and not all apps will function correctly on it.

Share This Page