1. Introducing Channels - a new way to chat with other Android users!
    Dismiss Notice

charging takes forever now .Support


Last Updated:

  1. dan44762000

    dan44762000 Well-Known Member This Topic's Starter

    Joined:
    Jun 12, 2010
    Messages:
    121
    Likes Received:
    18
    when first got phone charging from 10% too 100% would take roughly 2 and half hours .

    now 8 weeks later it has taken 6 hours to go from 10% to 100% on main plug charge .

    using stock charger .

    battery life once charged is excellent so i dont think its a problem with battery but i swear it never took this long to fully charge when i first got it .

    suggestions for a quicker charge ?
    or is this the normal . i dont really mind too much but it does seem excessive .
     

    Advertisement
  2. SUroot

    SUroot Well-Known Member Developer

    Joined:
    May 25, 2010
    Messages:
    23,925
    Likes Received:
    5,302
    The s3 has a built in detection system where it charges slowly if it thinks the usb connection is not stable (poorly connected or faulty) so I would try other cables first
     
    dan44762000 likes this.
  3. funkylogik

    funkylogik share the love peeps ;) VIP Member

    Joined:
    Sep 15, 2011
    Messages:
    21,470
    Likes Received:
    7,239
    Maybe the phone has taken a while to calibrate itself and youre now getting a true 100% charge (total guess lol)
     
  4. silentwitness

    silentwitness Well-Known Member

    Joined:
    Aug 19, 2012
    Messages:
    1,095
    Likes Received:
    318
    be happy the phone charges at all with the official charger that came with the phone. My s3 when i try to charge it with the stock charger i had left it for about 8 hours to charge and the battery started at 36% and ended up after 8 hours at 32%.
     
  5. doc1964

    doc1964 Well-Known Member

    Joined:
    Oct 13, 2010
    Messages:
    257
    Likes Received:
    60
    Mine started doing this recently as well. Would seem the standard charger or cable is faulty. Lots of posts on this. I use the charger i had with my S2 and it charges as it should.
     
  6. dan44762000

    dan44762000 Well-Known Member This Topic's Starter

    Joined:
    Jun 12, 2010
    Messages:
    121
    Likes Received:
    18
    well i was in work Friday night and had left charger at home , however a colleague of mine had his usb lead . but no charger .

    i popped my phone onto the pc and transferred somee music and though i would leave it charge while i didn't need it .

    got real busy at work so didn't go back to it for about 3 hours , looked at phone and it was fully charged .

    no idea how long it took in all it may well have been less than 3 hours but it was a lot faster than plugging into the mains at home .

    i am going to leave it run down to 5% today and then charge from there while plugged into my pc .

    i have a feeling that the charge unit is faulty and not the lead .

    Dan
     
  7. SUroot

    SUroot Well-Known Member Developer

    Joined:
    May 25, 2010
    Messages:
    23,925
    Likes Received:
    5,302
    Also, don't forget, Mains charges at 1000mA. USB 3.0 at 900mA and USB 2.0 at 500mA, so it should take twice as long charging from a USB 2 port than mains...

    I have a strong suspicion its the cable
     
  8. sherlock5545

    sherlock5545 Well-Known Member

    Joined:
    Dec 18, 2011
    Messages:
    1,050
    Likes Received:
    304
    I think it's the cable. Mine sometimes works properly and charges very fast, other times it takes 6 hours.
     
  9. samthegam

    samthegam Well-Known Member

    Joined:
    Jun 14, 2011
    Messages:
    58
    Likes Received:
    9
    my metro pcs siii charges slow after the jellybean 4.1.2 update. it gets stuck charging at 98% then takes a long time before 100%. i have tried different chargers & cables still the same end result
     

Share This Page

Loading...