1. Introducing Channels - a new way to chat with other Android users!
    Dismiss Notice

Connecting to a non-broadcasting wireless network


Last Updated:

  1. TENtimesFAST

    TENtimesFAST Active Member This Topic's Starter

    Joined:
    Nov 25, 2009
    Messages:
    27
    Likes Received:
    1
    My work's wireless router is setup to be WPA Personal as well as non-broadcasting, TKIP

    I see nowhere in the phone's wireless settings to configure for this :(

    Does anyone know if there is a way that I may be missing or an app that works well (pref free but I don't mind paying)
     

    Advertisement
    Fceddyjcu likes this.
  2. Slewman

    Slewman Well-Known Member

    Joined:
    Jan 22, 2010
    Messages:
    94
    Likes Received:
    4
    set your wireless router to broadcast for a moment, let your phone connect to it, then set it back to non-broadcast... thats the only way to do it... once your phone connects to it once it will find it on its own, even if its not broadcasted
     
    funkylogik likes this.
  3. TENtimesFAST

    TENtimesFAST Active Member This Topic's Starter

    Joined:
    Nov 25, 2009
    Messages:
    27
    Likes Received:
    1
    Sadly since this is the work router this is not an option :(
    They are adamant about keeping it non-broadcasting (even for a moment)
     
  4. Slewman

    Slewman Well-Known Member

    Joined:
    Jan 22, 2010
    Messages:
    94
    Likes Received:
    4
    unfortunately, you may be out of luck. I have not heard of an app that could help you out... the point of making the wireless router non-broadcasting is so people cant find the network... the reason why your phone/wireless adapter can find a non-broadcasting router after it has made 1 connection is that the phone/adapter KNOWS that this router exists and will attempt to contact it itself instead of just looking for whats available.

    sorry
     
    funkylogik likes this.
  5. TENtimesFAST

    TENtimesFAST Active Member This Topic's Starter

    Joined:
    Nov 25, 2009
    Messages:
    27
    Likes Received:
    1
    I've successfully connected my laptop and iPod Touch to the network without having to switch off the non-broadcasting. I'm gonna keep looking for a solution. If I find anything I will update this thread! Thanks for your intel :)
     
  6. JustDriftin

    JustDriftin Well-Known Member

    Joined:
    Nov 17, 2009
    Messages:
    119
    Likes Received:
    14
    Give this a try: Menu, settings, Wireless & networks, Wi-Fi settings, scroll down if you have to, Add Wi-Fi network. You will have to know the Network SSID and security settings which you should be able to get from your Network Administrator.
     
  7. wormser

    wormser Active Member

    Joined:
    Feb 5, 2010
    Messages:
    41
    Likes Received:
    3
    I have the same issue and already tried that. The AP is listed and the settings are correct because I can connect when its enabled. I think this is a bug.

    Another thread shows that others are having the same issue.
     
  8. mjschmidt

    mjschmidt Well-Known Member

    Joined:
    Jun 27, 2009
    Messages:
    1,272
    Likes Received:
    113
    While you can "add" a non-broadcasting wireless network to your list of WiFi networks on your phone, I found with my home WiFi network that when I had SSID broadcast off i was almost never able to connect. Once I turned SSID broadcast on, I have had no trouble. Most definitely a bug.

    Since you are unlikely to get the admin to broadcast the SSID, then even though you can add the network (if you know the name and settings) tou most likely won't be able to reliably connect, unless someone has found a work-around for the bug.
     
    funkylogik likes this.
  9. wormser

    wormser Active Member

    Joined:
    Feb 5, 2010
    Messages:
    41
    Likes Received:
    3
    Others have found that installing wifinder is a work around, but it did not work for me.
     
  10. wormser

    wormser Active Member

    Joined:
    Feb 5, 2010
    Messages:
    41
    Likes Received:
    3
    I found a work around that worked for me. It involves installing another app and isn't the optimal solution. This is a confirmed bug and hopefully the next update will fix it.

     
    funkylogik and torpid like this.
  11. wormser

    wormser Active Member

    Joined:
    Feb 5, 2010
    Messages:
    41
    Likes Received:
    3
    I found a real solution to not being able to connect to a hidden SSID. Try this first.

    Check your router mode to see if it is in Auto, B or G only. Then change the mode on your router to B and G. I connected right away.
     
  12. miklos

    miklos New Member

    Joined:
    Jun 24, 2010
    Messages:
    1
    Likes Received:
    0
    None of the workarounds above worked for me :( ... I cannot connect to a non-broadcasting wireless... broadcasting has to be turned back on.
     
  13. takeshi

    takeshi Well-Known Member

    Joined:
    Dec 6, 2009
    Messages:
    3,354
    Likes Received:
    281
    Odd. No problems here. My home WiFi doesn't broadcast its SSID.

    What device are you using?
     
  14. zappadragon

    zappadragon New Member

    Joined:
    Jun 26, 2010
    Messages:
    3
    Likes Received:
    0
    I have the same problem. My home network is hidden and I can not connect. I did try to enable it and then was able to connect but after hiding the SSID again I was not able to connect. It would be nice if they fix this when 2.2 rolls out.
     
  15. torpid

    torpid New Member

    Joined:
    Jun 26, 2010
    Messages:
    2
    Likes Received:
    2
    This sort of issue really needs more detail. What Model of cellular device you are using and the model of router you are trying to access(for the people claiming configuration changes, even when he's adamantly stated: non accessible router administration)


    Since most routers restart after changing this setting, this will not work for most people. If your router restarts, well, you get disconnected. Having this scenario work, seems more like a fluke.

    What did work for a Motorola Droid and Dr-655 hidden service set identifier.

    wormser's nugget of information about, Hidden ssid enabler, really did it.

    For anyone with a bar code scanner, wallah.
    [​IMG]
    Or, look it up in the android market

    You need to add the wireless connection to you connections list first with all of the appropriate security information.

    Install this, open it.
    Type in the SSID of the wireless network.
    Click on Enable Hidden SSID

    The above worked for me. I had recently had to reconfigure my router and decidedly never got around to resolving this. When I hid the SSID, the connection would go out of range. Now, I can have a slightly more secure, though not impervious, wireless connections. See no evil, hear no evil.
    *Notes*
    I only had to do this once with my connection. After turning off my wireless and turning it back on, it was still there and I auto connected to the network.

    I haven't pulled the battery or anything to see if it stays enabled.
    I am curious what this app did.
     
    hexxamillion and gtokarsk like this.
  16. patekgeneve

    patekgeneve Member

    Joined:
    May 16, 2010
    Messages:
    10
    Likes Received:
    0
    To connect to your office router, you'll definitely need to know the SSID and encryption key. Won't your admin be able to provide that?

    But, I'm a little curious why your network admin is using WPA Personal with TKIP. Routers at work should at a minimum use AES.

    Sorry, I haven't been of much help.
     
  17. gtokarsk

    gtokarsk Member

    Joined:
    Jun 25, 2010
    Messages:
    8
    Likes Received:
    0
    I just got an Incredible, and my home router is not broadcasting SSID. Here's what I found so far - in my wireless I manually add the wireless network with ssid and access keys. To connect to it I either have to tap it or hold it.. I forget.. anyhow it does not seem to want to "autoconnect" to this network, I always have to force it. I just pulled few apps to deal with WiFi, will see if any of them will manage that for me. Either way, at least for the first connect you have to create the network manually in your WiFi settings.
    Hope I'll get it to autoconnect too, eventually ;)
    GT
     
  18. gtokarsk

    gtokarsk Member

    Joined:
    Jun 25, 2010
    Messages:
    8
    Likes Received:
    0
    Hidden ssid enabler did not do it for me, still have to click on the ssid in my wireless list... oh well, nothing I cannot deal with, just seems to be a bit manual.
     
  19. zappadragon

    zappadragon New Member

    Joined:
    Jun 26, 2010
    Messages:
    3
    Likes Received:
    0

    Hidden ssid enabler did not do it for me either. I tried just like it was stated how to do it above and when I open up hidden ssid enabler and type in my network name nothing happens then I have tried to swap back and click my network name from the list. The only way I can connect to my wireless it to broadcast the ssid. There has to be a better way.
     
  20. lkhintonsr

    lkhintonsr New Member

    Joined:
    Jul 19, 2010
    Messages:
    1
    Likes Received:
    0
    All to resolve this problem, you have to: 1) Manually configure your connection to your hidden A.P. 2) Manually configure your "STATIC" Network settings: (IP Address, Gateway, Subnet Mask, DNS). Once you do this, your problems will be solved!
     
  21. Univice

    Univice New Member

    Joined:
    Mar 26, 2011
    Messages:
    1
    Likes Received:
    1
    Ok, got it to work finally and it was from putting pieces of this post together (Thank You all) - this is also why I joined the forum. I have an at&t Captivate running android 2.2 and not rooted or unlocked (yet). There is a hidden WiFi G network at work that I have no ability to make temporarily visible or physically see or touch. One of my computers is hooked up to the hidden network so i was able to see the network name and get the BSSID (same as SSID for this purpose) in WiFi properties of that network.

    I tried going to wireless settings on my phone and manually typing in the SSID in the box labeled "Network SSID". This alone did not work. I copied the SSID to Hidden SSID Enabler (HSE) and that alone nor the two together worked. However I didn't get the error from HSE stating not valid - it just blinked and seemed to do nothing - still no connection.

    Solution that worked (two steps - You will need the hidden networks Name and SSID):
    Phone State: HSE installed from market, and Wi-Fi on but not connected to anything.
    1) On phone go to [Settings> Wireless and network> Wi-Fi settings> Add Wi-Fi network] In the box labeled "Network SSID" type in the hidden network name (your hidden networks actual name) and touch [save] I left the security "open" in my case.
    2) Now go to HSE program and type or paste the hidden networks SSID and choose [Enable Hidden SSID].

    Note: Again I got the same response from HSE (no error just blinked once and seemed to do nothing). Then I downloaded WiFi Manager from the market to see if that would help - and to my pleasant surprise - while that program was opening I noticed the WiFi icon in the task bar was on - indicating a connection, and discovered it was connected to the WiFi network I had created with the network name only. I don't think the newly installed program "WiFi Manager" had anything to do with it but it showed the connection also.
     
    lianganfan likes this.
  22. bossman12334

    bossman12334 New Member

    Joined:
    Apr 26, 2011
    Messages:
    1
    Likes Received:
    1
    its actually very simple for me i saved my router ssid and password to my phone downloaed hidden ssid enabler out ssid in there bam worked no issues very easy
     
    lianganfan likes this.
  23. hexxamillion

    hexxamillion New Member

    Joined:
    Mar 10, 2012
    Messages:
    2
    Likes Received:
    1

    Wow! This was too easy and required no effort on my Droid Bionic. I just turned off broadcasting tonight. Now I can use my XBMC Remote again. Woohoo! :)
     
  24. dwpddxfig

    dwpddxfig Guest

    as out do hub NAP a for to
     

Share This Page

Loading...