Contacts saved Multiple Times on Samsung GS2Support


Last Updated:

  1. andydonlon

    andydonlon New Member

    HI Guys,
    I have been really frustrated with my new Samsung Galaxy S2.

    I am not technically minded at all, and require your help & assistance.

    On my phone I have 504 contacts, I have them all saved to Gmail account also.
    However on my Handset phone it shows I have contacts for the following in Groups:
    "My Contacts" - 504
    "Unknown (hotmail account)' - 148
    "Unknown (hotmail account)' - 17122

    can you advise on How I can delete these permanently off my phone, as this is causing the phone to be very slow in response to actions commanded.
    much appreciated
    Andy

    Advertisement
  2. SGS2

    SGS2 Well-Known Member

    go to contacts, settings, save new contacts to.

    choose google. do not choose phone, do not choose sim card, sim card can save contacts, and so can the phone itself. you do NOT need contacts saved to sim nor phone because google is all you need! how hotmail saved a random number, 148, and 17,122, i do not know.

    however, even if you loose your phone or it breaks, google will always have your contacts. and deleting contacts from the "contacts storage" app will NOT delete them from gmail, which i will discuss below.

    to fix, when in contacts, go into menu, more, sim management. delete contacts from sim. you obviously do not need contacts on sim, and i bet the sim and ALSO the phone itself has duplicated your contacts, or in your case , trippled.

    when in contacts, look to the right of your contacts. there should only be a "g" or google symbol, NOT a sim card or phone symbol.

    under contacts, go to accounts. under accounts you will/should have your gmail account. i bet you will see here your hotmail account.

    under contacts, go to settings again. you will see at the top save new contacts to phone, google, etc. set it to google.

    sooooooo, a way to start fresh, and i have done this myself, is to delete the data in the "contacts storage". you will not, i repeat not loose any google contacts. however, you will need to resync contacts under "accounts and sync". if contacts are also saved to phone, deleting your "contacts storage" should remove duplicates saved to your phone. contacts can be saved to sim, phone, gmail and in your case, also hotmail.

    i hope this makes sense..... good luck, and let us know if this worked.

    basically, you should only use google as your contact list, and what has occured is a replication of hotmail contacts. YOU NEED TO MAKE SURE ALL CONTACTS YOU WANT TO HAVE ARE IN FACT ALREADY SAVED IN GMAIL.


    if you use a hotmail account and gmail, it may not be possible to preven hotmail from duplicating your contacts, but at least you can remove the insane amount, and end up with the correct amount saved once to gmail and once to hotmail. however, if you set new contacts to be saved only to gmail, this will prevent new contacts from being saved to hotmail, unless you want it to be.


    p.s. the only way you can delete, permanently, a contact from gmail is if you go into contacts and select a specific contact and delete that specific contact.
    (G) likes this.
  3. chienb

    chienb Member

    yeah... syncing google contacts is a pain. I remember seeing a highly rated contact book app a while ago on the forums though.
  4. jej826

    jej826 New Member

    I just got an AT&T GS2.I don't even have the option to save to sim.Is that normal?

    Thanks
  5. lunatic59

    lunatic59 Moderati ergo sum Moderator

    Yes. Sim contacts are very limited, just a name and one number. You should have the option to save them as phone contacts if you don't want them associated with your gmail account, but then they won't sync and you need to back them up manually if you don't want to lose them.

Share This Page