Evo 4G "Connection to server lost" No Video!!Support


  1. zach3742

    zach3742 Member

    I have had the HTC evo for quite a while and have had no problems with it until a week ago. Any time I try to access a video file on any website, it shows, "Connection to server lost." My internet connection is working fine because I can access everything except for video files. This has become very irritating so I am wondering if there is any way to fix it.
    I noticed one of my family members, who is on my plan had the same thing happen to their phone (which is the same HTC evo 4g LTE). Also, there have been complaints on youtube about this phone in the customer support section with the same problem. Theirs randomly started working again, but mine doesn't seem like it will.
    If you have any information about this please help.
    Any help is appreciated. Thanks,
    -Zach

    Advertisement
  2. tube517

    tube517 Well-Known Member Contributor

    Go to wifi settings, forget the wifi connection and reconnect to it. Also, clear any cache in the Youtube app and your browser. Make sure you have the latest Adobe Flash.
    zach3742 and Mikestony like this.
  3. zach3742

    zach3742 Member

    I use cellular coverage, not wifi. To clear the cache on youtube and web browsers do I need to re-intall them or just delete their history? I have the latest adobe flash, but its still not working.
    -Zach
  4. zach3742

    zach3742 Member

    Nevermind, I finally figured out where to clear the cache and that helped. Thanks a lot.
    -Zach
  5. zach3742

    zach3742 Member

    Ok, it stopped working again and this time it popped up as an "error 104" and now it's back to the same problem. Any suggestions??
    -Zach
  6. tube517

    tube517 Well-Known Member Contributor

  7. zach3742

    zach3742 Member

    I saw this forum also, but I wasn't sure if a total system reset would be necessary or not. I have the same carrier (sprint) as those who are having the problem so I plan on contacting them. What exactly is a "power-cycle"? Are these my only options?

    Sorry, I'm not great with technology so I appologize if I sound like I don't know what I'm talking about .
    -Zach
  8. tube517

    tube517 Well-Known Member Contributor

    I think you should look at post #14. It talks about data roaming and checking the box for that. It seems to be a data roaming issue but I don't have the time to search further.
  9. zach3742

    zach3742 Member

    Ok, great. Thanks for the help. Turning off the mobile network and then turning it back on seemed to work for now...
    Thanks again,
    -Zach
  10. zach3742

    zach3742 Member

    That seemed to only work for about three days. I tried turning off and on the mobile network, deleting caches, history, and restarting the phone, but that isn't working anymore.
    Is there anything else I can do?
    -Zach
  11. tube517

    tube517 Well-Known Member Contributor

    Did you check or uncheck the box for data roaming in your settings?
  12. zach3742

    zach3742 Member

    I don't see a box like this in the settings. There's "data roaming sound" but I know that's not what you mean. I checked in all of the settings, but data roaming isn't an option to check or uncheck.
    -Zach
  13. tube517

    tube517 Well-Known Member Contributor

    Sorry, I can't get to the exact place because I'm rooted and on an AOSP rom.
  14. hookinmouth1

    hookinmouth1 New Member

    Okay after a week with no useful help from Sprint and a hour of trying everyones suggestions i finally fixed this youtube problem. Simply go to settings-apps-all, then scroll down and select "streaming media player" then "clear data". Youtube immediately started playing videos. Hope this cures everyones similar problems.
  15. chbartel

    chbartel New Member

    I found a solution that has somewhat worked for me...at least I am getting somewhere:

    okay, since it's my first post, I can't put the link in here, so here is what I did below:

    here is what I did, as mentioned in that link:

    ******FIX********
    I tried many other acclaimed fixes, but to no avail. Ended up finding the solution myself. I had the issue on wifi but not data. My problem turned out to be my phones DNS settings. Go to settings then navigate to your home wifi network. Press and hold on your network, then modify network config. Then change your IP settings from dchp to static. Then you will need to scroll down to DNS 1 & 2. I changed mine to the public Google DNS services. The Dns server addresses are as follows:
    8.8.8.8
    &
    8.8.4.4
    Enter these and hit save. This did the trick for me! I also had issues with Google play updating and installing apps on my home net but worked fine elsewhere. This got rid of this issue as well. Note: these instructions are for the Galaxy S3. If you need help, just reply but try to use your on wits and think for yourself like I did. Just use my instructions as a guideline.
    I'm glad I could help!
    Good luck everyone!



    BUT....this works for me for about 3-4 hours, then reverts back. I originally also had a problem downloading updates from the google play store...keeping these dns settings still has that problem fixed, but not the youtube issue.

    I have gone to my kids school tonight for basketball--connecting to their wifi and youtube works, but here at home on my brand new 5g high-end netgear router it won't work!

    So, to get youtube working again, I have to delete my wireless connections saved on my phone, reconnect, then manually edit and change the dns server to something besides my "normal" ones(which is comcast), then it works. I don't know how long it will continue to work tonight.

    Also, what is strange is, I had already changed my DNS to point to Googles, but I still had to physically change it on my phone...only then did youtube start working again(or allow me to download app updates from google store).

    Anyone have ideas here? it has to be something to do with the TCP/IP stack possibly on the phones being corrupted?

    Also, this happens on all android phones I have at my house. This includes two Galaxy SII's and two brand new Samsung Note 2's...I think this all started possibly within the past week, as I had been watching videos fine on my note 2 since I bought it 6-8 weeks ago.

Share This Page