Fix for fast battery draining


  1. gme109

    gme109 Well-Known Member

    I did it almost 5 hrs. ago, and I've only dropped from 50% to 37%. I don't quite understand it though, I haven't been without signal in the last 5 hrs., or at all today. So why is it telling me I've been without signal for 37% of the time?
  2. Toast95135

    Toast95135 Active Member

    [​IMG]

    Until today my time without signal was 0%, it's was 50% when I was driving and then 2% for a while. It's been 50% since this evening, I updated the PRL and its gone down some since. Hopefully that was all...
  3. icemanjs4

    icemanjs4 Well-Known Member

    It's not about being without signal. It's about the phone losing the signal in an area where it should be connected well, then constantly trying to reconnect. This drains the battery.

    I'm glad this helped everyone.

    Time for my results. Granted this is a new phone, but it had TWS of 52% yesterday before fix.
    I unplugged my fully charged phone last night before bed.
    It's now been 21 hours since I unplugged it and I'm still at 30%.
    TWS is still at 0%.
    It's AMAZING how well this fix worked.

    The question is - what do we do about it now? Samsung needs to find out that there's a bug. How do we file that with them? This seems pretty serious to me.

    Hope the fix works for everyone in the mean time!!!
  4. 5Strong

    5Strong Well-Known Member

    I checked my phone and I am showing 2%. :D
  5. gme109

    gme109 Well-Known Member

    Time for everyone to call Sprint and report this to their higher level tech support. They better get Samsung to fix this before my 30 day trial is up.
  6. daddyd302

    daddyd302 Well-Known Member


    So was mine.... I was wondering why the hell my old Evo had better battery life then my Epic. Now hopefully we found out why the battery has been horrible on the Epic.

    Everyone who has bad battery life, and tried this and it works, PLEASE contact both Sprint and Samsung and let them know of this bug!!!

    So far it dropped to 40% and then 18% a few minutes later. I hope this works... Does anyone know if we have to keep doing this airplane mode step over and over???


    EDIT: I was just thinking.... Today and yesterday, I was taking my Epic out of my pocket to make a few calls, I looked at the signal strength, there was none!!! This was outside, in a area I knew gave me 5 bars at least.

    It never occurred to me until now. I was wondering why I wasn't getting any bars without thinking about it. Then just like that[1 second later] all 5 bars showed up. It seems the Epic is losing the signal and picking it up again, all outside.
  7. gme109

    gme109 Well-Known Member

    Just got off the phone with Sprint and Samsung tier 2 tech support, and neither one of them is aware of this glitch.

    Everyone should call Samsung directly and and tell them about this.

    Here is the direct line for the Galaxy S phone. 1-877-392-4252
  8. idamann

    idamann Member

    my TWS is showing 0%

    my battery life has been VERY bad since I got the phone last week Wednesday, but has been getting better day by day.

    at the moment I charged it overnight and unplugged it at 8am, it's now 1pm and I've been playing with it all day and I'm looking at 66% battery, but I'm using the "Battery Status Pro", not really sure how accurate it is.

    I moved from the touch pro, so a short battery life is something I'm used to ;-)
  9. Arkansawyer

    Arkansawyer New Member

    Fantastic tip. And thanks for all the details on how to get to the right spots to change it. In less than two hours, mine went from 39% to 5%! woo-hoo!
  10. KoukiFC3S

    KoukiFC3S Well-Known Member

    What a bug. I got the 2nd battery so I gotta do this all the time.
  11. daddyd302

    daddyd302 Well-Known Member

    It seemed to have helped a bit. Saturday from 3pm til 12am, my phone went from 100% to 20%, with about 30 calls, all lasting less then a minute.

    Today with about the same thing over, from 4pm til 1am, it was at 45%, so an improvement.

    This is about at par with my old Evo. I cannot understand how people are raving how great the battery life is and how much better it is when I don't see any difference. They either got a bad Evo or a great Epic.......
  12. sleipner

    sleipner Active Member

    I had 0% time without signal, but still had the same terrible battery life. I tried switching airplane mode on & off, but didn't notice a difference. I got Quick Settings from the market and turned off 'mobile data' which dropped the 3G icon from the notification bar.

    before I did this - 5 hours straight off the charger, no use, no TWS - 77% battery remaining

    after doing this - went to bed with phone at 35%, woke up 8 hours later and it was at 33%

    I'm thinking of trying juice defender, I think it can do scheduling of data downtime and allow individual apps automatic use of 3G.
  13. jsanta11

    jsanta11 Member

    Well before the fix I would be dead by 8hrs of moderate use for me, yesterday I made it to 10hr58mins @ 10% left before I plugged it in , So am happy as hell ... Thanks

    60 text
    25 emails
    1hr Kindle usage
    Nexus Mod Live wallpaper pro enable
    Screen brightness set to auto
    Juice defender set
    Couple of calls more then 10mins each
    Played angry birds
    Uploaded pics to facebook
  14. rmingee

    rmingee Well-Known Member

    Hmm, I'll try again later, but both of these failed for me (and it told me to try again later :))

    My TWOS was 50%, so I just did the toggle of airplane mode, hopefully it'll help. I was golfing in an area of low signal yesterday, and definitely noticed my battery draining faster. The Pre had that problem as well until a software fix got pushed.

    -- robert
  15. Mac Man

    Mac Man Member

    Glad I saw this. Turns out, I was at 51%
  16. gtl408

    gtl408 Well-Known Member

    Done, here's to hoping the update will fix this annoyance and maybe fix the hopping signal indicator, too.
  17. rmingee

    rmingee Well-Known Member

    8 hours later, and my TWOS has basically been 0 since the toggle, with much less of the battery being used for standby. Hard to say if it's made a big difference in battery life since I've been using it a lot, but I can't see how it couldn't help. Thanks for the tip!

    I still cannot update my profile - not sure if I ought to be concerned about that or not. the error it returns is simply "Internal Error".

    -- robert
  18. antmon

    antmon Well-Known Member

    good to know.... though mine is at 4% so i think it's ok (i hope) for now...
  19. SBT

    SBT Active Member

    I don't get what the point in turning on flight mode is though, seeing as how you can't use your phone for texts, emails or calls in this setting.
  20. peaxie

    peaxie Member

    Its primary use is when you're "In Flight." When you're on an airplane they ask you to turn off your cell phones so you don't cause RF interference with their signals. However, if you still want to listen to your music or play games on your phone you just put it into flight mode.
  21. gme109

    gme109 Well-Known Member

    You place your phone in airplane mode, then take it right back out. Some how or another this fixes your phone from looking for service while in standby. This is only a temporary, you'll need to do it every time you turn your phone on. Hopefully Samsung will permanently fix this battery drain problem.
  22. Othan1

    Othan1 Well-Known Member

    heh. That's actually very good battery life.

    Try going off the charger at 5:30AM and you're down to 54% by 7:00AM with very little to no use.

    At least with this fix I can go from 5:30AM to 7:30AM and have 83% left after texting several times, 30 minutes of music player, playing angry birds for 15 minutes, downloading about 5MB of files...hey, now that I think about it, this is pretty good. :eek:)
  23. forddna

    forddna Well-Known Member

    Okay, I toggled airplane mode on and off. And I did the "update prl" and "update profile" thing someone mentioned. Whatever the hell those are. *shrug*

    My TWS is 56% right now. I will report back in the morning.



    (note, I am just doing this out of my own curiosity on the TWS thing as I have very good battery life)
  24. forddna

    forddna Well-Known Member

    Update. I am currently:

    9hr 33m straight, signal on

    0% without.
  25. redguardian

    redguardian Member

    What I did was use the app "Tasker" to turn on then off "Airplane" mode automatically every three hours. Im curious to see how long the battery will last. I had 12% before.

Share This Page