Forcing Droid to Stay in Extended NetworkSupport


Last Updated:

  1. jaifo

    jaifo New Member This Topic's Starter

    Joined:
    Nov 18, 2009
    Messages:
    4
    Likes Received:
    0
    Is there a way to make Droid stay in Extended Network even when it thinks there is Verizon coverage? My old phone would stay in Extended Network at my house and work fine. The Droid resists switching over (but does go back and forth at times) and maintains its Verizon coverage but usually with zero or one bar. The phone doesn't ring nor hold a call like this.

    I went into Mobile network settings but neither of the options seem to do what I am asking. Is there something I am missing? THANKS!!!
     

    Advertisement
  2. andrewrodney

    andrewrodney Well-Known Member

    Joined:
    Nov 9, 2009
    Messages:
    46
    Likes Received:
    1
    Could it be the option for Wi-Fi Sleep policy (set to never)? Found in Advanced from menu when in WiFi settings.
     
  3. jaifo

    jaifo New Member This Topic's Starter

    Joined:
    Nov 18, 2009
    Messages:
    4
    Likes Received:
    0
    No I don't believe the WiFi settings would control which network the phone was in. I appreciate the response though. I've looked through the Internet and haven't found an answer yet so maybe you just can't do it. I have a friend with an iPhone and it is right there, easy as pie, on her phone. I basically need to FORCE my Droid to roam when I am at my home, as the Verizon signal isn't strong enough to work here. My old phone would just go into what it called Extended Network (I'm assuming that meant it ran off the neighboring US Cellular towers instead of the Verizon towers which were futher off, but I could be mistaken) and it would work just fine. The Droid resists roaming, and instead, I get NO service to speak of.
     
  4. droid99999

    droid99999 Active Member

    Joined:
    Nov 13, 2009
    Messages:
    32
    Likes Received:
    0
    I sometimes have the same issue. Under Settings, Wireless & Networks, Mobile Networks you can select Home or Automatic (not Only Roam). But try Home only and see if that works for you. Its will be a less than ideal signal for you but it should stop some of the hopping around going on.

     
  5. jaifo

    jaifo New Member This Topic's Starter

    Joined:
    Nov 18, 2009
    Messages:
    4
    Likes Received:
    0
    Do you know exactly what "home" means under that setting?
     
  6. gilahacker

    gilahacker New Member

    Joined:
    Nov 26, 2009
    Messages:
    1
    Likes Received:
    0
    I could *really* use this feature as well.

    Where I live, every major cell phone provider's coverage is spotty at best. Except for Alltel. I can literally walk out of my front door and see the Alltel tower. It's probably only about a mile away. For this reason, I signed up with Alltel when I moved here.

    Verizon bought Alltel and said everything was converted over some time in September. My contract with Alltel was moved to Verizon with the acquisition, but had actually expired, so I was able to get a new phone, the Motorola Droid.

    My coverage now is absolutely horrible. I get 0-2 bars (usually 0) and calls drop all the time. The only time I get a good signal is when the phone roams (then I get full signal and it works flawlessly). My guess is that Verizon has *not* fully integrated Alltel's equipment as they said they did. My phone appears to be only using the Alltel tower when "roaming".

    I have wi-fi at home so net access on the phone is no problem, but I'd like to actually be able to make calls from it from home sometimes too. :confused:
     
  7. droid99999

    droid99999 Active Member

    Joined:
    Nov 13, 2009
    Messages:
    32
    Likes Received:
    0
    It all goes back to when there was a big deal with charges about staying on your own network versus roaming.

    Best I know is that its Verizon's own network versus someone's that they buy airtime in bulk from to fill in their own coverage gaps. Naturally they prefer that their own network be used.

    If you switch to home only, you reduce the number of towers that are available to you. The good news is that your signal has less bouncing around where these home and roam towers coexist. The bad news is that you could find yourself in an area with no home coverage even though you have roaming coverage.

    My suggestion is to see if home only works better from a given problem location but switch to automatic when on the move again.
     
  8. MountainX

    MountainX Well-Known Member

    Joined:
    Nov 27, 2009
    Messages:
    140
    Likes Received:
    3
    I have the same thing -- very poor VZW coverage at my home. I use WiFi and Sipdroid for all calls at home. Much better quality. And I did have to set WiFi Sleep Policy to never.
     
  9. ned23

    ned23 Well-Known Member

    Joined:
    Dec 12, 2009
    Messages:
    85
    Likes Received:
    1
    Some cell users were putting their phones on "roaming" all the time to get out of their service contracts. So the cell companies took that option off all of their phones.

    The problem is, as you noted, that the "automatic roaming" feature does not work most of the time and as a result the user is frequently in a position where his/her phone is unusable.

    I think this can be fixed with a custom app, and I'm willing to pay for custom coding for it. I posted an ad here. I think the only way to fix this is for customers to complain loudly or file a class action suit against carriers to fix the issue.
     

Share This Page

Loading...