GAOSP 2.2 Froyo on the BH2


Last Updated:

  1. yahma

    yahma Well-Known Member This Topic's Starter

    Joined:
    May 12, 2010
    Messages:
    56
    Likes Received:
    4
    What specifically is preventing the use of Froyo from GAOSP (Galaxy 2.2) on the Behold II?

    I know BH_MAN was able to port the 1.6 Galaxy ROM to the BH2.. I think he even used the 2.6.29 kernel (same as in GAOSP).
     

    Advertisement
  2. Nu11u5

    Nu11u5 Well-Known Member Developer

    Joined:
    Feb 3, 2010
    Messages:
    263
    Likes Received:
    234
    Version "2.6.29" only means that the kernel build was based off of the Linux Kernel 2.6.29 source code branch. The source code is then modified and drivers added to specifically handle each device. Android also requries extra features/extensions for its versions (1.6 vs 2.1 vs 2.2).

    The kernel we are using for 1.6 may be based off of the same Linux branch as Froyo on the Galaxy, but it is missing those extensions used by later Android versions.

    Similary, the kernel on the Galaxy is missing the drivers we need on the BH2.

    Without source code its very difficult to go this route.
     
  3. bearsfan85

    bearsfan85 Well-Known Member Developer

    Joined:
    Feb 23, 2010
    Messages:
    459
    Likes Received:
    97
    On Some forums people were looking at taking drivers from the BH2 from India, and some of the galaxy builds and figuring out which ones work and which ones dont and try to build one that way but I believe that died
     
  4. euph_22

    euph_22 Well-Known Member

    Joined:
    Feb 24, 2010
    Messages:
    2,634
    Likes Received:
    595
    The same exact things that are preventing the 2.1 GAOSP (which is what bhman's 2.1 rom-in-progress is based on) from working. Drivers mostly.
     

Share This Page

Loading...