Glitchy data connection and weird error messages after rooting


Last Updated:

  1. mplsnst

    mplsnst Active Member This Topic's Starter

    Joined:
    Mar 22, 2010
    Messages:
    29
    Likes Received:
    2
    So I rooted a week or so ago. Didn't flash any new ROMs or anything, just deleted some bloatware and set up wireless tethering. Right away I noticed the data connection going up and down a lot. Then a few days ago I started periodically getting a black popup with this:

    ! Data Call Failure
    Error Code 67 .Registration failure.
    Your PCS Vision username and/or
    password may be incorrect. Please
    try again.

    When I get it, I just hit "dismiss" and so far, everything goes back to working normally at that point. Still, it's a little disconcerting. Anyone else gotten this popup or had their data connection messed with by rooting?
     

    Advertisement
  2. 330D

    330D From My Cold Dead Hands VIP Member

    Joined:
    Mar 4, 2010
    Messages:
    2,863
    Likes Received:
    779

    Yes, and I fixed it, but don't know if it works no matter what you have for a rom.... I will find out and let you know...


    Post #182 of this thread has the info about pushing the fix to your phone;

    http://androidforums.com/all-things-root-sprint-hero/84701-fresh-2-1-2-out.html
     
  3. SteaminLoaf

    SteaminLoaf Member

    Joined:
    May 18, 2010
    Messages:
    24
    Likes Received:
    0
    I think its something to do with trying to root while being on a stock rom... maybe not having superuser permissions?
     
  4. 330D

    330D From My Cold Dead Hands VIP Member

    Joined:
    Mar 4, 2010
    Messages:
    2,863
    Likes Received:
    779

    I have rooted 1.5, with fresh 2.1.2 flashed, and it happened to me. It is a known issue with .omadm.apk. i am not sure what it is or does, but since I pushed the fix, I have had zero issues with the data call failure.
     

Share This Page

Loading...