Gtalk error "Could not connect to server, will retry shortly"Support

Last Updated:

  1. santosh.skumar

    santosh.skumar New Member

    I am having samasung galaxy fit, android version 2.2.1

    i am connected to the wifi, and the internet is working fine, no issues at all, i am able to send mails from gmail account and receiving mails also.

    BUT when I try to login to gtalk, it gives me the error "Could not connect to server, will retry shortly". Also I am not able to download any thing from the market.

    I have tried doing the factory reset several time, but of no use.

    Please help.

  2. varungnath

    varungnath Well-Known Member

    First of all, im not a galaxyfit user, But found an information on another forum that could help...

    Step 1: In the android menu, go to the settings.
    Step 2: Select applications.
    Step 3: Load list by clicking 'Manage apps"
    Step 4: Click on Google talk; Click clear data and Click ok to confirm.
    Step 5: Under clear button, click clear cache.

    This may not be a fix, but is worth a try. :) let know if it helps!


    And about not able to download anything, have to ever tried removing the battery and sim out of the phone and putting it back in after sometime???
  3. vsanandan

    vsanandan New Member

    I am using Motorola Defy MB525. Connected to internet through Wifi. I could browse and see the mails from gmail and others, but when I try to download some application it stuck with "Starting Download". From a google site I found suggestion to restart gtalk. I subscribed to gtalk and try to connect but that also stuck with "Could not connect to server. Will retry".
    I'm trying the same for several days. I cleared the gtalk and other caches as suggested , switched between 3G and 2G and did few factory resets etc, but no solution yet. :mad:

    Has any body found a solution for this? Please help? I see from others that this doesn't work for internet connections other than Wifi also.
  4. Kinjal Shah

    Kinjal Shah New Member

    Hey I also get the same problem from tomorrow.and i have cleared the still i got same problem.. if u have any idea then plz help me..
  5. MMax_A45

    MMax_A45 Member

    Try updating to gingerbread...
  6. antamidhya

    antamidhya Member

    I had the same problem, try this it works:
    Go to Settings -> Applications -> Manage Applications -> All
    1. Select 'Market' -> Clear Cache -> Clear Data
    Go back
    2. Select 'Google Services Framework' -> clear cache -> clear data
    3 Reboot

Share This Page