Help!!!! Superpad 2 stuck on calibrate... Look pleaseSupport


Last Updated: 2014-10-03 07:28:45
  1. averagejoe604

    averagejoe604 New Member

    HELPP! I have a superpad 2, the p041 model and I cant seem to get past the touch calibration screen. I did a factory reset on my pad while go, and now everytime I reboot it it says "TOUCH CROSSHAIR TO CALIBRATE" AND then it gets stuck on 'TRY ONCE MORE" I seriously cannot get past these screen no matter, how hard and repetitive i press on these crosshairs. Plugging a mouse in doesnt seem to work when i try clicking on the crosshairs also. I CANT GET PAST THIS SCREEN!! HELP PLEASE, I WILL APPRECIATE ANY, BECAUSE I DONT WANT TO USE THIS TABLET AS A PAPERWEIGHT :( I cant even access anything because everytime i turn it on, im at the screen calibration test.


    p.s does the p041 model mean i have a fake superpad also :|

    Advertisement
  2. paulsam7

    paulsam7 Active Member

    Since you know it's a P041, you could try flashing a newer P041 firmware. (Google "flytouch3 P041 firmware"). I upgraded my P041 with a newer firmware and it improved several slightly buggy problems. Anyway, could solve your boot problem (IF it's not hardware-related!)
  3. averagejoe604

    averagejoe604 New Member

    Hey guys everytime I reboot I still am at the "TOUCH CROSSHAIR TO CALIBRATE" AND then it gets stuck on 'TRY ONCE MORE"...help? is there anyway i could put a file into my sd card that has pre-set screen calibration settings? much help appreciated..
  4. paulsam7

    paulsam7 Active Member

    Sounds like the screen is broken - no response to touch. I have no idea how that could have happened just with a software reset, but... no answers come to mind.
  5. rosina71

    rosina71 New Member

    hi joe did u get this sorted
  6. rosina71

    rosina71 New Member

    hi can someone hekp please i done a tetest on my android,,and now when i boot it up,its saying touch crsoohair to calibrate..i ant get past the screen can soemone help me plzzzzzzzzzzz
  7. dart16

    dart16 Well-Known Member

    Two possibilities -
    1/ your touch screen and/or connecting ribbon cable is broken

    2/ you have corrupted the firmware

    the corrupted firmware is easiest to fix, download an appropriate firmware for your model number and re-flash it
    If its the touch screen then you could buy a replacement (************ or ebay) and replace it.
  8. kokii25

    kokii25 New Member

    First open ur tab first and wait until the Phrase " touch crosshair to calibrate " Then Use Somthing Like A Pencil and touch the center inside the circle each time it appears ( 5 times ) > after that u will find it opened ........
  9. dart16

    dart16 Well-Known Member

    :d:d:d
    kid98765 likes this.
  10. penta

    penta New Member

    I had the same issue. The narrow cable that comes from display was causing the issue. Fixed it properly into motherboard socket and that solved the issue.

Share This Page