help update from 1.0 to 2.2General


Last Updated:

  1. kiddykoff

    kiddykoff Guest This Topic's Starter

    I actually posted this in the updates and cupcakes board, but i was told this board would be better.

    So i'm new to this android scene, but i'm ready to dive in. I just want to make sure of some things before i brick my phone.

    I got this phone from my sister and hasn't been used in a long time. It's running now, but the firmware is out of date

    Model number:
    T-Mobile G1
    Firmware version:
    1.0
    Baseband version:
    62.33.20.08H_1.22.12.29
    Kernel version:
    2.6.25-01843-gfea26b0 android-build@apa27 #6
    Build number:
    kila-user 1.0 TC4-RC29 115247 ota-rel-keys,release-keys

    i was going to follow these instructions for updating to Froyo. [ROM][BBQ] CyanogenMod-6 for Dream & Magic - V6.0.0 (08/28/2010) - xda-developers
    but they are a bit confusing.

    I guess i have to install a boot loader, CyanogenMod 6.0.0-DS and i'm following these instructions
    Dream:Installing CyanogenMod 5+ - CyanogenMod Wiki

    i downloaded
    latest CyanogenMod ROM: update-cm-6.0.0-DS-signed
    latest EBI1 kernel: bc-4.2.15.1-ebi1-signed
    latest Google Apps: gapps-ds-ERE36B-signed

    my question is that it says to copy them as update.zip to the root of the phone. but there are 3 of them. How can they all be named as the same, but at the root of sd card?

    can someone clarify this for me. or tell me i'm doing something wrong

    also, what are the benefits of rooting a phone? i know that it has to do with permissions, but what permissions am i missing as a non-sudo user?
     

    Advertisement
  2. CuBz

    CuBz Well-Known Member

    Joined:
    Sep 21, 2010
    Messages:
    1,654
    Likes Received:
    230
  3. kiddykoff

    kiddykoff Guest This Topic's Starter

    well to be honest, i don't know what i want. I just know that i'm unable download things from the market and i guess it has to do with not having the latest firmware. (i guess this could be coming from experience of not wanting to update my firmware on my ps3.)

    If i want to update to 2.1, is there a set of instructions that could be recommended for a beginner?

    any other suggestions are welcome.
     
  4. ashykat

    ashykat Well-Known Member

    Joined:
    Apr 27, 2009
    Messages:
    1,076
    Likes Received:
    127
    Strange double post.
     
  5. ashykat

    ashykat Well-Known Member

    Joined:
    Apr 27, 2009
    Messages:
    1,076
    Likes Received:
    127
    There are certain apps that are only compatible with 2.1 or 2.2, but the fact that you're still running 1.0 is the bigger problem as the G1 has been updated to 1.6. If you haven't received a popup that an update is available, do this to manually check:

    Install AnyCut from the market. Create a new shortcut on your phone
     
  6. kiddykoff

    kiddykoff Guest This Topic's Starter

    i got a pop-up prompting for an update, and the phone restarted and it looked like it had an icon with an arrow coming out of the box (unpacking?) then then i got an error with a yellow triangle and exclamation.

    I'll try installing that app, right now
     
  7. kiddykoff

    kiddykoff Guest This Topic's Starter

    i looked for the app and couldn't find it, but i did try and update it.

    Once i said yes to updating my phone restarted and tried to install the new firmware, but it came up with an error. I had to take the battery out to restart.

    can someone help me update to 1.6 at least?
     
  8. kiddykoff

    kiddykoff Guest This Topic's Starter

    bump
     
  9. ashykat

    ashykat Well-Known Member

    Joined:
    Apr 27, 2009
    Messages:
    1,076
    Likes Received:
    127
    Here's how to manually do the update:

    First download the official 1.6 ROM http://android-roms.googlecode.com/files/signed-kila-DRC83-from-CRC1.c41b93c1.zip

    -Copy the downloaded file to your sd card.
    -Rename the file update.zip (make sure it's just update.zip, a lot of people accidentally make it update.zip.zip)
    -Reboot your phone into recovery mode. Power off the phone first and then hold down the Home key while powering it back on.
    -The recovery mode is finished loading when you see the ! mark inside the triangle. Press Alt+L to display the list of options.
    -Press Alt+S to flash the file update.zip.
    -Wait for the update to apply. Your phone may reboot during this process.
    -Press Home+Back if it asks you to reboot your phone.
     
  10. kiddykoff

    kiddykoff Guest This Topic's Starter

    thanks, i'll do this right now
     
  11. ashykat

    ashykat Well-Known Member

    Joined:
    Apr 27, 2009
    Messages:
    1,076
    Likes Received:
    127
    No problem, let me know if it worked out.
     
  12. kiddykoff

    kiddykoff Guest This Topic's Starter

    alright i'm having a problem with the zip. I'm getting an error when booting into the recovery utility and another when trying to apply the update.

    Code (Text):
    1. E:Can't open /cache/recovery/command
    2.  
    3. Home+Back - reboot system now
    4. Alt+L - toggle log text display
    5. Alt+S - apply sdcard:update.zip
    6. Alt+W - wipe data/factory reset
    7.  
    8. Installing from sdcard...
    9. Finding update package...
    10. Opening update package...
    11. Verifying update package...
    12. E: No signature (302 files)
    13. E: Verification failed
    14. Installation aborted.
    15.  
    16. Press Home+Back to reboot
    I just bought a new SD card, because i thought it might have had a bad sector. This leads me to believe that it's trying to access a filesystem that isn't recognized by windows or linux, which i'm using.
     
  13. kiddykoff

    kiddykoff Guest This Topic's Starter

    A week after my finals I've finally figured out how to root my phone. I used the guide that was suggested, but it's dated. There is a different recovery image and there is a different cyangenmod and google apps has to be downloaded seperately.

    However i would have never been able to figure out that telnet stuff.

    I'll detail my steps later, but now i'm going on vacation and need to figure out how to use the internet from my phone on my laptop, among other things.
     
  14. sillyphilly

    sillyphilly New Member

    Joined:
    Jan 26, 2011
    Messages:
    1
    Likes Received:
    0
    hey i have the same problem i tried too root my phone to the 2.2 i had the 1.6 android earlier...and now its at 1.0 and i need steps to get at least to 1.6 please help :(
     

Share This Page

Loading...