How to restore system folder


  1. bobbaluba

    bobbaluba New Member

    I followed two guides over at transformerprimeroot.com. One for rooting my transformer and one for installing ubuntu.
    The process seemed to do weird things to my binaries though, and several commmands i didn't know it would do. One of them was cd /system/bin/ && chmod 4777
    There are other problems as well:
    Random crashes in gmail and other applications
    Compiling helloworld and installing via eclipse causes a segmentation fault.
    Starting a terminal emulator launches a shell with superuser permissions (i don't wan't that, i wan't to type su to do superuser stuff!)

    I did a factory reset because i thought that would restore my system directory, but it didn't. Android Market crashed just a few minutes ago, and i still get a root terminal when running terminal emulator. Now i feel kind of stupid because i didn't take a backup or verify that factory reset did what i thought it would do.

    Any tips on how to fix my system folder?
    Could i download a dump and copy over the system directory, or would that cause even more problems?

    Advertisement
  2. JAy3001

    JAy3001 Well-Known Member

  3. ylexot

    ylexot Well-Known Member

    I don't see the guide on installing ubuntu over there, but I'm guessing that it required unlocking your bootloader. If that's the case, install this or some other ROM:
    [ROM] 04/10/12 Stock, Rooted, BusyBox 9.4.2.21 - xda-developers

    That will replace everything and get you back to a stock OS (+root, etc.).

    And personally, I'd stick with mods posted over at XDA. That site seems a bit sketchy to me.
  4. JAy3001

    JAy3001 Well-Known Member

    Well said ylexot. :)
  5. bobbaluba

    bobbaluba New Member

    Yes, it seems sketchy indeed. And only allows moderated comments. I should probably have seen the blinking red light.
    It's the same guy as androlinux, that's where i found the guide.
    It's the top hits on google for "transformer prime root" and "transformer prime ubuntu", though.

    Anyway, here is the guide (it's for running ubuntu in a chrooted environment):
    How to Install Ubuntu on Rooted Transformer Prime! | Android+Linux=AndroLinux

    I haven't unlocked the bootloader yet, but i might as well do it.
    Are there any disadvantages to flashing with another rom? Will I still get updates the normal way?

    EDIT: typo

    EDIT: If I download the firmware from asus' own web page, do i still have to unlock the bootloader?
  6. ylexot

    ylexot Well-Known Member

    Since you haven't unlocked the bootloader, you should be able to load the firmware from ASUS. Keep in mind that version 15 is rootable, but version 21 is not.
  7. bobbaluba

    bobbaluba New Member

    How do i load the firmware? I tried holding volume down, then pressing volume up, but all i get is a picture of an android lying on it`s back. Can you please point me in the right direction?

    EDIT: found out myself. Put the zip on the microsd card and inserted it into the prime. Android recongized the file.

    EDIT2: Everything is back to normal now, i can even run HelloWorld :)
    I installed version .15.
Loading...

Share This Page