How to root Huawei IDEOS X3 (U8510)?


  1. sammmurai

    sammmurai New Member

    Hello, any help in how to root Huawei IDEOS X3 (U8510)?
    (for an android newbie)

    Thank you!

    Advertisement
    :
  2. mechanicarts

    mechanicarts New Member

    Try z4Root. This is the only way so far that successfully works with u8150 (I've tried many others, but maybe there are others too, but z4root is just one click)

    [APP] z4root - xda-developers
  3. Gmash

    Gmash Well-Known Member

    The x3 has gingerbread, so I don't think z4root is going to work. Try Gingerbreak, but there is no guarantee that will work either. Good luck. Please report back with your results to help other people with this phone.
  4. sammmurai

    sammmurai New Member

    z4root dont work (crash)
    gingerbreak dont work (gingerbreak error data is in an unexpected location)

    any successful tips?
  5. Zenuno

    Zenuno New Member

    Hi.

    I just try Super One Click 2.1.1 and no luck, i'ts fails in step 6... :(

    I also try Z4Root and the result is the same... :mad:

    Peace
  6. nu2andy

    nu2andy Well-Known Member

  7. TV!

    TV! Well-Known Member

    Hi Rakaan,

    My girfriend has just bought one of these and im thinking of rooting it as it looks straight forward enough.

    How have you found running the CyanogenMod 7.2 any issues ? Can you also confirm does it support apps 2 sd as the ROM has been ported from developers on Spanish and German Forums and even with using google translate im still not a 100% sure also do you need to partition the SD card ?

    Any replies greatly appreciated.

    Many Thanks
  8. Charger2008

    Charger2008 New Member

    Hello! I'm new here, I'm from Portugal and my operator is Vodafone. My phone is locked to them, so I want to have access root, also if I need to change SIM Card and delete all the useless gizmos. I even try a rom upgrade... :(
    I'd tried almost every thing:

    Instant root: forget it
    z4root: nevermind
    CyanogenMod: I had one but freeze the phone
    If someone help... I'll be gratefull
    Best Regards
Loading...

Share This Page