Howto install DATA2SD: Guide

Last Updated:

  1. droidzone

    droidzone Well-Known Member

    Thanks..I think Richard Trip suits me..

  2. droidzone

    droidzone Well-Known Member

    This is a bit of an Anticlimax..

    My Phone suddenly started developing Force Closes after a reboot. Not sure what made it behave like that. Maybe the Sync-Off, or the class 2 Card..

    Wiping and trying again..
  3. SUroot

    SUroot Well-Known Member Developer

    I get that sometimes after flashing things.

    I find if I flash a kernel (or a few in a row maybe) that eventually it all f*cks up.

    I have to wipe data and Advanced restore>SD-ext via Nandroid
  4. droidzone

    droidzone Well-Known Member

    How do you explain it?

    A ROM which works perfectly well for 10-15 reboots suddenly goes loony!

    I hadnt made a Nandroid of this one since I wasnt sure it would work..

    So I've wiped everything..
    Dont have a Nandroid ext to restore..
    Dont I have to erase the ext file on FAT32..Since it's invisible, how do I do that? Format sdcard? Or will it work only for Partition1?

    What steps to be repeated to reinstall Data2SD on a system which was previously on DATA2SD, but wiped? No Nandroid available..
  5. SUroot

    SUroot Well-Known Member Developer

    Its not the rom. Its the Partition. It must be the mounting / unmounting of it. It gets corrupt quite easily.

    Mine is stable as hell, until I want to flash something, then sometimes, I have to do a lot of work to recover it.
  6. droidzone

    droidzone Well-Known Member

    Edited the previous post.. Can you suggest a solution without doing the whole procedure all over again? Wish I'd installed Amon-Ra..It was good for partitioning..
  7. droidzone

    droidzone Well-Known Member

    Whatever it was, it corrupted my Recovery.. I did a Fastboot Flash of Clockworkmod..But it still keeps looping at the Joker's image..
  8. Rastaman-FB

    Rastaman-FB Well-Known Member

  9. droidzone

    droidzone Well-Known Member

    Nopes, it was the latest version of Clockwork mod..
    Tried Amon Ra too..
    Nothing..The image flashed ok, but looping at the joker again while going to recovery.
  10. SUroot

    SUroot Well-Known Member Developer

    There's a good flashing app on xda. I used it to fastboot flash

    Not had any recovery issues with dat2sd though
  11. droidzone

    droidzone Well-Known Member

    What should I search for? Keywords/Link? ..It's not turning up in my searches..
  12. droidzone

    droidzone Well-Known Member

    Sorry..Forgot that you're in the office..
  13. Rastaman-FB

    Rastaman-FB Well-Known Member

    latest one is
    its a baddy

    hmmm you can get clockwork recovery from here
    [AlphaRev] Public release S-OFF HTC Desire GSM - xda-developers

    flashing tool if you want to do it with a gui can be found here
    [UTILITY] 1-click Android Flasher(Recovery, splash1, Radio, HBOOT)[V1.5.5](UPD!) - xda-developers
  14. droidzone

    droidzone Well-Known Member

    Oops..Forgive my ignorance..My Clockwork was Tried reflashing that, no use. Reflashed the Hboot from alpharev..nothing again

    That link gives a gui..Was using the same commands via shell..

    I need something stronger..Would using alpharev again help? Or would it brick?
  15. Rastaman-FB

    Rastaman-FB Well-Known Member

    im not sure how redoing alpharev will work
    I have a feeling this is something else and you wont like it.

    Ive seen this behaviour when the SDcard is corrupted.
    try a different sdcard and see if you can boot to recovery

    You could try booting into recovery without an SDCARD at all
  16. droidzone

    droidzone Well-Known Member

    Tried switching sdcard too, nothing would work..
    Finally fixed it..

    What's with my phone and bricking? I seem to be a lightning rod for it! Had a harrowing time, but finally fixed it..

    What I tried:
    1. As suggested by Alpharev:
    fastboot erase recovery
    fastboot flash recovery recovery-clockwork-
    fastboot reboot-recovery

    It wrote fine, but again the Joker looped..

    2. Tried flashing Amon-ra by above method, didnt work.

    Which led me to think something other than Recovery was corrupted. So I flashed my Nandroid backup created earlier by the following steps. Hopefully it will help someone else who gets the Alpharev Joker Loop.

    3. Copied my Nandroid backup files (*.img) to Tools folder
    fastboot flash boot boot.img
    fastboot flash cache cache.img
    fastboot flash data data.img (This one failed: FAILED (remote: partition does not exist!)

    fastboot flash recovery recovery.img
    fastboot reboot

    It rebooted and got me into Android home, then promptly restarted..Which meant half the problem is over. Tried to get into recovery again, but Joker looped.

    So, I tried flashing Clockworkmod again:
    fastboot flash recovery recovery-clockwork-

    fastboot shutdown
    fastboot reboot-bootloader

    It worked! I got back my recovery

    I didnt see these instructions anywhere..Just intuition. Still worked.. Thanks, Rastaman-FB and Dan, for pointing me in the right direction! :)
  17. Rastaman-FB

    Rastaman-FB Well-Known Member

    thats mental
  18. droidzone

    droidzone Well-Known Member

  19. Rastaman-FB

    Rastaman-FB Well-Known Member

    yeah, i wasnt aware the other images would affect recovery.
    must have been the boot.img still though thats borked
    i wonder whether it was the flash of s-off that caused the issue.
    had you tried to access recovery since s-off prior to this problem?

    eitherway thank fk for s-off tbh other alternative would have been good ol RUU
  20. droidzone

    droidzone Well-Known Member

    Yes, on countless occasions since I was experimenting with Data2SD..There never was a problem getting into Recovery after Alpharev. I know they've documented it, but dont know why it stayed low for so long.

    And they've said about Recovery getting corrupted, nothing about Boot getting corrupted.

    ..But have a mixed experience with RUUs. The only one for my branded Indian device was an old version. Last time I didnt have a goldcard, and I got an SLCD brick after flashing the Indian RUU.

    Couldnt recover.
    Took it to HTC, they replaced the SLCD and gave me an AMOLED Desire..Hence thankful for the brick for my awesome AMOLED display..

    Still I'm scared of RUUs..Anyway I'd have to use the WWE and change the CID if I did that.
    Thanks to S-OFF. Else I'd have been stuck!
  21. SUroot

    SUroot Well-Known Member Developer

    Ours is not to reason why. Ours is but to flash and die
  22. droidzone

    droidzone Well-Known Member

    lol.. :D
    But not without a fight.. ;)
  23. Rastaman-FB

    Rastaman-FB Well-Known Member

    but surely now you have a gold card, so you can use any ruu as long as its the same or higher than the current
  24. droidzone

    droidzone Well-Known Member

    That's true..But you know what.. I tried running the Ruu as from card, and it wouldnt get recognized.. The file is supposed to be picked up by fastboot, but it wasnt.

    And RUUs give me weird error messages. It says my battery is <30% when actually it was near fully charged.
  25. Rastaman-FB

    Rastaman-FB Well-Known Member

    lol you are just unlucky
    the must be extracted from the installer, i had a friend who was telling me they couldnt flash it and he actually zipped the exe and put it on the sdcard.
    sufficed to say this didnt work lol.
    also people have not noticed it was actually called due to windows hiding the extention

Share This Page