I have a Superpad stuck on android logoSupport

Last Updated:

  1. Doniphan

    Doniphan New Member

    I have a Superpad stuck on droid logo. I tried factory reset. No result. I think is because the method i followed is for another model of he supperpad. I cannot find a correct method for my model:

    a SuperPad [9V / 2 TF Slots / two USB slots / 1 ethernet slot / sawee10 / 10" display]

    I also bought a male to male USB cable to flash from the PC. (because I readed that my model cannot flash with the TF card method). The PC doesnt even recognize it and doesnt ask for the driver.

  2. dragonsuicida

    dragonsuicida New Member

    I have the same problem, I bought it, used it 2 days downloaded couple app and left it on the desk for about a week, came back it was stuck on infotmic screen. reset it and it goes to the linux pinguin and to android_ stays there forever.....
    I tried the home power back and nothing. USB cables don't work, pc wont even recognize. been like that for few monts looking for a solution. I think I will draw a red circle on the screen and use it for target practice. Freeking Chinese tablet...

Share This Page