I want to do this steps to my galaxy s4 att but I do not know how to do it


  1. elmostro44

    elmostro44 Member

    How to Unroot The Device:
    Now lets unroot the device:

    1. open ESFile Explorer
    2. Grant Root permissions
    3. click menu
    4. Click Root Explorer on the left
    5. Click Mount R/W
    6. Check all the RW boxes and click OK
    7. On the top of the app, click the / icon
    8. navigate to System/xbin
    9. delete busybox and SU
    10. close ESFile Explorer
    11. Go to System setings
    12. Click the More tab
    13. Click Applications and uninstall SuperSU
    Now reboot the device twice and you should have a 100% clean system and be fully unrooted


    I am new in this but, how I go to GrantRoot permissions?

    Advertisement
  2. Atma

    Atma Well-Known Member

    Hi elmostro. :hello: I moved your post to the AT&T All Things Root forum for you.

    To grant root permissions, you would first need to be rooted and have superuser installed. When you try an app that needs root permission, superuser will popup and ask if you want to grant permission.
  3. CrimsonPride

    CrimsonPride Well-Known Member

    Is your device even rooted?
  4. blazeddd

    blazeddd New Member

    Is there any other way to grant permission to an app?

    I have this battery app that has an option to limit the CPU when in lockscreen, but whenever I try to do it, it tells me a message that I need to root my phone and grant permissions to it.

    I have rooted my phone and have granted access to many other apps including Root Explorer by a pop up that comes up when first opening the app.

    But in this battery one, it just never popped up and I also uninstalled and reinstalled it just to make sure, but no message asking for permissions ever pops up.

    I also tried launching SuperUser and adding it manually, but there is no option to do so.. any clues on what I can do?
  5. elmostro44

    elmostro44 Member

    thanks I did it , thanks
    Atma likes this.
  6. Atma

    Atma Well-Known Member


    Hi blaze :wavey: Welcome to AF.

    I'm not sure of another way. Try going in settings > apps and clearing the superuser app data. Try your battery app again and see if superuser asks for permission. If that doesn't work, maybe try contacting the developer.
    blazeddd likes this.

Share This Page