If you have wifi problems read this


Last Updated:

  1. logoo

    logoo New Member

    I used to be so much angry against my wifi connection which lasted for a few minutes/seconds then droped out... I was about to return my legend but i read somewere a very good tip ,that's why i'm writting this post if it can help someone who has the same issue...

    Download from the market an app called "Wifi Fixer" it's a background app that checks if you're still connected to the wifi and if no, it reconnects you automatically.

    Advertisement
  2. Curnsie

    Curnsie Active Member

    This hasn't worked for me! Wifi still useless!
  3. GeoffBot

    GeoffBot Well-Known Member

    It's a bit of a pain but lots of routers can use MAC address filtering instead of WEP/WPA (as in, turn security off but filter). I just did this on my home router and it seems to have fixed the issue.
  4. Curnsie

    Curnsie Active Member

    My problem isn't the initial connection. Its staying connected and signal strength thats problematic.

    I have an access list set up on my router. I'll turn it off and see what happens. I'll keep WEP enabled.

    Drew
  5. Twatko

    Twatko New Member

    Hi - I changed my home router wifi channel to channel 11 (it was on 3) and this has worked for me. Hope this helps (at least when you are at home)

    Welcome to Greenlight - Greenlight, LiveTheBusiness.com - UK & Jersey (CI)
  6. Mantidae

    Mantidae New Member

    For me it's the opposite: it wont connect when filtering on MAC but WEP security works fine.
  7. Mantidae

    Mantidae New Member

    (I'm using a Netgear WIFI router)
  8. Cosmo Kramer

    Cosmo Kramer Member

    For the first month I had my Legend I used to always wonder why my wi-fi would not stay connected.

    Turns out the default setting was for it to stay connected for only 15 minutes then disconnect. I changed it to 'never' disconnect and it's been good ever since.

    I guess you guys have already done this though.
  9. Alenah

    Alenah New Member

    I signed up just to tell you this tip.

    I was furiously mad because I couldn't get my WiFi to work with ANY network. I was damn close to wipe and reflash a new rom because of this.

    BUT.

    What I did was, go into the WiFi menu. Longpress every network you've stored and hit "Forget", on every single one. Turn off WiFi. Turn it on again.

    Ta-****ing-da.

    Thanks.
  10. luckypatel

    luckypatel New Member

    hello friends,
    i have htc legend. i also had wifi issue. i just tried some different routers and finally found some result. generally my htc legend connects all the router but cant access internet from TP-LINK router. you just try to change your router and get i have tp-link router so i use virtual router software in my lappy. and finally it works with virtual router.

Share This Page