1. Download the #1 Android News App:   EarlyBird - News for Android
    Dismiss Notice

[International] No 4G/LTE

Last Updated:

  1. Can anyone help? I have rooted and am using Viper ROM. I have a 4G sim but cannot get 4G. I have checked with my network and they state there is no problems with their service. They have exchanged my sim card and I :(still have no 4G. I have downloaded an app from my network provider which can check your phone for 4G and it states my phone is not 4G enabled. Do we know what could be causing this?

    I am on the tesco mobile which uses o2's network in the UK. I downloaded their app when I took out their 4G service. This is the app that told me my phone was not 4G enabled. I have an unlocked M7 UL 64GB HTC One.

  2. Bump. Does anyone know what is the problem? Will this be hardware or software related? Thanks for any guidance.
  3. InfernalByte

    InfernalByte Well-Known Member

    There used to be 2G/3G selectors on older roms, have you gone through your settings? I have never used Viper.
    scotty85 likes this.
  4. scotty85

    scotty85 Guides Guide

    What data are you getting? Only Edge(2g) or are you able to pick up umts or hsdpa 3g?

    Also,just to make sure were on the same page,are you looking of "old" 4g(hspa+) or are you looking for LTE?

    Its possible you may need an apn change,has your carrier walked you thru a setting that supports your missing 4g?
  5. I am on the tesco network in the UK which uses the o2 network. I have been getting 3G without a problem. Tesco do have their own app which I installed and there is a segment regarding 4G capability. When I have checked for 4G availability it states I do not have a 4G phone! Confused :(
  6. InfernalByte

    InfernalByte Well-Known Member

    Did everything work fine and dandy before root?
  7. To be honest I don't know. Got the 4G SIM after I rooted. Would go back to stock but am not finding it easy to do so on a mac. Rumrunner doesn't work on a mac I believe?
  8. chickent1ts

    chickent1ts Member

    Just curious OP,

    Did you try resetting the APN under "mobile data" settings?

    I recently switched carriers on an unlocked vanilla HTC sense ROM, and even though the APN *claimed* to be on "auto", I still had to enter the APN info by hand.

    Once I did my 4g was up and running.

    This place is a good example, but you'll have to either contact your carrier for their APN settings or luck out with Google.

    Link Here:World Wide Mobile Phone Settings

  9. Yes I have tried that to no avail. It's got me stumped has this
  10. InfernalByte

    InfernalByte Well-Known Member

    Did you get sent the settings texts? I ave only two suggestions; a) get in touch with the carrier for your settings, b) try another rom.
    scotty85 likes this.
  11. scotty85

    scotty85 Guides Guide

    these are about the only things i can think of as well. if you are s off currently,try running an ruu to get back to 100% stock.

    do you have other devices that your current sim works in,and have working 4g?
  12. I might try using another ROM to see if this will make a difference. Any recommendations? I am S-On at the moment and would happily go back to stock but I am having difficulty doing it on a mac.
  13. InfernalByte

    InfernalByte Well-Known Member

    By far the best plan of attack would be to get your settings sent to you by your provider first!
  14. I got the APN settings from here:

    Tesco mobile APN settings | Geek Squad

    This didn't work so there was an option to reset them to default, which I did. The Tesco app when I use it has a section 'Getting set up for 4G'. When I check on that it says 'you need to upgrade to a 4G phone'. Will this be the ROM, APN settings or a hardware issue? Rational thought has gone.
  15. InfernalByte

    InfernalByte Well-Known Member

    That page was posted nearly a year ago!
  16. I know. There is a link on the thread about APN settings and they are still the same as those. I reverted them back to default settings anyway. Can APN settings make an app think a phone is not 4G?
  17. clsA

    clsA Well-Known Member

    what are the settings for network here:
    HTC Info Menu *#*#4636#*#*
    then click phone information
    then half way down the page Set Preferred network type:
    is LTE Auto in the box ?

    Attached Files:

  18. It is and I have ticked that option, makes no difference. Could this be a hardware problem?
  19. scotty85

    scotty85 Guides Guide

    It certainly could be a hardware issue. Despite being a an LTE capable device,it may just not pick up O2's LTE band,wich is 800 MHz, according to this: http://en.wikipedia.org/wiki/O2_(United_Kingdom)

    While m7_ul specs do include an 800 band for LTE,not all variants will have that enabled(much like the t mobile 1700 band). Being a us developer edition,your 800 LTE band may be locked,for lack of a better way to explain it.

    My guess is that if you've used the recomended apn settings and have the network setting on LTE auto,you may have to be happy with hspa+ :( or possibly trade your us phone for a European m7_ul wich theoretically should have a working option for 800 MHz LTE
  20. We will have to see. UPS have picked up the phone today to see if HTC can fix the issue. I will hopefully find out soon enough. I should have taken a screenshot of what the Tesco app showed.
  21. scotty85

    scotty85 Guides Guide

    See above... I was editing as you were replying. I think your situation is similar to a dev edition on t mobile... Where it will not pick up hspa+ on the 1700 band,like a t mobile variant will
  22. Got the phone back yesterday. They have unrooted the phone but still have no 4G. There was no note saying what they have done, or if there was a fault with the phone which I find quite strange. Checking the phone again it is a HTC One 801s 64GB and I think it will be on the 1800MHz band which is probably why the Tesco app states I do not have a 4G phone.
    I take it this will be a hardware issue and there is nothing I can do unless I can get a network provider who uses the 1800MHz band for 4G? Is there anyway I can check what frequency the LTE is on the actual phone?
  23. scotty85

    scotty85 Guides Guide

    if the phone is truly wanting to utilize that band,then yes. youll need to find a carrier that uses it. quick searching shows the "801s" to be not well defined,and insinuates that 801s and 801n are both M7_ul and listing regions where they were released,but not really making any mention of what frequencies were used

    you mean what frequency the phone wants to pick up? if so,then none that i know of(but that doesnt mean one doesnt exist)

    if youre wanting to see what frequencies the phone is picking up,there are widgets that will tell you that.

    sorry i couldnt be of more help than that. :eek:
  24. Thanks scotty85. I contacted HTC again and they think the phone I have is an Australian model which won't have the 800Hz frequency (although they did not confirm this, and they had the serial number for the phone). They said the frequencies for the phone will probably be 900, 1800 and I think 2100 MHz. Looks like I will have to try and find a provider that uses those frequencies (if there is one) :-(
    scotty85 likes this.
  25. cookiesnfooty

    cookiesnfooty New Member

    Assuming by tesco are you in the uk if so there isn't a network on that band

Share This Page