[International] S4 I9505 not booting with Omega ROM

Last Updated:

  1. rzkman

    rzkman New Member

    Hello all,
    Got myself into a slightly embarrassing situation today where my SGS4 I9505 will no longer boot. Hope some kind soul(s) can point me in the right direction.
    I have had reasonable success in rooting and upgrading the ROM on my S4, but on the scale of things I would be classified as a noob. Knowing just enough to be dangerous!
    So here is what I have. I have installed the TWRP v2.5.0.2. (I have tried to restore an old backup to back-paddle, but it said Restore Failed :-( ). I was on v12 of Omega ROM but it was slightly unstable (rebooting itself maybe once or twice a day) so I went to v13/v13.1, but found that I wasn't getting any mobile signal (I think I might have stuffed up the order of having to install the modem via ODIN first and then flashing the ROM). As I was impatient I reflashed back to v12 to restore my mobile function. All seemed fine until I took a photo and tried to do some editing in an app. It would hang whilst trying to save the image. I thought maybe the internal storage was corrupt and needed a reformat. I went into TWRP and selected WIPE -> FORMAT DATA. This is when things when off the rails. Since doing this operation, neither v12 of v13.1 of Omega is booting for me. V12 doesn't make it past the Samsung screen and reboots. V13.1 makes it to the Omega logo which is meant to start spinning, but it spins only for a fraction of a section, hangs and then reboots. So I am basically up the river without a paddle. Any suggestions?


  2. Sydney99

    Sydney99 Well-Known Member

    You're in a boot loop old boy. Easily done......I say that from bitter experience this week.

    There is an excellent guide on xda that walks you through what to do: http://forum.xda-developers.com/showthread.php?p=41072377.

    Scroll down a few paragraphs and it'll tell you the steps to take.

    Ultimately you may well need to wipe cache/dalvik, do factory reset, and flash stock firmware through Odin, that fixes most things, but follow his steps first ;)
  3. ironass

    ironass Well-Known Member

    Hello and welcome to Android Forums rzkman! :)

    Sorry to learn about your problems with Omega ROM. You do seem to have got yourself into a right pickle with it.

    My suggestion would be to cut your losses now and stop trying to get it to work by more flashing.

    Providing that you have not ever been on a stock Samsung firmware with Knox security and a locked bootloader, (firmwares MGG onwards), I would suggest backing everything up and flashing the pre MGG, unlocked, stock Samsung firmware for your phone via Odin after first doing a Factory Reset. This will at least give you a stable base to re-download your apps, not settings, and you can the re-root by following the steps in the Rooting Galaxy S4 - Dummies Guide. You can then decide if you want to flash Omega again or try one of the other ROMs mentioned in the guide.

    EDIT Ninja'd by Syd! Try his suggestion first as I adopt the, "kill or cure", approach in situations such as yours.
    rzkman likes this.
  4. rzkman

    rzkman New Member

    Thank you so much Sydney and Ironass for your prompt and helpful replies, and thanks for the welcome IA. Happy chappy tonight with the phone booting back to a stock ROM. Will probably do a bit more reading before venturing off to my next ROM. Much appreciated, Ray.
  5. Sydney99

    Sydney99 Well-Known Member

    Glad you're back in business

Share This Page